FORUMS
Remove All Ads from XDA

[ROM][I317/t0lteatt][lollipop/5.1.1][UNOFFICIAL]Dirty Unicorns v9.4(07/18/2015)

1,138 posts
Thanks Meter: 1,458
 
By AzraelsKiss, Senior Member on 29th December 2014, 12:51 AM
Thread Closed Email Thread
Here it is... The unofficial build of Dirty Unicorns v9, built specifically for our at&t I317 Samsung Galaxy Note II devices (although this should work with other GSM Note II devices as well). Dirty Unicorns v9 is a work-in-progress build of android 5 lollipop, and as such is continuously receiving updates to add new features, fix bugs and improve performance. Also, being a WIP custom ROM, you should be warned that there could be the random, occasional bug, and Dirty Unicorns and I are not responsible if your device explodes and destroys your whole neighborhood. Just thought you should know. If you do happen to find a ROM related bug, go ahead and let us know by posting in this thread. This is an unofficial build, and as such, is not the responsibility of Dirty Unicorns' devs, so if you do not post your issue here, you'll likely not receive proper assistance. In other words... Do not post issues in the Dirty Unicorns G+ group. Thank you.

Known Issues:
  • Youtube (maybe others?) video rendering issues in Chrome. (Videos may not look right...Videos go black in fullscreen and may even cause the device to reboot.)
  • Snapchat and other social networks/media sharing apps are having camera and media uploading issues.
  • Bluetooth issues are possible on almost all custom Lollipop ROMs for t0lte based devices.
  • Voice search or commands in Google Now do not work over bluetooth, including voice dialing. You may need to find a 3rd party app if you need these features over bluetooth.
  • SELINUX defaults to enforced. If you use bluetooth devices, you will need to set SELINUX to permissive, because bluetooth will not work with SELINUX enforced at this time.
    • Settings > Dirty Tweaks > General UI > Misc. Tweaks > Selinux Mode > Permissive
  • Cellular dropouts are possible while connected to wifi. If they get to be too excessive, please try the following:
    1. Delete all APNs except for the appropriate one for your carrier (ATT Nextgenphone works best for me on at&t)
    2. With wifi off, tap on Network Operators under Cellular Networks (tap OK through the warning about the data connection being interrupted)
    3. Allow the system to search for available network operators (takes like a minute or less) then either select your carrier, or let the system automatically choose
    4. Once your cellular connection reconnects to your carrier, reboot your phone (sometimes it may take a couple of reboots)
    5. Your preferred network type should stay LTE and SIM status under About Phone should show LTE for the Cellular network type (unless you don't have LTE service)
    6. Profit

Installation Instructions:
  1. Download ROM here: Dirty Unicorns 5
  2. Download GAPPS here: DU TBO GAPPS or BaNkS GAPPS
  3. Reboot into recovery (The latest version of TWRP is recommended).
  4. Full wipe: Wipe cache, dalvik, wipe data/factory reset, clean to install new rom, format system. (If you insist on dirty flashing and end up having any issues, please do not report these issues. Do a clean flash first, and only report issues that exist after a clean flash.)
  5. Flash ROM downloaded above.
  6. Flash GAPPS downloaded above.
  7. Reboot into system.
  8. Let the system rest for a bit to connect to the cellular network and get everything squared away before initial setup.
  9. A few reboots will more than likely be necessary to work out all the kinks.
  10. Enjoy the lollipop sweetness.

btw... If you remove the keep awake permission from Google Play Service or other Google apps as per some suggestions to help improve battery life, you'll likely find that music will stutter after the screen turns off. Removing the keep awake permission from any essential Google app is not recommended.

I would like to thank the following who made this build possible:
sbrissen, DerTuefel1980 and all other contributors who were able to get the t0lte device tree updated for and running lollipop.
mr.nth.na.vn for his work-around to get sbrissen's i605 CM12 build to work correctly on t0lte and his continuing development for t0lte since.
Voyebanm for his posts and links which helped me to find the answers I needed.
fkfmfz for his gps fix that I have baked into the ROM and miji2 for cleaning up the fix.
ctludlow for the Chrome glitching fix. http://forum.xda-developers.com/show...&postcount=244 (No longer needed.)
wilson3q and rogersb11 for all that y'all do to keep t0lte development alive.

For more information about Dirty Unicorns, please visit the following links:
Dirty Unicorns Google+ Community: https://plus.google.com/communities/...28866939227235
Dirty Unicorns Source: https://github.com/DirtyUnicorns
Official t0lteatt Dirty Unicorns XDA forum by jmz: http://forum.xda-developers.com/show....php?t=2640856

https://github.com/AzraelsKiss

Have a good one!
The Following 17 Users Say Thank You to AzraelsKiss For This Useful Post: [ View ] Gift AzraelsKiss Ad-Free
 
 
29th December 2014, 01:06 AM |#2  
AzraelsKiss's Avatar
OP Senior Member
Flag Owenton, KY
Thanks Meter: 1,458
 
Donate to Me
More
Changes
7/18/2015
  • Expanded desktop
  • Added long click options to QS tiles
  • Navbar arrows
  • Volume steps
  • Background updates

7/2/2015
  • SELINUX enforced by default
  • SELINUX switch
  • cLock changes
  • Powermenu torch option
  • Screen pinning improvements
  • Lockscreen weather
  • Storage notification enhancement
  • NavBar tile
  • SlimPie tile
  • New hardware button disabler
  • DU Tweaks menu changes
  • NavBar custom icon fixes

6/26/2015
  • 5.1.1_r5
  • Navbar changes
  • Slim Pie
  • National data roaming settings
  • Background updates

6/19/2015
  • Breathing notifications
  • Slim recents
  • Option to disable torch when screen turns off
  • Option to launch default music player when headphones are plugged in

Older changes:

6/11/2015
  • More background updates
  • Dirty Unicorns v9.4

6/9/2015
  • Background updates
  • Design updates
  • Omniswitch updates
  • Pin keypad shuffler

6/2/2015
  • Slim Privacy Guard added
  • Option to unlink ringer/notification volumes
  • NFC QS tile
  • Notification ticker
  • Compass QS tile
  • ADB over network QS tile
  • Increasing ring
  • Removed whitelist from HFM

5/27/2015
  • Task Manager added
  • Headset plugged in notification is now optional
  • Lockscreen shortcuts can be disabled
  • Fixed In-call Volume (?)
  • Background updates

5/20/2015
  • 5.1.1_r3

5/19/2015
  • AOKP custom system animations
  • Custom hardware key disabler
  • Yet even more background updates

5/12/2015
  • 5.1.1_r2
  • Fixed mute button while in call
  • Wakelock Blocker
  • Add Whitelist to HFM
  • Option to swap volume buttons when screen is rotated

5/07/2015
  • Add Music Tile
  • Force Expanded Notifications
  • Background updates

5/01/2015
  • Customize backlight for capacitive buttons
  • Add USB Tether tile in QS

4/27/2015
  • v9.3 again
  • Fixed theme related FCs

4/22/2015 (It's not a downgrade. The devs chose to correct the version number back to 9.2 until they decide the 5.1 builds can be considered stable)
  • 5.1.1_r1
  • Even more background updates

4/20/2015
  • NTFS support added
  • More background updates

4/19/2015
  • 5.1.0_r5
  • Background updates

4/14/2015
  • Upgraded to lollipop 5.1.0_r3

4/10/2015
  • Background updates

3/28/2015
  • Updated RIL (This seems to have stabilized the cellular connections a bit. I don't have the cellular service dropouts after every call like before, but cell service will still occasionally do a quick reset after a call.)
  • System apps can be adjusted in App Ops

3/20/2015
  • Added whitelist options for ad blocker

3/12/2015
  • Updated to v9.2
  • DU Updater (Doesn't work with t0lteatt, because there are no official builds for t0lte or t0lteatt at this time)
  • Lots of theme edits

3/6/2015
  • More QS tiles
  • User configurable lockscreen shortcuts

2/27/2015
  • Even more QS tiles added
  • Lockdown power menu option
  • Double tap to sleep on nav bar
  • Volume rocker music controls
  • Left clock added
  • Carrier label options
  • SuperSU v2.46
  • Change location modes in QS
  • Front camera HD capable
  • Ambient display (I've personally only found benefit with pocket mode, so let me know what you think about it... Also, let me know if this fouls up the proximity sensor... My i317 currently doesn't have service, so I can't test it on calls, but the last time I tried to add ambient display to the build, the screen would only dim when proximity was active, rather than turn completely off.)


2/20/2015
  • More QS tiles added
  • Nav bar ring options
  • Four tiles per QS rom
  • Behind the scenes tweaks

2/11/2015
  • Netflix may work
  • Set SELinux to permissive again

2/9/2015
  • v9.1
  • Apollo ain't orange no more
  • Hopefully fixed rebooting issue some were having.

2/5/2015
  • Expandable Volume Control
  • More NavBar Customization

2/2/2015
  • Notification and Battery LED Customization
  • NavBar Customization

1/29/2015
  • Apollo
  • Option to disable alarm icon in status bar

1/26/2015
  • Headsup
  • Lockscreen shortcut options
  • CM12 Theme Engine
  • Allow disabling FC dialogs
  • SuperSU v2.45
  • Powermenu screenshot delay options
  • Calendar widget
  • Quick settings customization

1/13/2015
  • Add weather to status bar header
  • Add cLock widget

1/10/2015
  • Switch to disable home button wake
  • Screen record in power menu
  • DU blackout keyboard option
  • Recents changes
  • Density changer

1/8/2015
  • Home button wakes device
  • Power menu options
  • Smart pulldown
  • Clock fixes
  • Change battery saver color

1/6/2015
  • Gesture anywhere
  • App circle sidebar
  • Battery bar
  • Camera sound toggle
  • Battery icon options
  • Battery text mode

1/3/2015
  • Statusbar brightness control
  • Clock and date customization
  • Quick settings quick pulldown
  • Disable search bar in recents
  • Configure screen rotation
  • Ad-blocker FC fixed
  • Double tap to sleep

12/31/2014
  • Custom actions for hardware buttons.
  • Charging during power off.
  • Other, behind the scenes changes.


Have a good one!
The Following 4 Users Say Thank You to AzraelsKiss For This Useful Post: [ View ] Gift AzraelsKiss Ad-Free
29th December 2014, 02:47 AM |#3  
AzraelsKiss's Avatar
OP Senior Member
Flag Owenton, KY
Thanks Meter: 1,458
 
Donate to Me
More
Prompt How to build Dirty Unicorns
I personally use LMDE 2 "Betsy" for my build rig, but I would recommend Ubuntu 14.04 LTS because it's stable, it has a large installed base and it's a long term support release. Either way, these instructions should be nearly the same. If installing within VirtualBox (or VMware, because the process would be quite similar), make sure to select Linux as the type and Debian (64 bit), or Ubuntu (64 bit) for Ubuntu 14.04 LTS, as the version. You will also want to set the memory size to at least 4 GB, but if you have more than 8 GB of physical RAM, I would recommend a setting of half your physical RAM (i.e. if your system has 16 GB of physical RAM, set your virtual machine to use 8 GB). Finally, make sure you have at least 150 GB available on the hard drive (I tried to use 100 GB once, but there wasn't quite enough room to hold all the source files and all the build files while compiling). If you just can't spare the HDD space, you'll have to find unsupported ways to limit the necessary space for source files on your own.

Install the JDK

Lollipop requires Java 7 to build, so we need to install the proper JDK:
Code:
$ sudo apt-get update
$ sudo apt-get install openjdk-7-jdk
Install the required packages

Ubuntu doesn't preinstall all the packages we need, so we'll do that now:
Code:
$ sudo apt-get install git gnupg flex bison gperf build-essential zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 libgl1-mesa-dev g++-multilib mingw32 tofrodos python-markdown libxml2-utils xsltproc zlib1g-dev:i386
$ sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib/i386-linux-gnu/libGL.so
Make the required directories

There are two directories we need to make for the build environment:
Code:
$ mkdir -p ~/bin
$ mkdir -p ~/du
Add bin to PATH

Make sure ~/bin is added to PATH:
Code:
$ PATH=~/bin:$PATH
Get repo tool

We need to download and make executable the repo tool:
Code:
$ curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ~/bin/repo
$ chmod a+x ~/bin/repo
Configure git

This is where we add our information to git:
Code:
$ git config --global user.email "[email protected]"
$ git config --global user.name "Your Name"
$ git config --global gerrit.dirtyunicorns.com.username "username used on gerrit.dirtyunicorns.com"
$ git config --global gerrit.dirtyunicorns.com.email "email address used on gerrit.dirtyunicorns.com""
$ ssh-keygen -t rsa -C "[email protected]"
Now you will need to add your SSH public key to http://gerrit.dirtyunicorns.com/ so that you can submit patches in the future.

Get the code

First, we need to download the SDK from http://developer.android.com/sdk/index.html
Extract the SDK into your home directory and rename it android-sdk
Add the following to the bottom of your .bashrc file:
Code:
# Android tools
export PATH=${PATH}:~/android-sdk/tools
export PATH=${PATH}:~/android-sdk/platform-tools
export PATH=${PATH}:~/bin
Add the following to the bottom of your .profile file:
Code:
PATH="$HOME/android-sdk/tools:$HOME/android-sdk/platform-tools:$PATH"
Then type the following within terminal:
Code:
$ android
Make sure Updates/New and Installed are ticked and click the install button.

Now we need to initialize the Dirty Unicorn repository.
Change the directory to the du directory:
Code:
$ cd ~/du
Nexus devices will need:
Code:
$ repo init -u https://github.com/DirtyUnicorns/android_manifest.git -b lollipop
Non-nexus devices will need:
Code:
$ repo init -u https://github.com/DirtyUnicorns/android_manifest.git -b lollipop-caf
Finally we download the source code:
Code:
$ repo sync
Setting up ccache

ccache will allow future builds to process faster:
Code:
$ echo "export USE_CCACHE=1" >> ~/.bashrc
$ ~/du/prebuilts/misc/linux-x86/ccache/ccache -M 25G
You should make your ccache at least 10G, but a little more won't hurt and if you build for more than one device, you'll definitely need more.

Building the ROM

These are the commands you will enter every time you wish to build. These commands will update the code, ready the build and finally start the build:
Code:
$ repo sync
$ . build/envsetup.sh
$ lunch (Pick your device from the list)
$ make -j? bacon
Replace ? with how ever many threads your processor is capable of processing at once +1 (i.e. Intel Core i7 Quad has 4 cores with hyperthreading allowing 2 threads per core, or 8 simultanious threads, so you would use make -j9 bacon. This allows all 8 virtual cores to be used plus one queued thread, ready for processing.)

If everything goes okay, the build will successfully complete and the final zip will be located at ~/du/out/target/product/<device>/DU_<device>_<android version>_<date>-<time>.<DU version>-UNOFFICIAL.zip ready for flashing. If something goes wrong, the build will error out with an error message that hopefully helps you figure out what went wrong, so that you may fix it and try again.

Finally, you'll want to use the commands make clean or make clobber every once in a while before or after you build to clean up your build environment. This will clean up the various build files that are created during the build process. Using make clean or make clobber is similar in nature to doing a clean flash over a dirty flash... Although the build times are faster if you don't do a make clean or make clobber before the build, there's a chance that an old file may gum up the works when it's not replaced by a newer version when necessary. I've gotten into the habit of using make clobber after a build and make clean before, but I tend to like redundancy. Also... Because these commands will delete the entire contents of the out directory, including the zip file you just created, don't issue the commands until after you've copied the ROM zip to another location, such as your device.

If your device is not listed in the lunch menu, you will need to port DU for your ROM with a compatible device tree. A simple Google search should be able to help get you started. You may also find someone to assist you in the DU G+ community, but you should at least take the initiative to try to figure some things out on your own and have your device tree started before enlisting their assistance.

Further information:
https://github.com/DirtyUnicorns/android_manifest
https://source.android.com/source/initializing.html
http://docs.omnirom.org/Setting_Up_A...le_Environment
https://plus.google.com/communities/...28866939227235
The Following 4 Users Say Thank You to AzraelsKiss For This Useful Post: [ View ] Gift AzraelsKiss Ad-Free
29th December 2014, 04:13 AM |#4  
Senior Member
Thanks Meter: 1,144
 
Donate to Me
More
Will you update op page once compiled and uploaded please.

Sent from my SAMSUNG-SGH-I317 using Tapatalk
29th December 2014, 04:32 AM |#5  
AzraelsKiss's Avatar
OP Senior Member
Flag Owenton, KY
Thanks Meter: 1,458
 
Donate to Me
More
Quote:
Originally Posted by rob_z11

Will you update op page once compiled and uploaded please.

Sent from my SAMSUNG-SGH-I317 using Tapatalk

It won't be ready until tomorrow. My internet is being temperamental right now.

Have a good one!
The Following User Says Thank You to AzraelsKiss For This Useful Post: [ View ] Gift AzraelsKiss Ad-Free
30th December 2014, 05:42 AM |#6  
chopt51's Avatar
Senior Member
Thanks Meter: 355
 
More
Good job. I have it going on Verizon i605 but not releasing yet. I don't like the all white UI with my burned in screen

Sent from my Galaxy Note ll
31st December 2014, 12:15 AM |#7  
AzraelsKiss's Avatar
OP Senior Member
Flag Owenton, KY
Thanks Meter: 1,458
 
Donate to Me
More
Update!
New build available for download. https://www.androidfilehost.com/?fid=95864024717072713

Before you ask... No... Netflix doesn't work. Also... You can try dirty flashing, but if you have any issues, please do a clean flash before reporting them.

Have a good one!
The Following User Says Thank You to AzraelsKiss For This Useful Post: [ View ] Gift AzraelsKiss Ad-Free
31st December 2014, 05:28 AM |#8  
AzraelsKiss's Avatar
OP Senior Member
Flag Owenton, KY
Thanks Meter: 1,458
 
Donate to Me
More
Thumbs up Finally!
After numerous missteps in tying to upload an updated build, I was finally successful. W00H00!!! lol Anyone who may have been unlucky enough to have downloaded any builds from earlier today, I would recommend downloading and installing the current build. If, somehow, you were able to install one of those builds and boot into the system, you may only need to dirty flash the newest build. Otherwise... A clean flash is recommended, but, of course, isn't always necessary. As explained in post #2, this build adds the settings in Dirty Tweaks to customize the hardware buttons behavior and allows charging while the phone is off.

Have a good one!
31st December 2014, 08:45 PM |#9  
rhaneyjr's Avatar
Senior Member
Flag Visalia
Thanks Meter: 317
 
More
Whooooo hoooo! So glad gonna flash this right after work

Sent from my GT-N7105 using Xparent Cyan Tapatalk 2
31st December 2014, 09:13 PM |#10  
xsleazoidx's Avatar
Senior Member
Thanks Meter: 27
 
More
I tried to log into Google countless times, but it would not let me. Has this problem been fixed
31st December 2014, 09:23 PM |#11  
AzraelsKiss's Avatar
OP Senior Member
Flag Owenton, KY
Thanks Meter: 1,458
 
Donate to Me
More
Quote:
Originally Posted by xsleazoidx

I tried to log into Google countless times, but it would not let me. Has this problem been fixed

Default browser won't login. Chrome works though, but it's a little glitchy.

Have a good one!
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes