FORUMS
Remove All Ads from XDA

[Direct Download] Latest Bootloaders & Modems

1,491 posts
Thanks Meter: 6,162
 
Post Reply Email Thread
5th December 2015, 07:22 PM |#11  
HazeMC's Avatar
Member
Flag HIdalgo
Thanks Meter: 6
 
More
5.1.1 BL and CP?
I using N900W8 (hltcan) on 5.1.1 and im facing some Camera issues, some memers suggested me to update my BL.

This is my BL and CP version; n900w8UBUCNH1

im trying to flash OK6 BL and CP but odin fails every time (FAILED! auth)
(Does OK6 is a newer version? maybe thats the problem)
I've already disabled Device manager, remote controls and reactivation lock.

This:
BL UBU2DOI2
CP UBU2DOE4

are a newer version than UBUCNH1? do they work on 5.1.1?

thanks in advance!
 
 
6th December 2015, 03:09 AM |#12  
jcadduono's Avatar
OP Recognized Developer
Flag Thunder Bay
Thanks Meter: 6,162
 
Donate to Me
More
Quote:
Originally Posted by HazeMC

I using N900W8 (hltcan) on 5.1.1 and im facing some Camera issues, some memers suggested me to update my BL.

This is my BL and CP version; n900w8UBUCNH1

im trying to flash OK6 BL and CP but odin fails every time (FAILED! auth)
(Does OK6 is a newer version? maybe thats the problem)
I've already disabled Device manager, remote controls and reactivation lock.

This:
BL UBU2DOI2
CP UBU2DOE4

are a newer version than UBUCNH1? do they work on 5.1.1?

thanks in advance!

yes those are the ones you should flash if you want to update. for N900W8, CNxx is KitKat (4.4), 2DOxx is Lollipop (5.0)
OK6 is for international/N9005XX models only, which is why it failed auth, and good thing it does or you'd have bricked your phone!
your camera issues are more likely related to incompatible kernel and proprietary .so files (they need to match up)

these are a few possible paths that commands can take to the hardware, sorted by most common to least common AFAIK:
1. android -> translation layer & extra functions libraries (proprietary .so files) -> kernel -> hardware
2. android -> kernel -> hardware
3. android -> translation layer & extra functions libraries (proprietary .so files) -> kernel -> firmware -> hardware
4. android -> kernel -> firmware -> hardware

see the firmware stage of communication. sometimes this firmware is included as part of the kernel, and the respective kernel drivers will flash the firmware for you if it needs updating. sometimes, very rarely, the firmware will be part of the modem or bootloader binaries instead of flashed from kernel. this is a situation where updating bootloader/modem could potentially help.

this is only from reading lots of samsung kernel sources, so some of it is only assumed. i can't know everything.
if anyone wants to share more accurate information than what i can provide, we would all be thankful!
The Following 2 Users Say Thank You to jcadduono For This Useful Post: [ View ]
6th December 2015, 02:50 PM |#13  
Member
Thanks Meter: 4
 
More
Whats the lastest bootloader and modem for sm-n9005
im using cm13
now i have
CP_N9005XXUGPOF3.tar.md5
BL_N9005XXUGPOF3.tar.md5
7th December 2015, 03:36 AM |#14  
jcadduono's Avatar
OP Recognized Developer
Flag Thunder Bay
Thanks Meter: 6,162
 
Donate to Me
More
Quote:
Originally Posted by sajmon1983

Whats the lastest bootloader and modem for sm-n9005
im using cm13
now i have
CP_N9005XXUGPOF3.tar.md5
BL_N9005XXUGPOF3.tar.md5

For N9005XX, OK6 is the latest bootloader, OJ1 is the latest modem. XXUGP series is specific to Nordic regions like Finland, Sweden, etc. only as far as I can tell.
There's probably no difference in bootloader and modem code between the XXUGB and XXUGP series.
In any case, OI2 is the latest bootloader and modem for the N9005XXUGP Nordic firmware. I will add it to the mirror soon. (it's added now)
The Following 3 Users Say Thank You to jcadduono For This Useful Post: [ View ]
7th December 2015, 09:59 AM |#15  
Senior Member
Thanks Meter: 65
 
More
is there any reason to update to the latest bootloader/modem?
(I use XSP firmware. haven't been able to find or make my own BL or CP files)
The Following User Says Thank You to wilflare For This Useful Post: [ View ] Gift wilflare Ad-Free
7th December 2015, 01:09 PM |#16  
PlutoDelic's Avatar
Senior Member
Flag Prishtina
Thanks Meter: 473
 
More
Quote:
Originally Posted by jcadduono

For N9005XX, OK6 is the latest bootloader, OJ1 is the latest modem. XXUGP series is specific to Nordic regions like Finland, Sweden, etc. only as far as I can tell.
There's probably no difference in bootloader and modem code between the XXUGB and XXUGP series.
In any case, OI2 is the latest bootloader and modem for the N9005XXUGP Nordic firmware. I will add it to the mirror soon. (it's added now)

I cant find the link for the differences, but apparently they do actually differ, if i'm not wrong, it has something to do with a different development tree. People have reported issues flashing non-nordic roms after the nordic ones itself, but only when the values change.
7th December 2015, 05:52 PM |#17  
HazeMC's Avatar
Member
Flag HIdalgo
Thanks Meter: 6
 
More
Quote:
Originally Posted by jcadduono

yes those are the ones you should flash if you want to update. for N900W8, CNxx is KitKat (4.4), 2DOxx is Lollipop (5.0)
OK6 is for international/N9005XX models only, which is why it failed auth, and good thing it does or you'd have bricked your phone!
your camera issues are more likely related to incompatible kernel and proprietary .so files (they need to match up)

these are a few possible paths that commands can take to the hardware, sorted by most common to least common AFAIK:
1. android -> translation layer & extra functions libraries (proprietary .so files) -> kernel -> hardware
2. android -> kernel -> hardware
3. android -> translation layer & extra functions libraries (proprietary .so files) -> kernel -> firmware -> hardware
4. android -> kernel -> firmware -> hardware

see the firmware stage of communication. sometimes this firmware is included as part of the kernel, and the respective kernel drivers will flash the firmware for you if it needs updating. sometimes, very rarely, the firmware will be part of the modem or bootloader binaries instead of flashed from kernel. this is a situation where updating bootloader/modem could potentially help.

this is only from reading lots of samsung kernel sources, so some of it is only assumed. i can't know everything.
if anyone wants to share more accurate information than what i can provide, we would all be thankful!

Thanks for a very complete response!

I've realised that the front camera has the same issue recording video, so as far i understand you response, i will try to update the kernel, or try a different rom.

Thanks mate.
9th December 2015, 06:40 PM |#18  
jorioux's Avatar
Junior Member
Flag Montreal
Thanks Meter: 3
 
More
I flashed AP_N900W8VLU2DOH1_KERNEL.tar.md5 using Odin, on my N900W8, and when it reboot it get stuck and wont boot into the ROM. What is wrong?
9th December 2015, 07:17 PM |#19  
mahsel71's Avatar
Member
Flag Elazığ
Thanks Meter: 14
 
More
yes ok
10th December 2015, 06:04 PM |#20  
HazeMC's Avatar
Member
Flag HIdalgo
Thanks Meter: 6
 
More
Quote:
Originally Posted by jorioux

I flashed AP_N900W8VLU2DOH1_KERNEL.tar.md5 using Odin, on my N900W8, and when it reboot it get stuck and wont boot into the ROM. What is wrong?

If you are on 5.0 LL you have to use DOI2
11th December 2015, 02:24 PM |#21  
jcadduono's Avatar
OP Recognized Developer
Flag Thunder Bay
Thanks Meter: 6,162
 
Donate to Me
More
Quote:
Originally Posted by jorioux

I flashed AP_N900W8VLU2DOH1_KERNEL.tar.md5 using Odin, on my N900W8, and when it reboot it get stuck and wont boot into the ROM. What is wrong?

The kernel is SELinux Enforcing, so if you flash DOH1 kernel on a non-DOH1 rom then there's a high chance it won't boot. (policy does not match rom) I provide kernels in the case someone flashes a custom kernel on their stock rom, but wants to return to stock kernel later on.
Post Reply Subscribe to Thread

Tags
firmware, latest, note 3, odin, stock

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes