Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[Q] GPS Problems

1,872 posts
Thanks Meter: 259
By brando56894, Senior Member on 26th August 2014, 04:24 PM
Post Reply Email Thread
Edit: I actually just though of something, I updated to NF1 about 2 or 3 weeks ago and the problem started happening within the past few weeks. Does the baseband control the GPS radio also?

I know this is a problem with the Note 3 across all carriers, but it also seems to be a stock software issue. I'm on an AOSP ROM so none of that really helps me. GPS will lock on to my current location, but it won't "follow" me and it loses it's connection after about a minute and then it will sporadically update my location. I noticed this for the first time last week (I've had the phone since April/May and it has worked fine up until now) when I was trying to use Maps to get to a town a half hour away. I would open Maps and it would find my exact location and give me point to point directions but before I even moved it would say "GPS Signal Lost" and wouldn't reconnect. After about 3 or 4 reboots I finally got it to lock on and follow me. One the way back I could get it to follow me at all.

I recently started playing Ingress since I work in NYC and live right outside of it so there are a ton of players, the problem is that the stupid map won't update my location so the marker usually just stays in the same location, but will spin around depending on which way I turn. It will also occasionally update my location, for example, on Sunday I was able to play for 2.5 hours because it would actually follow me for a good amount of the time, at about the 2.5 hour mark it pretty much stopped updating. I had walked 3 blocks from where it shows me at that point I got frustrated and went home. During my time where it actually "worked" it wouldn't be that accurate, I know GPS isn't accurate down to the exact foot/inch but this would be pretty far off. I'd be standing next to portal (shown by the picture) and it would say that it was 50 or 100 meters away!

I tried to play yesterday in NYC and it wouldn't even follow me at all over the course of about 5 blocks! I got frustrated and stopped playing the game. During this time I had flashed two different AOSP ROMs and neither have fixed the issue.

GPS Status shows all the correct info, except for "waiting for GPS location....". I saw that someone mentioned checking/bending the GPS contacts but I'm not sure which ones they are and don't want to screw anything up.

Does anyone else have these issues on AOSP ROMs and if so, did you manage to fix them?

I'm currently running:
C-ROM Kang v1.6 20140816
Kernel Version: 3.4.0-gd84d543
Baseband: N900TUVUDNF1
Post Reply Subscribe to Thread

aosp, gps, kitkat, note 3

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes