FORUMS
Remove All Ads from XDA

App permission monitor stating the obvious on SMS?

1,520 posts
Thanks Meter: 368
 
Post Reply Email Thread
Has anyone seen this App permission monitor pop up while doing something completely normal and keep letting you know every time you use it? For me, I'm using Google Messages as my default SMS app, and this thing pops up telling me "1 apps have been detected using 1 permissions" and lists Messages | SMS.

OBVIOUSLY.

What's even stranger is that I went to app permissions and it says that Messages is authorized for SMS, just like I okay'd it when Messages was set as the default SMS app. What gives? I think this might come in handy when an app goes rogue, using permissions without me saying it was okay to do so, but in this case, it's like saying "water is wet." When you click on the notification, it says that Messages has been using permissions in the background.... What?

Any thoughts on how to okay this with App permission monitor so I can text without this warning all the time (and no, I'm not about to hide notifications of it since it could be helpful in the future).
 
 
10th September 2017, 06:02 AM |#2  
foulmouthedruffian's Avatar
Senior Member
Flag Texas
Thanks Meter: 55
 
More
Go into Settings > Lock Screen and Security > App Permissions Monitor and turn it off.

Sent from my SM-N950U
The Following User Says Thank You to foulmouthedruffian For This Useful Post: [ View ] Gift foulmouthedruffian Ad-Free
10th September 2017, 06:16 AM |#3  
KryptosXLayer2's Avatar
OP Senior Member
Flag Charlotte, NC
Thanks Meter: 368
 
Donate to Me
More
Quote:
Originally Posted by foulmouthedruffian

Go into Settings > Lock Screen and Security > App Permissions Monitor and turn it off.

Not helpful. Please read what I wrote again. I think the app could possibly be useful, but it just needs to be corrected.
10th September 2017, 08:21 PM |#4  
hungmung's Avatar
Senior Member
Flag Addison, il
Thanks Meter: 203
 
More
You can actually go in and tell it to not report permission uses for specific apps instead of turning it off completely. Instead of clicking the rifle just click on the words so permission monitor and it'll give the full list of apps and you can shut off reporting for apps you trust.
The Following 3 Users Say Thank You to hungmung For This Useful Post: [ View ] Gift hungmung Ad-Free
11th September 2017, 01:25 AM |#5  
KryptosXLayer2's Avatar
OP Senior Member
Flag Charlotte, NC
Thanks Meter: 368
 
Donate to Me
More
Quote:
Originally Posted by hungmung

You can actually go in and tell it to not report permission uses for specific apps instead of turning it off completely. Instead of clicking the rifle just click on the words so permission monitor and it'll give the full list of apps and you can shut off reporting for apps you trust.

THANK YOU. This is what I was looking for. I didn't know what you were referring to at first, I was just getting the notification because I didn't see it in Settings (there is so much stuff in there now, you just about have to use the search feature for everything these days!), but now that I found it, I clicked on the words, not the toggle switch, and set Messages to NOT monitor. Perfect, thank you.
29th September 2017, 08:19 PM |#6  
Junior Member
Thanks Meter: 0
 
More
I am kind of confused. What did you search to make it go away? This is getting so annoying because it is always telling me textra is using SMS and I am not sure what to do to make it stop. Like you I would still like to keep the monitor on I just wish it would stop telling me what I already know.
15th November 2017, 08:49 PM |#7  
Senior Member
Thanks Meter: 21
 
More
Detailed Process
Quote:
Originally Posted by Mseunice83

I am kind of confused. What did you search to make it go away? This is getting so annoying because it is always telling me textra is using SMS and I am not sure what to do to make it stop. Like you I would still like to keep the monitor on I just wish it would stop telling me what I already know.

I was a little confused as well so this is what I did to correct it.

SETTINGS >> LOCK SCREEN AND SECURITY >> APP PERMISSION MONITOR

From there you should go down to the android Messages app and toggle it to off. That will disable giving the warning every time you send a message.

Hope that helps.
The Following User Says Thank You to This_dude For This Useful Post: [ View ] Gift This_dude Ad-Free
18th January 2018, 07:37 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by KryptosXLayer2

Not helpful. Please read what I wrote again. I think the app could possibly be useful, but it just needs to be corrected.

You do know they legit just told you how to do it.... you dont have to be mean about it. and then stating "THIS" is what im looking for. Like they told you how to get there, you click the name. if you went onto there to just hit the toggle without looking/investigating around, ie. pressing the section instead, then you arent probably getting the most out of your phones.

I suggest playing around in your settings and everything to get the most out of your phone.

I legit just made this account to tell you this because the person helped you and you seemed to speak rude to them.
18th January 2018, 09:23 PM |#9  
KryptosXLayer2's Avatar
OP Senior Member
Flag Charlotte, NC
Thanks Meter: 368
 
Donate to Me
More
Quote:
Originally Posted by whoissouvy

You do know they legit just told you how to do it.... you dont have to be mean about it. and then stating "THIS" is what im looking for. Like they told you how to get there, you click the name. if you went onto there to just hit the toggle without looking/investigating around, ie. pressing the section instead, then you arent probably getting the most out of your phones.

I suggest playing around in your settings and everything to get the most out of your phone.

I legit just made this account to tell you this because the person helped you and you seemed to speak rude to them.

Wow, you "legit" just wasted my time by coming to an out of date thread that the first comment did NOT answer my question. Congratulations. Welcome to XDA.
19th January 2018, 02:07 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by KryptosXLayer2

Not helpful. Please read what I wrote again. I think the app could possibly be useful, but it just needs to be corrected.

Quote:
Originally Posted by KryptosXLayer2

Wow, you "legit" just wasted my time by coming to an out of date thread that the first comment did NOT answer my question. Congratulations. Welcome to XDA.

HA! he did answer it, cause it works for me.
25th January 2018, 08:26 PM |#11  
Junior Member
Flag Salisbury
Thanks Meter: 0
 
More
This is happening on my note 8 as well. Have you been able to fix this? I'm a little worried it could be something malicious using back-end processes, like they programmed the exploit to send SMS messages without involving surface flinger...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes