FORUMS
Remove All Ads from XDA

HP Elite x3 Lapdock w/ Galaxy S10

7 posts
Thanks Meter: 1
 
By Muezick, Junior Member on 8th March 2019, 01:50 AM
Post Reply Email Thread
Hey folks. Figured I'd go ahead and get the ball rolling on this. The note9 folks have have a thread for their note9s, so let's have one for the Galaxy s10.

the x3 elite Lapdock works pretty good with the s10, about as well as folks are reporting it works with the note9.

I'm having basically the same issues as those people over there are

Issues:
-Sound issues
---Built in speakers and headphone jack never work (There are some work-arounds, I need to do more reading) so far only the phone's speakers work, and only when I reboot both phone and lapdock (but don't need to do this every time)
-Trackpad buttons, (No Left or Right click, only tapping works. It's not bad, takes some getting used to. The track pad on this thing was trying to rip apple off and failed and it's really sad because I'm sure it could've been great lol)

Everything else works. This may become my new daily driver. Need to figure out if blue tooth speakers/Samsung Buds will work with this setup, because if they will, the other issues will be non issues.

Remember to record what ever steps you take to fix something as clearly as possible, and remember to note exactly what model of s10 and lapdock you have.

Mine:
Samsung Galaxy s10 Model: SM-G973U 9(US.. T-Mobile Prism White 128GB Pre-order)
HP x3 Elite Lapdock Model: V8H07UTR#ABA


Thanks for Reading
The Following User Says Thank You to Muezick For This Useful Post: [ View ] Gift Muezick Ad-Free
8th March 2019, 09:16 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Your S10 has a Snapdragon right?
8th March 2019, 09:19 PM |#3  
OP Junior Member
Thanks Meter: 1
 
More
Yes it is a Snapdragon s10.

I am returning my dock this morning because spontaneously over night it has decided to stop working at all. I have no idea if this is just the interface between the phone and the lapdock being finicky or if the dock itself has failed. I'm suspecting the latter.

So i'm kind of out of the game for the moment but I'm definitely hoping to encourage more conversation on this.
12th March 2019, 07:18 AM |#4  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Muezick

Yes it is a Snapdragon s10.

I am returning my dock this morning because spontaneously over night it has decided to stop working at all. I have no idea if this is just the interface between the phone and the lapdock being finicky or if the dock itself has failed. I'm suspecting the latter.

So i'm kind of out of the game for the moment but I'm definitely hoping to encourage more conversation on this.

I just bought a HP lapdock with my s10e and the same thing happened on the first day but i figured out that if I change the setting to screen mirroring when I first connect it then back to dex it will connect properly.
The Following User Says Thank You to ByronCole For This Useful Post: [ View ] Gift ByronCole Ad-Free
15th March 2019, 09:32 PM |#5  
ranova's Avatar
Senior Member
Thanks Meter: 249
 
More
Quote:
Originally Posted by Muezick

Yes it is a Snapdragon s10.

I am returning my dock this morning because spontaneously over night it has decided to stop working at all. I have no idea if this is just the interface between the phone and the lapdock being finicky or if the dock itself has failed. I'm suspecting the latter.

So i'm kind of out of the game for the moment but I'm definitely hoping to encourage more conversation on this.

Its a bug. You have to playing some sort of media (music or video) while you plug in your phone. You can stop playback after it launches DeX
20th March 2019, 05:27 AM |#6  
Junior Member
Thanks Meter: 0
 
More
So i get
So I get it synonymous with video in the background not to run. The reaction to the communication is always a little different. Once I was so far as the mekn Smartphone dex has detected, and no hdmi error message is still no image. Do erit I came only once. 'll use another jabel, just use thunderbolt 3 cable
12th June 2019, 01:50 PM |#7  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Mirko2836

So I get it synonymous with video in the background not to run. The reaction to the communication is always a little different. Once I was so far as the mekn Smartphone dex has detected, and no hdmi error message is still no image. Do erit I came only once. 'll use another jabel, just use thunderbolt 3 cable

Hi, did you solve it?
24th October 2019, 02:22 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Flashing
Question
I know the hp x3 elite works for.the galaxy s9 and s8. Would getting the s10 flashed help out??
25th October 2019, 04:12 PM |#9  
Member
Thanks Meter: 11
 
More
I got no problem with the HP elite X3 on my snapdragon S10. I also tried the Dell K17A and everything work perfectly,
26th October 2019, 03:39 AM |#10  
Junior Member
Thanks Meter: 0
 
More
Flashing
How did u get it to work??

I tried hdmi cables, usb cables and nothing is working

---------- Post added at 02:39 AM ---------- Previous post was at 01:53 AM ----------

are you able to use dex on it or do u just mirror the phone.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes