FORUMS
Remove All Ads from XDA

[ROM][5.1] OMNI - i777 [UBER][UNOFFICIAL] beta

985 posts
Thanks Meter: 2,075
 
By cyril279, Recognized Contributor on 4th February 2015, 01:19 PM
Post Reply Email Thread

This firmware:
- Does not include root management (I suggest flashing SuperSU from recovery)
- Installs TWRP as device recovery
- 5.0.x Tested using PA Pico GApps
- 5.1 Tested using BaNkS Gapps via euroskank
or these other minimal GApps (untested)

Known issues:
- No sound during calls until toggle speaker phone
- Time zone bug

Installation notes:
- Do not use Mr.Cook's rom-wipe script; [ here's why ]
- I do NOT recommend dirty-flashing over other i777 firmwares

**Downloads**

I am not a developer, just a builder.
Credit to the Omni team, and to @asimovi, for the i9100/exynos4 source modifications, from which these builds are based.

Happy flashing,
-Cyril

**Source Details**
The Following 15 Users Say Thank You to cyril279 For This Useful Post: [ View ] Gift cyril279 Ad-Free
 
 
4th February 2015, 05:07 PM |#2  
Senior Member
Flag Ahmedabad
Thanks Meter: 45
 
More
So what are the bugs in this rom. Is it same as cyandel?
4th February 2015, 07:58 PM |#3  
cyril279's Avatar
OP Recognized Contributor
Thanks Meter: 2,075
 
More
On this firmware, WIFI works, and mobile data works.

I have not been running this firmware long, so I don't know all of the bugs yet. I am still testing the firmware myself.

I will keep the OP updated as I learn more.

Quote:
Originally Posted by virajjjj

So what are the bugs in this rom. Is it same as cyandel?

The Following 3 Users Say Thank You to cyril279 For This Useful Post: [ View ] Gift cyril279 Ad-Free
7th February 2015, 08:03 PM |#4  
mmystere68's Avatar
Senior Member
Flag Mauritius
Thanks Meter: 33
 
Donate to Me
More
Can you shoot videos??
Is sdcard detected?
8th February 2015, 03:16 AM |#5  
Member
Thanks Meter: 6
 
More
It looks like there's no multi-user support. Or maybe I'm blind and I just can't find it. The other problem I found is that ES File Explorer doesn't work; it crashes and causes the phone to restart. Updating from the Play store doesn't fix it.

Otherwise, it seems to run alright. Wifi is fine, but I don't have a SIM for it.
8th February 2015, 12:16 PM |#6  
cyril279's Avatar
OP Recognized Contributor
Thanks Meter: 2,075
 
More
Quote:
Originally Posted by mmystere68

Can you shoot videos??
Is sdcard detected?

Sdcard is fully functional. When shooting video, the stock camera freezes.
Quote:
Originally Posted by sciguy125

It looks like there's no multi-user support. Or maybe I'm blind and I just can't find it. The other problem I found is that ES File Explorer doesn't work; it crashes and causes the phone to restart. Updating from the Play store doesn't fix it.

Otherwise, it seems to run alright. Wifi is fine, but I don't have a SIM for it.

I intentionally disabled multiuser support. If that's something that you use, I can enable it.

The stock file browser, and solid Explorer both work well on this firmware. I therefore suspect that ES crashes are an app compatibility issue.

SIM card works, I'm daily driving it right now.

I appreciate the feedback.

-Cyril
The Following 4 Users Say Thank You to cyril279 For This Useful Post: [ View ] Gift cyril279 Ad-Free
9th February 2015, 11:50 AM |#7  
Member
Thanks Meter: 27
 
More
Talking it works
thank you for sharing this with us, i have been trying to just see/try android 5.0 on my device and with your rom its working . i didnt fully test everything but overall seems fine to me
The Following User Says Thank You to MONSTERELLEVEN For This Useful Post: [ View ] Gift MONSTERELLEVEN Ad-Free
10th February 2015, 12:54 AM |#8  
cyril279's Avatar
OP Recognized Contributor
Thanks Meter: 2,075
 
More
Quote:
Originally Posted by coolerboyj

I heard there was a bug of the wifi, and that if you power your phone off with the wifi off, it will be stuck in a boot loop.
Is this true?

And secondly, I wanted to know if I could flash another kernel, like Shift....

@coolerboyj, I just tried it. I turned off the wifi, then rebooted, and the device booted into android as expected.

I have not tried shift with Omni 5.0, but it should work well.
The Following 3 Users Say Thank You to cyril279 For This Useful Post: [ View ] Gift cyril279 Ad-Free
12th February 2015, 09:38 AM |#9  
Member
Thanks Meter: 27
 
More
i have had some random reboots and the call bug as you mentioned but other than that all is good. just wondering about any future fixes for the call bug ?
The Following User Says Thank You to MONSTERELLEVEN For This Useful Post: [ View ] Gift MONSTERELLEVEN Ad-Free
12th February 2015, 01:15 PM |#10  
cyril279's Avatar
OP Recognized Contributor
Thanks Meter: 2,075
 
More
Quote:
Originally Posted by MONSTERELLEVEN

[...] just wondering about any future fixes for the call bug ?

...I sure hope so. This is where you can all help me out. If you notice that another 5.0 firmware (for i777 or i9100) doesn't have the call bug, let me know, and I will look into what fixes they applied, and attempt to apply them to OMNI.

-Cyril
The Following User Says Thank You to cyril279 For This Useful Post: [ View ] Gift cyril279 Ad-Free
12th February 2015, 01:23 PM |#11  
Member
Thanks Meter: 27
 
More
Quote:
Originally Posted by cyril279

...I sure hope so. This is where you can all help me out. If you notice that another 5.0 firmware (for i777 or i9100) doesn't have the call bug, let me know, and I will look into what fixes they applied, and attempt to apply them to OMNI.

-Cyril

yeah, absolutely hope soon it would be fixed as its pretty hard to go back to kk after trying lollipop
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes