Remove All Ads from XDA
Honor 9 Lite

External SD Card read/write

159 posts
Thanks Meter: 10
By safeelhd2, Senior Member on 27th January 2012, 12:53 PM
Post Reply Email Thread

i recently got a 16gb Sandisk Class 10 SDHC card from and have noticed that in certain tests, (antutu benchmark and SD Tools) i cannot get a red/write speed for the external SD, so i tried to move a file with root explorer from internal to External SD and it says "Cannot move file"

Can anybody think what this might be?

I had an 8gb card previously and that worked fine, then i flashed an ICS Rom and it was still working fine for a couple of weeks, now i put the 16gb card in and it doesnt seem to show any figures, its as though the card doesnt exist.

I can however see all the pics off the card in the Gallery and see all the contents in file explorer so it looks like the phone is reading the card fine but writing is another issue.

any ideas guys?

EDIT: I have downloaded a couple more apps, SD Maid and SDCardTester, both show me permissions errors when trying to test the External SD. Could a CWM "Fix Permissions" fix this? What exactly does that feature of CWM do?

EDIT 2: Tried the fix permissions thing, didnt work. Still got the problem.
27th January 2012, 03:17 PM |#2  
OP Senior Member
Flag Bradford
Thanks Meter: 10

This issue has now been fixed thanks to a member called "try" over in the ICS rom forum. Heres how to do it.

Edit platform.xml located in /system/etc/permissions/ using ADB or Root Explorer. Under WRITE_EXTERNAL_STORAGE add <group gid="media_rw" /> so it would look like this...

<permission name="android.permission.WRITE_EXTERNAL_STORAGE">
<group gid="sdcard_rw" />
<group gid="media_rw" />

Make sure you make a copy of the file just incase, once the above edit has been done and saved, reboot the phone and Voila!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes