FORUMS
Remove All Ads from XDA

[ROM][I9100][UNOFFICIAL][8.0.0] LineageOS 15.0 [WIP][UNSTABLE][ALPHA]

272 posts
Thanks Meter: 1,851
 
By rINanDO, Senior Member on 17th September 2017, 08:08 PM
Post Reply Email Thread
Code:
/*
** Your warranty is now void.
**
** We are not responsible for bricked devices, dead SD cards,
** thermonuclear war, or you getting fired because the alarm app failed. Please
** do some research if you have any concerns about features included in this ROM
** before flashing it! YOU are choosing to make these modifications, and if
** you point the finger at us for messing up your device, we will laugh at you.
**
**/
Hi all,

This is a very VERY highly WIP Oreo build for the Galaxy S2 (i9100). Almost everything is broken.
I just want to release it for people who wants to help or test these builds. The ROM boots and the lockscreen comes up, but the home button doesn't work, no audio, etc... yet.
I'm currently using TWRP 3.0.2 on my dev-phone to install the ROM. Other versions of TWRP I haven't tried yet.

Source code:
https://www.github.com/lineageos
https://www.github.com/rinando

Build #1 2017-09-17
DON'T INSTALL THIS ROM ON YOUR DAILY DRIVE PHONE.
Overall state: UNSTABLE

What works? Nothing, not really tested because it just booted
What doesn't work? Everything, not really tested
Download here: lineage-15.0-20170917-UNOFFICIAL-i9100.zip
The Following 47 Users Say Thank You to rINanDO For This Useful Post: [ View ] Gift rINanDO Ad-Free
 
 
17th September 2017, 08:09 PM |#2  
OP Senior Member
Thanks Meter: 1,851
 
More
* Reserved *
The Following 9 Users Say Thank You to rINanDO For This Useful Post: [ View ] Gift rINanDO Ad-Free
17th September 2017, 08:37 PM |#3  
toy_story's Avatar
Senior Member
Flag Tambov
Thanks Meter: 378
 
More
Download Gapps for Lineage OS – Android 8.0, 7.x, 6.x [All Versions] [Updated Daily]
Installation in TWRP-3.1.0-0 was successful.
Upd.
My first time too was not loaded.
I did all the Wipe and uploaded in 5 minutes.
The screenshots are done, but the screenshot's image is very bad, like on the old TV, where the channel constantly gets off and does not see anything, so @rINanDO posted such an image, not a screenshot.
Yes, almost nothing works, but the phone works quickly, without a cellular connection, you can check and solve the problems, but my s2 is the main phone.
Attached Thumbnails
Click image for larger version

Name:	11094105.png
Views:	3304
Size:	164.0 KB
ID:	4276381   Click image for larger version

Name:	11094106.png
Views:	3220
Size:	58.1 KB
ID:	4276382   Click image for larger version

Name:	11094108.png
Views:	3222
Size:	66.9 KB
ID:	4276383  
The Following 10 Users Say Thank You to toy_story For This Useful Post: [ View ] Gift toy_story Ad-Free
17th September 2017, 09:04 PM |#4  
Member
Thanks Meter: 7
 
More
It looks pretty cool even tho with bugs. Hope it comes out soon without bugs.... Thank you!
The Following User Says Thank You to HutchGuy For This Useful Post: [ View ] Gift HutchGuy Ad-Free
18th September 2017, 03:08 AM |#5  
Member
Flag Salvador, BA
Thanks Meter: 48
 
More
Blood pressure dropped a bit when I saw 'Android O' even in alpha phase!
I'll try right now!

---------- Post added at 02:08 AM ---------- Previous post was at 01:52 AM ----------

How can I help besides reporting the bugs?

EDIT: I tried to install the trial version of Oreo lineage with TWRP versions 3.02-1 and 3.1.0. Unsuccessfully. It is only in part 'Patching system image unconditionally'. 10 minutes later it stays the same and the CPU of the cell phone goes to 67 degrees. Exit the screen only if you remove the battery.
I also tried the recent kernel dorimanx and nothing happened.
I'll wait for the next test build =)
The Following 2 Users Say Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
18th September 2017, 08:15 AM |#6  
Shambles22's Avatar
Senior Member
Flag Roma
Thanks Meter: 38
 
More
I tried to flash the build with latest twrp but doesn't boot
The Following 2 Users Say Thank You to Shambles22 For This Useful Post: [ View ] Gift Shambles22 Ad-Free
18th September 2017, 12:27 PM |#7  
Spyr0s's Avatar
Senior Member
Flag Athens
Thanks Meter: 998
 
Donate to Me
More
How is battery life?
The Following User Says Thank You to Spyr0s For This Useful Post: [ View ] Gift Spyr0s Ad-Free
18th September 2017, 05:51 PM |#8  
bielie's Avatar
Senior Member
Flag Jakarta
Thanks Meter: 22
 
More
* buying more popcorns *
19th September 2017, 01:13 AM |#9  
Member
Thanks Meter: 13
 
More
Hehehe great! Work hard for a full supported port!
19th September 2017, 04:46 AM |#10  
Junior Member
Thanks Meter: 1
 
More
On my device It boot's up, but the colors are inverted in some way, the blue on the logo is a green, the entire system get's green for some reason
19th September 2017, 02:02 PM |#11  
OP Senior Member
Thanks Meter: 1,851
 
More
Quote:
Originally Posted by matterrorist

On my device It boot's up, but the colors are inverted in some way, the blue on the logo is a green, the entire system get's green for some reason

True, I didn't noticed that at first.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes