FORUMS
Remove All Ads from XDA

[ROM][OFFICIAL][9.0][i9100] Pixel Experience GO [AOSP][r35][20190419]

381 posts
Thanks Meter: 834
 
Post Reply Email Thread

PixelExperience for i9100



What is this?
An AOSP based ROM, with gapps included, and all Pixel stuffs (launcher, wallpapers, icons, fonts, bootanimation).

Based on Android 9.0

Code:
/*
** Your warranty is now void.
**
** We are not responsible for bricked devices, dead SD cards,
** thermonuclear war, or you getting fired because the alarm app failed. Please
** do some research if you have any concerns about features included in this ROM
** before flashing it! YOU are choosing to make these modifications, and if
** you point the finger at us for messing up your device, we will laugh at you.
**
**/
Whats working?
Wifi
RIL
Mobile data
GPS
Camera
Flashlight
Camcorder
Bluetooth
Lights
Screenshots
Sound / vibration

Known issues
* Slow start due to GAPPS. Wait 10 minutes before setting up the appliance.
* Initial wallpaper with different colors on the first start. Apply again and return to normal.

DON'T FLASH GAPPS, ALREADY INCLUDED

NO ETA REQUESTS!!!



Credits - @rINanDO

You need 1.5GB of system partition for ROM to install.
Not sure how? See in this post

If you like my work, do not forget to click the button thanks. It's free!!!

XDA:DevDB Information
Pixel Experience, ROM for the Samsung Galaxy S II

Contributors
linusdan
ROM OS Version: 9.x Pie
ROM Kernel: Linux 3.0.x
Based On: AOSP

Version Information
Status: Stable

Created 2018-11-18
Last Updated 2019-04-19
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	4230
Size:	234.9 KB
ID:	4667468   Click image for larger version

Name:	2.png
Views:	4254
Size:	114.9 KB
ID:	4667469   Click image for larger version

Name:	3.png
Views:	4184
Size:	42.3 KB
ID:	4667470   Click image for larger version

Name:	4.png
Views:	4086
Size:	42.7 KB
ID:	4667471   Click image for larger version

Name:	5.png
Views:	4042
Size:	50.9 KB
ID:	4667472   Click image for larger version

Name:	6.png
Views:	3944
Size:	39.7 KB
ID:	4667473   Click image for larger version

Name:	7.jpg
Views:	3898
Size:	38.1 KB
ID:	4667474  
The Following 32 Users Say Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
 
 
18th November 2018, 02:25 PM |#2  
linusdan's Avatar
OP Senior Member
Flag Salvador, BA
Thanks Meter: 834
 
More
EMULATED STORAGE IMPLEMENTED FROM THE FEBRUARY BUILD.
DON'T INSTALL BEFORE FOLLOW THESE INSTRUCTIONS!!!

AFTER MIGRATION, READ THE SECTION D DESCRIBED HERE.

A. Bugs
Did you find a bug or problem?
Make a logcat and put it in pastebin/hastebin. I'll look when I can
You will need a computer, adb installed, usb debugging enabled on the smartphone and a usb cable.
Here's how to do it here.

1. Open Command Prompt (Windows) or Terminal (Linux/macOS).
2. Type:
Code:
adb logcat -d > logcat-dd-mm-yyyy.txt
This will save the log to logcat-dd-mm-yyyy.txt.

B. Magisk
Please do not ask me about compatibility with Magisk.
The i9100 Kernel (3.0.101) does not support namespace to work.

C. Root
For now, the builds are rootless (forgot to warn).
I'll check a way to bring compatibility when you have time

D. Error 7
ROMs android 8+ require TWRP with version 3.2.3 or higher because of the security script to ensure that it will not be installed on different phones, avoiding major problems.
The Pixel Experience is no different. In order for you to have OTA updates or success in clean installation, you need to update TWRP.
Files Required:
* boot.img of ROM
* TWRP EMU 3.3.0 by linusdan

1) After migrating the emulated storage (do not install before or the bootloop will say hi), extract and install the ROM boot.img file.
1.1 - Install > sdcard1 > (folder where the file was saved)
1.2 - Install Image Button
1.3 - Select boot.img
1.4 - Click the boot option and slide to install.

2) Install TWRP EMU 3.3.0
2.1 - Go back to the folder where the files are
2.2 - Select TWRP_3.3.0_i9100-EMU-linusdan.img
2.3 - Click the Recovery option and slide to install.

Restart the device by selecting the reboot> recovery option.
Install Pixel Experience normally.
If you want to install another ROM with emulated storage, do the same procedures.

Changelog
19042019
  • Updated gapps
  • Updated sources
  • Add live display
  • Add support to F2FS
  • Improvements in the SELinux
  • Fixed allow home button to wake
  • Add dummy keydisabler to allow navbar disabling

    Bugs
  • Superuser causes bootloop
  • Video recording in camera app not working.


07042019 - First official build
  • Updated gapps
  • Updated sources
  • April security patch
  • Fixed WiFi HotSpot
  • SELinux enforcing mode
  • Fixed sound picker crash
  • Ported FunctionFS to our kernel (Thanks to rINanDO, ChronoMonochrome)

    Bugs
  • Sometimes the camera stops and gives connection error. Use OpenCamera app for now.

14032019
  • Updated gapps
  • Updated sources
  • Increase heapsize to 360mb
  • Fixed crashes of Pixel Launcher
  • SELinux: come back to permissive mode
  • Snap camera replaced by Camera2 app for now.
  • Removed libyamaha-mc1n2-audio, was causing conflicts and excessive battery consumption

    Fixes by @rINanDO:
  • Fixed graphical glitch at wake up
  • Screen tearing fixed, thanks to @ChronoMonochrome
  • Wakelock on flashlight (Flashlight turned off after 10 secs)
  • Fixed GAPPS crash at first startup. (I think it was Ashmem-tracking hack)
  • Moved Exynos4 framework hacks to device tree's, thanks to @ChronoMonochrome
  • Removed AshMem-tracking hack, thanks to @ChronoMonochrome for hacking our libsecril.so!
  • Move Target SDK to shims to allow textrelocation for gps, sensors and ril (removed bionic/libc-hacks)

    Known issues:
  • Slow start due to GAPPS. Wait 10 minutes before setting up the appliance.
  • Initial wallpaper with different colors on the first start. Apply again and return to normal.
  • Crashes when trying to change the ringtone in the settings of the device. Thanks to @Exhigh for reporting!

05032019 - deleted
  • Updated gapps
  • Updated sources
  • Enabled libyamaha-mc1n2-audio
  • Enabled SELinux enforcing mode

    Known issues:
  • Slow start due to GAPPS. Wait 10 minutes before setting up the appliance.
  • Sometimes there are some lags. Turn off animations, turn on power saving mode and dark mode for a better experience. Slowdown is still making me pass anger to get a good optimization

07022019
  • Updated gapps
  • Updated sources
  • PowerHAL added
  • Fixed dark mode issue
  • Performance and speed improvements
  • dalvik.vm.heapsize adjusted to 256m again
  • Fixed error at try download files via navegador or third-party apps

13012019
  • Updated gapps
  • Updated sources

    Fixes by @rINanDO:
  • ZRAM set to 200MB
  • Fixed memory leak and crash in hwc
  • Fixed high-res display statusbar issue
  • Applied GO config for 512mb devices

17122018
  • Updated gapps

    Fixes by @rINanDO:
  • Fixed screenshot and Colorfade animation
  • Updated pinnerService, which caused excessive lags and battery drain
  • Tryout: Change size of dalvik.vm.heapsize to 360m, as an attempt to soften the system slowdowns with gapps included

16112018
  • Initial build
The Following 8 Users Say Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
18th November 2018, 02:25 PM |#3  
linusdan's Avatar
OP Senior Member
Flag Salvador, BA
Thanks Meter: 834
 
More
Apps tip
The Following User Says Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
21st November 2018, 06:20 AM |#4  
chhapil's Avatar
Senior Member
Xen
Thanks Meter: 432
 
More
I had to give couple of clean flashes and a lot of reboots to make it working.
Pixel setup app kept on crashing on first boot and couldn't bypass it.
Finally managed to boot.
All working fine so far but with some stutter and slowness
21st November 2018, 12:23 PM |#5  
Junior Member
Thanks Meter: 2
 
More
I have upgraded from Pixel Experience 8.1 with a dirty flash (only cache and dalvik wiped). It was running with the first boot. All the functionality I need is working well. But it is a little bit slower than 8.1.
21st November 2018, 02:39 PM |#6  
linusdan's Avatar
OP Senior Member
Flag Salvador, BA
Thanks Meter: 834
 
More
Quote:
Originally Posted by hedgehog99de

I have upgraded from Pixel Experience 8.1 with a dirty flash (only cache and dalvik wiped). It was running with the first boot. All the functionality I need is working well. But it is a little bit slower than 8.1.

I am aware of this and looking for solutions to optimize
The Following 3 Users Say Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
10th December 2018, 12:07 PM |#7  
Junior Member
Thanks Meter: 2
 
More
Flashed this ROM the other day. The UI seems very slow and stutter-ish with this ROM.
I wanted to flash another ROM today, but i just noticed, that connecting via USB is not working anymore. When I go into the setting menu, everything is grayed out.
I tried different ports on my computer as well as different cables.
Does anyone have a solution for this?
10th December 2018, 06:10 PM |#8  
Senior Member
Flag Vienna
Thanks Meter: 276
 
More
Quote:
Originally Posted by exza137

Flashed this ROM the other day. The UI seems very slow and stutter-ish with this ROM.
I wanted to flash another ROM today, but i just noticed, that connecting via USB is not working anymore. When I go into the setting menu, everything is grayed out.
I tried different ports on my computer as well as different cables.
Does anyone have a solution for this?

Hi
No idea why usb is not working but i would just download the rom and gapps on a micro sd card and install it from there then using twrp.

Sent from my [device_name] using XDA-Developers Legacy app
10th December 2018, 06:37 PM |#9  
linusdan's Avatar
OP Senior Member
Flag Salvador, BA
Thanks Meter: 834
 
More
Quote:
Originally Posted by exza137

Flashed this ROM the other day. The UI seems very slow and stutter-ish with this ROM.
I wanted to flash another ROM today, but i just noticed, that connecting via USB is not working anymore. When I go into the setting menu, everything is grayed out.
I tried different ports on my computer as well as different cables.
Does anyone have a solution for this?

Erase the system via TWRP and test without the system.
The Following 2 Users Say Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
10th December 2018, 06:39 PM |#10  
linusdan's Avatar
OP Senior Member
Flag Salvador, BA
Thanks Meter: 834
 
More
Quote:
Originally Posted by TriboDoP

Hi
No idea why usb is not working but i would just download the rom and gapps on a micro sd card and install it from there then using twrp.

Sent from my [device_name] using XDA-Developers Legacy app

No need to flash the gapps. It is described in the OP.
The Following User Says Thank You to linusdan For This Useful Post: [ View ] Gift linusdan Ad-Free
10th December 2018, 07:21 PM |#11  
Senior Member
Flag Vienna
Thanks Meter: 276
 
More
Quote:
Originally Posted by linusdan

No need to flash the gapps. It is described in the OP.

Okay! Thanks!

Sent from my [device_name] using XDA-Developers Legacy app
The Following User Says Thank You to TriboDoP For This Useful Post: [ View ] Gift TriboDoP Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes