FORUMS
Remove All Ads from XDA

[How to]Install Google Play on chinese ROM Galaxy S2 i9100G

72 posts
Thanks Meter: 9
 
By chewee133, Member on 10th May 2012, 06:15 PM
Post Reply Email Thread
Hi all,

When buying your S2 in China, you while probably have the bad surprise to discover Google Play is not installed on the device.
Even by installing some .apk downloaded from the web doesn't solve the issue.

I managed to got mine working. Here's how i did.

I find the hint here
http://forum.xda-developers.com/show....php?t=1351283

You'll need to Root your device first

Here's how it goes:
1) Install GoogleServicesFramework.apk
This seems to be the issue, as when you install it you can see the permissions Google requires, and pretty much says it can access ALL the data in your phone, even the private stuff. You've been warned. (what did you expect? it's still Google after all)
2) Install Google Play with any .apk you can find, as system app (see bellow):
Instructions (Thanks to Bandage)
-1. Transfer the .apk files to your Kindle Fire via PC / Mac (remember where you put them)
- 2. Open Root Explorer App, and navigate to the transferred .apk files
- 3. Select the GoogleServiceFramework.apk and install
- 4. When complete, click "Done" and return to the file location for Vending.apk
- 5. Long-press Vending.apk and select the "Move" option on pop-up menu
Navigate to /system/app folder
- 6. Change mount option from RO to RW (read-only to read-write)
Paste Vending.apk into the /system/app folder
- 7. Long-press Vending.apk and select "Permissions" from pop-up menu
Change permissions to match all other apps in this folder (rw-r--r--)
- 8. Install Vending.apk
- 9. Reboot device
3) Launch Google Play
You should now be able to input your account and login.
For the first login, you will probably need to turn on both Wifi and APN (also can try turning off Wifi and only use APN).

You can now browse the market, but still can not install any apps.

Final step: You'll need to send some e-mail to Google (go to google play web site -> help). Explain the problem, they need to allow Play to be used by your device.
Took me a couple e-mail to get it right. The google team was very kind open to help (unlike samsung).

Go ahead and install any app you want
I recommend starting by installing Market Unlocker (especially for those in China). It lets you get the market as if you where in another country.

Hope this has been useful.
And don't forget to press the Thanks button

I actually did this a while ago (I wanted to try it out first before sharing). So i may be forgetting some specific points. Let me know how it turns out for you so i can update this How To.

Cheers

Chewee
May the force be with you
The Following 6 Users Say Thank You to chewee133 For This Useful Post: [ View ] Gift chewee133 Ad-Free
 
 
13th May 2012, 06:46 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Thanks!
I tried many other ways, but they just would not work on my I9100G!
Just now I have tried this simple method and it works perfectly.
For me the final step is not necessary.
Thanks again!
14th May 2012, 08:43 AM |#3  
chewee133's Avatar
OP Member
Thanks Meter: 9
 
More
Thanks for the reply. I really appreciate.
Glad i could be of any help
14th May 2012, 02:02 PM |#4  
Senior Member
Thanks Meter: 1,533
 
Donate to Me
More
I did add all google services on my chinese G in november, i basically have all google services working, including calendar sync, and still on stock GB.
What i did was to take all the google apps from CM and put them in the system app folder with correct permissions.
But i remember i did setup gmail sync before getting google market (now play store) to work correctly.
For the calendar, only the sync adapter is needed, do not replace other apps, it's not needed.
21st May 2012, 07:04 PM |#5  
shivaraman's Avatar
Member
Flag Shenzhen, China
Thanks Meter: 0
 
More
Question
Quote:
Originally Posted by chewee133

Hi all,

When buying your S2 in China, you while probably have the bad surprise to discover Google Play is not installed on the device.
Even by installing some .apk downloaded from the web doesn't solve the issue.

I managed to got mine working. Here's how i did.

I find the hint here
http://forum.xda-developers.com/show....php?t=1351283

You'll need to Root your device first

Here's how it goes:
1) Install GoogleServicesFramework.apk
This seems to be the issue, as when you install it you can see the permissions Google requires, and pretty much says it can access ALL the data in your phone, even the private stuff. You've been warned. (what did you expect? it's still Google after all)
2) Install Google Play with any .apk you can find, as system app (see bellow):
Instructions (Thanks to Bandage)
-1. Transfer the .apk files to your Kindle Fire via PC / Mac (remember where you put them)
- 2. Open Root Explorer App, and navigate to the transferred .apk files
- 3. Select the GoogleServiceFramework.apk and install
- 4. When complete, click "Done" and return to the file location for Vending.apk
- 5. Long-press Vending.apk and select the "Move" option on pop-up menu
Navigate to /system/app folder
- 6. Change mount option from RO to RW (read-only to read-write)
Paste Vending.apk into the /system/app folder
- 7. Long-press Vending.apk and select "Permissions" from pop-up menu
Change permissions to match all other apps in this folder (rw-r--r--)
- 8. Install Vending.apk
- 9. Reboot device
3) Launch Google Play
You should now be able to input your account and login.
For the first login, you will probably need to turn on both Wifi and APN (also can try turning off Wifi and only use APN).

You can now browse the market, but still can not install any apps.

Final step: You'll need to send some e-mail to Google (go to google play web site -> help). Explain the problem, they need to allow Play to be used by your device.
Took me a couple e-mail to get it right. The google team was very kind open to help (unlike samsung).

Go ahead and install any app you want
I recommend starting by installing Market Unlocker (especially for those in China). It lets you get the market as if you where in another country.

Hope this has been useful.
And don't forget to press the Thanks button

I actually did this a while ago (I wanted to try it out first before sharing). So i may be forgetting some specific points. Let me know how it turns out for you so i can update this How To.

Cheers

Chewee
May the force be with you

HI I followed the steps but at stage 3 after reboot I open google play it 'force closes' automatically. I cannot open play app. What may be the issue. This is Chinese phone, i also tried one of the market unlcker.. is there any specific version you can suggest ?
Ok now it opens google play and displays 'loading' but nothing appears. Funny that when I try to install it from website it says 'app will be sent/installed on your phone shortly' but nothing happens
I installed a market unlocker (some random one which configured my China phone for USA T-mobile - there are other countries i can configure for too)
Any guess what could be problem ?
22nd May 2012, 12:55 PM |#6  
toctan's Avatar
Junior Member
Flag Wuhan,Hubei,China
Thanks Meter: 0
 
More
It's not the right way!!!
It seems to work properly, but it may cause some problem, frequent FC for example. And some apps even can't work, such as Foursquare, which you can have a try.It's not only the Google Play but also the whole gapps that are not included in the Chinese ROM. The GoogleServicesFramework.apk and GooglePlay.apk are just part of it, so this problem can't be solved by simply installing some apks.

The right way is to download the right gapps from this page: goo.im/gapps and flash it from CMW.To do that, you must flash a kernel first, such as superatoms, lucir.

Or, you can simply root your phone and decompress that zip file and move it to your phone to the right folder.Never forget to fix the permission. You'd better do that through adb.
23rd May 2012, 01:51 AM |#7  
Senior Member
Thanks Meter: 1,533
 
Donate to Me
More
I can't agree with what you're saying. I have a chinese G and installed all google apps from Cyanogen wiki, with the exception of goggles, everything else work perfect ! Including Gmail with full sync, contacts with full sync,calendar with full sync, music working, books working etc ... Stock zcki1 rooted.

Sent from my GT-I9100G using XDA
23rd May 2012, 09:13 AM |#8  
shivaraman's Avatar
Member
Flag Shenzhen, China
Thanks Meter: 0
 
More
Edit
10th July 2012, 08:21 PM |#9  
Junior Member
Thanks Meter: 1
 
More
Ta
Thanx for the walkthrough. I got the market working but can't download. Will be contacting Google help soon.
11th July 2012, 01:05 AM |#10  
Senior Member
Flag Shenzhen
Thanks Meter: 42
 
More
ICS 4.0.4
They just released the ICS 4.0.4 ROM for China, that one also does not have any of the GAPPS, in addition some
service providers actively block Google services so installing GAPPS will do no good unless you set up a VPN

Quote:
Originally Posted by chewee133

Hi all,

When buying your S2 in China, you while probably have the bad surprise to discover Google Play is not installed on the device.
Even by installing some .apk downloaded from the web doesn't solve the issue.

I managed to got mine working. Here's how i did.

I find the hint here
http://forum.xda-developers.com/show....php?t=1351283

You'll need to Root your device first

Here's how it goes:
1) Install GoogleServicesFramework.apk
This seems to be the issue, as when you install it you can see the permissions Google requires, and pretty much says it can access ALL the data in your phone, even the private stuff. You've been warned. (what did you expect? it's still Google after all)
2) Install Google Play with any .apk you can find, as system app (see bellow):
Instructions (Thanks to Bandage)
-1. Transfer the .apk files to your Kindle Fire via PC / Mac (remember where you put them)
- 2. Open Root Explorer App, and navigate to the transferred .apk files
- 3. Select the GoogleServiceFramework.apk and install
- 4. When complete, click "Done" and return to the file location for Vending.apk
- 5. Long-press Vending.apk and select the "Move" option on pop-up menu
Navigate to /system/app folder
- 6. Change mount option from RO to RW (read-only to read-write)
Paste Vending.apk into the /system/app folder
- 7. Long-press Vending.apk and select "Permissions" from pop-up menu
Change permissions to match all other apps in this folder (rw-r--r--)
- 8. Install Vending.apk
- 9. Reboot device
3) Launch Google Play
You should now be able to input your account and login.
For the first login, you will probably need to turn on both Wifi and APN (also can try turning off Wifi and only use APN).

You can now browse the market, but still can not install any apps.

Final step: You'll need to send some e-mail to Google (go to google play web site -> help). Explain the problem, they need to allow Play to be used by your device.
Took me a couple e-mail to get it right. The google team was very kind open to help (unlike samsung).

Go ahead and install any app you want
I recommend starting by installing Market Unlocker (especially for those in China). It lets you get the market as if you where in another country.

Hope this has been useful.
And don't forget to press the Thanks button

I actually did this a while ago (I wanted to try it out first before sharing). So i may be forgetting some specific points. Let me know how it turns out for you so i can update this How To.

Cheers

Chewee
May the force be with you

12th July 2012, 03:51 AM |#11  
Senior Member
Thanks Meter: 1
 
More
Can someone please explain where and how to change permissions!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes