FORUMS
Remove All Ads from XDA

No IMEI, BASEBAND, (GUIDE)

424 posts
Thanks Meter: 55
 
By JAMIE1000UK, Senior Member on 13th April 2012, 02:27 AM
Post Reply Email Thread
So... Tonught I was happily having a game on draw something with the mrs.. Then noticed a no entry looking sign where my signal was.. Took the sim out wiped it put it back in.. Same again.. Thort strange.. Must of crashed or something..

Anyways..

Did a factory reset. ( settings - privacy - factory reset)

This didnt work either nor did hard reset using the code..

Anyways.. Looked all over the internet and most forums said basically.. Warranty.. Send it back..
As i baught it second hand wasnt sure of wether i could so kept looking....

I then found this.. And my god it was a godsend. I was convinced my phone was dead..

If you have similar issues then follow this..


"Re: Samsung Galaxy S2 ( Baseband Unknown ) help!!!! 1 week, 3 days ago #5921 ABRAHAM

OFFLINE
Droid Recruit

Posts: 1
Karma: 0
HEY GUYS , i've created an account here just to address this problem :
( only for SAMSUNG GALAXY SII )
Solution 100% solved and WOrking ( BY ME )

1st step , download any compatible android firmware available in your hands. ( if your phone isin't stuck in a boot loop , skip this step, or if u can use everything but GSM cellular network, or any other connection provided by your sim card provider )
2nd : root your mobile using this toolkit here's the link

http://www.ngopdul.com/en/androids/r...g-toolkit.html

3rd: step : search in the market for GSII_repair app ( needs root aka superuser access )
4rth step : repair your efs files using this app . ( it's obvious when u look at it )
5th step : search in the market for galaxy s unlock ( follow steps , easy ones )
6th step : ENJOY having your phone back from the dead



PS : this is addressed to all of the guys with the unsolved baseband issues ( unknown baseband)
no imei , imei sv wifi adddress , bluetooth address in a (unavailable) state , will 100 work , hope u enjoy , i blogged for the 1st time in my life to try to help out ppl :_) , try it and reply to me if it did work ( of course it's gonna work"

The 1st 2 steps got my phone working again..

Thanks goes to droid recruit for this!

Original thread:
http://www.androidmobile.co.nz/forum...it=10&start=10

Sent from my GT-I9100 using xda premium
The Following 12 Users Say Thank You to JAMIE1000UK For This Useful Post: [ View ] Gift JAMIE1000UK Ad-Free
 
 
13th April 2012, 02:42 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Thumbs up
thanks.. it works.. having the same prob here..
13th April 2012, 04:38 AM |#3  
Junior Member
Flag Trivandrum , India
Thanks Meter: 0
 
More
Tried GSII_Reapir . But is showing Busy Box Error in Step 1 . Any Suggestions.
13th April 2012, 04:47 AM |#4  
OrrPenn18's Avatar
Senior Member
Recovery Mode
Thanks Meter: 1,702
 
More
I always get no IMEI, BASEBAND or anything in the status section when i connect my phone for charging and reboot ...

Sent from my GT-I9100 using Tapatalk
13th April 2012, 04:53 AM |#5  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by g_albin

Tried GSII_Reapir . But is showing Busy Box Error in Step 1 . Any Suggestions.

Are you sure busybox is installed/updated?
13th April 2012, 09:47 AM |#6  
JAMIE1000UK's Avatar
OP Senior Member
Flag leicester uk
Thanks Meter: 55
 
More
As someone said make sure your busybox is installed correctly.

My phone was as stange as hell.. I set up a lock screen before it all happened.. For some reason after a factory reset.. my lock screen showed up. But for some reason o could draw any dots and it would unlock it..

Also i had no imei.. No baseband. No bluetooth.. Wifi would work. But anything tondo with my gsm sim care would not work..

When using GS11_repair.. Skip the first tab and goto the repair tab. Do everything in order on that page.. The unlock part i didnt do as my phones the unlockes debranded firmware so didnt need it. I only did the first 2 steps and magically everything just came right..

Hope this mini guide helps.

Sent from my GT-I9100 using xda premium
13th April 2012, 09:54 AM |#7  
JAMIE1000UK's Avatar
OP Senior Member
Flag leicester uk
Thanks Meter: 55
 
More
Apparently the problem is your nv_data file is corrupt. Which is in or around your efs folder which has all the information about your phone [imei baseband etc]

backing up and restoring your efs and deleting the old nv_data file fixes the problem for apparently 9/10 gs2's.

MAKE SURE YOU BACK UP YOUR EFS.. 2 FILES SHOULD BE BACKED UP IN THIS PROCEDURE. IF I WAS YOU.. UPLOAD THESE 2 VERY IMPORTANT FILES TO YOUR DROP BOX OR WHATEVER SO YOU ALWAYS HAVE THEM SHOULD YOU NEED THEM.

Sent from my GT-I9100 using xda premium
13th April 2012, 11:19 AM |#8  
Junior Member
Thanks Meter: 0
 
More
+1 Thanks


13th April 2012, 11:39 AM |#9  
Guest
Thanks Meter: 788
 
More
This only works in few cases and you should not use gs_repair because it creates the efs filesystem with the incorrect parameters.
The Following 2 Users Say Thank You to Odia For This Useful Post: [ View ] Gift Odia Ad-Free
13th April 2012, 12:48 PM |#10  
JAMIE1000UK's Avatar
OP Senior Member
Flag leicester uk
Thanks Meter: 55
 
More
No idea mate.. All i know is it worked for me.. Device is fine now

Sent from my GT-I9100 using xda premium
14th April 2012, 01:22 AM |#11  
Inactive Recognized Developer
Flag Nottingham
Thanks Meter: 2,968
 
Donate to Me
More
See here for all your backing up and restoring needs. Everything EFS, and can also fix baseband and IMEI issues.

http://forum.xda-developers.com/show...php?p=18524176

Sent from my GT-I9100 using Tapatalk 2
The Following User Says Thank You to lyriquidperfection For This Useful Post: [ View ] Gift lyriquidperfection Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes