FORUMS
Remove All Ads from XDA

[Q] Decompiling Turkbey v11 SystemUI error.

907 posts
Thanks Meter: 1,262
 
By Tired Storeman, Senior Member on 2nd June 2012, 08:49 AM
Post Reply Email Thread
I am trying to decompile Turkbeys SystemUi from v11 and keep getting the following error.

C:\Users\Betty\Desktop\APK TOOL>apktool d SystemUI.apk
I: Baksmaling...
Exception in thread "main" java.lang.RuntimeException: bad magic value: 64 65 78
0a 30 33 36 00
at org.jf.dexlib.DexFile.<init>(DexFile.java:377)
at org.jf.dexlib.DexFile.<init>(DexFile.java:274)
at brut.androlib.src.SmaliDecoder.decode(SmaliDecoder .java:48)
at brut.androlib.src.SmaliDecoder.decode(SmaliDecoder .java:33)
at brut.androlib.Androlib.decodeSourcesSmali(Androlib .java:68)
at brut.androlib.ApkDecoder.decode(ApkDecoder.java:85 )
at brut.apktool.Main.cmdDecode(Main.java:128)
at brut.apktool.Main.main(Main.java:65)

C:\Users\Betty\Desktop\APK TOOL>

i can decompile any other SystemUI apk without any problems, can anybody shed any light on what i can do to resolve this problem, any help would be greatly appreciated, Thankyou in advance
 
 
2nd June 2012, 09:33 AM |#2  
The-Hulk's Avatar
Retired Forum Moderator
Flag Warrington
Thanks Meter: 1,842
 
Donate to Me
More
Quote:
Originally Posted by Tired Storeman

I am trying to decompile Turkbeys SystemUi from v11 and keep getting the following error.

C:\Users\Betty\Desktop\APK TOOL>apktool d SystemUI.apk
I: Baksmaling...
Exception in thread "main" java.lang.RuntimeException: bad magic value: 64 65 78
0a 30 33 36 00
at org.jf.dexlib.DexFile.<init>(DexFile.java:377)
at org.jf.dexlib.DexFile.<init>(DexFile.java:274)
at brut.androlib.src.SmaliDecoder.decode(SmaliDecoder .java:48)
at brut.androlib.src.SmaliDecoder.decode(SmaliDecoder .java:33)
at brut.androlib.Androlib.decodeSourcesSmali(Androlib .java:68)
at brut.androlib.ApkDecoder.decode(ApkDecoder.java:85 )
at brut.apktool.Main.cmdDecode(Main.java:128)
at brut.apktool.Main.main(Main.java:65)

C:\Users\Betty\Desktop\APK TOOL>

i can decompile any other SystemUI apk without any problems, can anybody shed any light on what i can do to resolve this problem, any help would be greatly appreciated, Thankyou in advance

Try replacying the apktool.jar file you can find it here, just copy and past this into your apktool file and it will replace the old one.
2nd June 2012, 10:49 AM |#3  
Tired Storeman's Avatar
OP Senior Member
Flag Perth
Thanks Meter: 1,262
 
Donate to Me
More
Thanks for the reply, but no luck, still getting the error
2nd June 2012, 11:20 AM |#4  
ag4751's Avatar
Senior Member
Flag Scarborough
Thanks Meter: 245
 
More
Quote:
Originally Posted by Tired Storeman

Thanks for the reply, but no luck, still getting the error

Open the apk with 7zip and see if there is a classes.dex file, if there is extract it and save it somewhere, then delete the dex file from the apk and decompile it after you recompile ir drag the dex file you extracted back to the same location in the apk.
The Following User Says Thank You to ag4751 For This Useful Post: [ View ] Gift ag4751 Ad-Free
2nd June 2012, 12:15 PM |#5  
The-Hulk's Avatar
Retired Forum Moderator
Flag Warrington
Thanks Meter: 1,842
 
Donate to Me
More
Are you using the new ICS apktool, i have added mine for you to try, also sometimes it helps if you add twframework-res.apk to your working apktool folder and run the command
Code:
apktool if twframework-res.apk
, and then try to decompile your systemui.apk.
Attached Files
File Type: zip ICS_Apktool.zip - [Click for QR Code] (5.25 MB, 47 views)
The Following User Says Thank You to The-Hulk For This Useful Post: [ View ] Gift The-Hulk Ad-Free
2nd June 2012, 12:57 PM |#6  
Tired Storeman's Avatar
OP Senior Member
Flag Perth
Thanks Meter: 1,262
 
Donate to Me
More
Thanks ag4751, removed classes.dex, and decompiled without error, much appreciated.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes