Remove All Ads from XDA

Galaxy s2 charging port problem

278 posts
Thanks Meter: 31
By treble4, Senior Member on 13th August 2011, 09:24 AM
Post Reply Email Thread
13th February 2012, 07:48 PM |#151  
Junior Member
Flag LIlle
Thanks Meter: 1
try ton change your cable ...
16th February 2012, 03:25 PM |#152  
Thanks Meter: 8
I am having the same problem with my phone, it thinks it's always connected to usb. It just started happening when the weather got really cold last week, must have been the condensation some people are talking about.
Anyway it's still bugged after 10 days, I'll send it in for repair, cleaning the port didn't help.
23rd February 2012, 02:24 PM |#153  
Junior Member
Thanks Meter: 0
s2 conection
Originally Posted by xmoo

Mine is going to be repaired in two weeks.
I was the 8th SGS2 since tuesday which came in the repair center.

The repair guy said it is a manifacturing fault.
The phone gets hots, and outside temperature is cold, so it makes moisture in the phone.
This cause the phones power management to get fu up (SGS2 has a small battery inside of it, and that gets fu up). Only fix is replace hardware, but 9 of 10 times Samsung gives the fault to the customer. They say it has water damage and can't be fixed in warrenty...

I'm going to write a huge article about it, and I hope it will get published by a lot of site's soon. Phones he admitted having the problem: SGS1, SGS2 and SGSN.

How much did you have to pay if its not covered by warrenty.
Ive also got the saw problem. ive had cpw to flash it but still the same. also how long did it take to repare it.
24th February 2012, 05:14 AM |#154  
Senior Member
Thanks Meter: 53
Originally Posted by brar.arsh

I think with new LPB ICS FW there is one more issue with battery..
Everything was working fine in ICS leaked FW till last night.
But .. Suddenly phones light lit up while charging, i thought it has fully charged. But it was just 67%.
Then this happened few times.
After that i unplugged the phone and started doing something on it. Suddenly Tap to Talk opened automatically and closed.
It happend many times. I rebooted, but it kept on happening.
I switched the phone off, but it turned on itself after some time.
I plugged in the charger, but it dint charge.
I tried USB, same result but a promp, charging pause due to over voltage.
I took out the battery for whole night an d put it on in morning.
Same tap to talk and not charging.
Then flashed back to original stock 2.3.6 and now it seems to be good.

Anyone having same issues.

For ur info i flashed ICS on Friday, and till last night there were no issues and i dint installed anything new.

Same problem here. All good initially on LPH. Then after a few days the phone thought it was connected to a charger when it was not. No moisture of any kind and nothing would fix it.

Flashed back to 2.3.6 and have not had the issue since. Maybe a bug somewhere in the ICS code that makes it overly sensitive.
27th February 2012, 10:40 PM |#155  
Junior Member
Thanks Meter: 0
my 6 month old sg2 has the same problems with going into car mode and not turning off etc.
tried cleaning it. in the end phoned smasung to log a repair (the reseller was not interested as passed 28 days old) and sent to birmingham for repair (inter city i think) and today they phoned me to say water damged just as lot of other people on here and they would not fix it under warranty.
I complained to samsung and there not interested and said they have to take the word of the reapir shopm, theyalso said thery have no record of other problems like this with there customers. based on this forum alone that clearly is very wrong.
And the repair shop want £45 to fix it. and also now my warranty is viod because of the damage unless i pay for it to be repaired then the work will be covered and my warranty will be valid again. this is a joke.
Which car phone wharehouse shop is fixing the phones? as i have asked for a second opion.
Maybe i should just pay the £45. or change the flex cable myself for £6 and then have no warranty which is practiclly useless anyway. just sounds a little dauting to change this.
my nearest cpw repair shop is coventry about 15 miles away.
27th February 2012, 10:49 PM |#156  
chrisjcks's Avatar
Senior Member
Flag Bolton
Thanks Meter: 1,163
Originally Posted by treble4

For the last week now when ever I charge the phone and unplug it it is still showing as charging do I just need to factory reset the phone or is the phone in need of repair cheers

Sent from my GT-I9100 using XDA Premium App

This happened to my SGS2, i sent it in for repair.

It also wouldn't let me turn off the phone, it would turn itself back on.

Faulty USB slot, probably dirty but I tried cleaning mine & it didn't help it.

This was before I was aware of mobile odin, i was worried sending it in as it was rooted, with villainrom installed - but they still fixed it.

Although, my screen is definitely a different one - the auto brightness is alot darker on this one, but no big deal.

I believe they replaced the guts of it all.

Sent from my GT-I9100 using Tapatalk
29th February 2012, 12:03 PM |#157  
Junior Member
Thanks Meter: 0
well i payed for my phone to be fixed. and got it back today and they have replaced the USB board and it seems ok now.
Even though i paid the would not give me back the old part as i wanted to see it and said it had to go back to samsung.
Aslo after i agreed to reluctantly pay they pahoned me back for the unlock code of the phone. so that was the first time the tried to turn it on. makes you wonder if they looked at the usb board at all as i gave thme so much info about the problem. and they most likley knew what it was with out looking and gave me a deafult response of water damage.
2nd March 2012, 10:36 AM |#158  
Junior Member
Thanks Meter: 0
Thumbs up cleaned miniUSB port with a staple
I also got this problem suddenly... a few days after I flashed a new ROM and and a night of intense Tower Defence.
I was worried that I broke something because I gamed while charging...

After reading this thread I cleaned out the miniUSB port (had some dust in it) thoroughly with a bend staple and the problem dissappeared.
8th March 2012, 11:35 PM |#159  
Junior Member
Thanks Meter: 0
same big problem here
I have the same yellow triangle/ thermometer problem

and now I cant recharge my gs2

I made a firmware upgrade (from 2.3.2 to 2.3.3 but not sure and i cant verify) yesterday so I am quite sure it is not any dust / dirty issue

any advice???

plan b : how can I downgrade and back to the previous release?
if I find a way to charge

9th March 2012, 12:37 AM |#160  
kouray's Avatar
Senior Member
Thanks Meter: 32
Same problem here. I've been reading a bit about it on internet but it looks like it starts generalizing a lot (good job Samsung !).

First of all, it's no software issue. Yes, changing rom might make the issue "disappear" for a day or two, but it is not a fix. The first advice that fixed the issue for some people was to clean the port with a qtip and alcohol (very little alcohol, don't dip your qtip in your bottle of 90% alcohol and then put it on your device).
Just take of the battery, put a bit of alcohol on the qtip to make it humid and try to clean gently as much as you can the inside of the port. Let it dry (the guy who suggested that advised to let it dry 24 hours, but I think 12 would be safe enough).

That should fix the issue for a while for some of us, but you should also get a replacement port on ebay for when it breaks for real (because I'm sure it's gonna).

Good luck
The Following User Says Thank You to kouray For This Useful Post: [ View ] Gift kouray Ad-Free
9th March 2012, 02:22 PM |#161  
Junior Member
Thanks Meter: 0
ok i've checked
i made upgrade from 2.3.3 to 2.3.4 and all this mess begin!!!!

now the mobile have been charging all night
BUT now it look like the battery is going down faster but now sure..i will investigate


now i plugged the charger it looks like is charging
but one hour ago it was charging and then for some reason stopped as it charged only 2%
this last issue make thinking is a hardware connection problem something like how the plug is positioned (ok sorry for my bad english)

saty tuned
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes