Remove All Ads from XDA

[Q] Galaxy S2 - Gyro & Compass not working

29 posts
Thanks Meter: 0
By Evo911, Junior Member on 15th September 2011, 05:51 AM
Post Reply Email Thread
I have a Korean Galaxy S2 SHW-250K, and I flashed a XXKH3 firmware on it. Used it for a couple of days, then went ahead and installed MoDaCo GR5 firmware on it. Now while exploring the options, I tried to test out that tilt-to-zoom feature in Gallery, but it didn't work so well. In fact, it more or less didn't work at all despite me checking out all the settings. So I went into Gyro and Horizontal calibration, and noticed something strange. The horizontal calibration dot was moving in jitters despite I had a pretty steady hand holding it. So I went into gyro calibration and noticed that this dot was not moving at all.

I then remembered that when I first got the phone, with Korean firmware and all, I calibrated the sensors and I don't remember seeing the dot ever moving as I calibrated it while placing it on a flat surface.

Now I went into the *#0*# menu and ran the tests. The results are like this:

Gyro sensor Display reading while sitting on a flat surface:

The self test apparently cleared:

The compass also doesn't respond to magnetic fields at all, and more or less rotates with the phone. Tested in a couple other Compass apps, and calibrated it by moving in 8 shape and all, but no avail:

Any idea what's wrong with it? Can it be fixed via software, or is it a hardware issue?
17th September 2011, 03:34 PM |#2  
OP Junior Member
Thanks Meter: 0
What.. no love?
18th September 2011, 12:50 PM |#3  
Thanks Meter: 6
I have the same issue with my s2
the compass is much more jumpy and less accurate than my old HTC hd2
i hope its not a hardware issue.
19th September 2011, 12:18 AM |#4  
rumz82's Avatar
Senior Member
Flag London
Thanks Meter: 65
Im having the same issue guys.

Horizontal calibration works, but the gyro one doesnt- the blue ball doesnt move!!!!
19th September 2011, 08:09 AM |#5  
Senior Member
Thanks Meter: 19
Same here

Sent from my Desire HD using Tapatalk
5th October 2011, 03:49 PM |#6  
Senior Member
Thanks Meter: 25
any solution, I think i have the same issue
5th October 2011, 06:36 PM |#7  
Senior Member
Thanks Meter: 25
Is this a hardware problem?
17th October 2011, 08:20 AM |#8  
Senior Member
Thanks Meter: 9
I have the same problem too. The compass is not working properly. It's turning in the reverse direction. And pointing to incorrect directions.

Is there any config or app to correct this problem?
21st December 2011, 12:08 AM |#9  
SrAdama's Avatar
Senior Member
Flag Stockholmistan
Thanks Meter: 17
Same problem on my Galaxy Note... anyone know how to fix this? Should I return my phone?
5th January 2012, 04:40 PM |#10  
Thanks Meter: 8
I just solved a very similar problem on my colleges SGS2 buy removing it from its case with MAGNETIC catches.
12th January 2012, 02:39 PM |#11  
Junior Member
Thanks Meter: 1
Nobody came up with idea it's nothing wrong with it? It is gyroscope, just put phone on something stable and calibrate to get rid of offset in gyro readings. In other word to make phone know to show zero readings when it has no angular velocity (not rotating).
Post Reply Subscribe to Thread

compass, fail, galaxy, gyro

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes