Remove All Ads from XDA

[Q] I9100G IMEI and Basemand version unknown

1 posts
Thanks Meter: 0
By tatterdemalion, Junior Member on 22nd February 2014, 12:34 AM
Post Reply Email Thread
Hello all,
I tried to stop myself from creating an user and also from starting a new thread on XDA, but i find myself in a bit of a huge mess.

I have a Galaxy S2 I9100G. I find it is an awesome phone, sadly not in the state i have it right now.

I have flashed a CM 10 ROM on it.
All i did is install a modified zImage that had a CWM in it using Heimdall. (It went well)
I have then made a quick backup using CWM and then flashed the CM 10 zip yet again using CWM.

I have then installed an Omni rom using the same flashing with CWM method.
This also went well.

I had to revert to CM10 cause i disliked the Omni rom. After some time (a week or so) i had to revert to the backup cause there was some data i needed, that i had saved in a note created on the stock rom. (This also went well)

After the data was saved i went back to CM10. (This also went flawlessly).

After a while (a few days) i cleaned my phone a bit. After assembling it and starting it up, the signal was gone. At first i was thinking that it is the place i liv in. This sometimes happens where i live. After a while, i came to see that there was no signal nomater where i was. I dissasembled the phone, thinking i might have done a mistake in connecting something back, all was connected back well and the phone still did not have signal. I came to see after playing around with the options that i have had no IMEI and no Baseband version.

What i tried was the following:

Booted to recovery:
in CWM i immediately flashed the created recovery. I have had no IMEI and baseband.

I then found some forums describing the deletion of the nv_data.bin+nv_data.bin.md5 files and renaming the .nv_data.bak to nv_data.bin and letting the md5 being created for it.

I deleted the data from /efs and then let the phone recreate the whole thing from scratch, all i did more was to copy the IMEI and .nv_data.bak file which i renamed to nv_data.bin

I then tried to flash the /efc with a zip file in CWM still to no avail.

I then tried the k-tool from the play store still no success.

There was a tool i found, NV writer tool, but that required for me to set the phone in Qualcomm mode, which was not an option for an I9100G with Texas Instruments OMAP processor. Still i tried the procedure, but the staps where i should have set the phone skipping the set to Qualcomm mode step (the *#something#* code was not working), and the app could not connect to the phone, so this was a stillborn solution for me.

I downloaded (kernel + rom), another stock rom (4.0.4), with Odin and repeated the process described above.

No imei and no baseband still.

I flashed the whole thing also i flashed the kernel again and the rom (this time i went back a step, to 4.0.3), also i used a PIT file for the SII i9100G model, and i did lfash from the a3 recovery mode the zip with the radio. Then i used a software, with the kind help of a friend, called Simlock Remote Server, where i have used a baseband + IMEI repair tool which was targeting my EFS partition and also it was flashing a stock i9100g EFS image. I have initiated quite a few of the of the operation mentioned before with the reair using the EFS image and also then i used another builtin functionality which could write the IMEI and baseband, still with a total lack of success.

I was sort of thinking that instead of an awesome phone i have a wery capable ipad, as all but the GSM functions were working. Sadly i have to say that i find myself in yet another problem. After flashing around 300 or so MBs are used on the system partition, where the rom resides. but after a while i notice heavy battery usage, even when not using my Galaxy S2 "iPad", and also the system partition is getting ever more full, till the whole 2GB are consumed and everything ceases to function. A factory restore with *2767*3855# solves the problem, but this will stard happening again after some time. I was thinking it could be a virus or something, as i have my phone rooted and installed a massive amount of applications which claimed miraculous IMEI repair abilities but failed miserably to deliver. I have installed 4 different anti-virus sw and these did not detect anything.

I am getting a bit scared of making this little piece of HW an useless transistor box, any advice and help would be appreciated. I am really ready to try anything, whatever platform Window$ or Linux may be necessary, please don't keep any possible solutions/suggestions from me.

Many thanks!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes