Remove All Ads from XDA

[Q] I9100T Odin flash OK, Download and recovery OK, stuck at logo!

6 posts
Thanks Meter: 0
By Kaine, Junior Member on 26th January 2014, 04:43 AM
Post Reply Email Thread
Hi folks, mid last week I woke up to a non responsive Galaxy S2. It's been happily running stock Vodafone ICS for over a year, and somehow spontaneously went soft brick on me. Gets stuck at logo screen or goes into boot loop.

Download mode is accessible. I can flash through Odin (1.85 and 3.09) and it reports success. I have successfully put CWM (various versions) on it can can boot into them fine.
Recovery mode is also accessible and appears to be working fine. I can access external SD card no problem.

Attempting to flash through zip from external SD aborts with Mode 7, reporting bad zip or unable to read source file. I have tried removing asserts from install script (educated myself to the risks and made sure the ROM was correct!!) and multiple versions of CM (10.1.3 stable, 10.2 nightly) and multiple versions of CWM recovery ( is what I've been using mostly, as recommended by CM guide)

Tried running which reported successful wipe, then attempted zip install from SD with same result (aborted mode 7). Repeated wipe and attempted stock (I9100TDVLSK_I9100THUTLSD_I9100TDVLS3_HOME.tar) from flash through Odin. Reported success, phone booted into recover and applied KOR CSC successfully, then reboot and still stuck at logo screen/boot loop.

I have attempted the fix in as best I could wish the resources I could find, but it's hard to follow to the letter with the links broken!!!

I have not tried repartition with PIT as I'm not sure where to get an appropriate PIT file. Advice on this appreciated!

I want to make this clear because people seem to not want to believe it: I did not soft brick my phone flashing it. My best theory at this point is some kind of memory corruption or hardware failure that's causing a boot loop. Any help or suggestions would be appreciated. This week I will probably take it in to a repair shop and hope for the best, but tomorrow is a public holiday and I've got nothing to lose by trying any more suggestions.
12th February 2014, 04:51 PM |#2  
unubtanium's Avatar
Senior Member
Flag London
Thanks Meter: 55
Originally Posted by Kaine

Mode 7

If memory serves me right this is due to an old version of Recovery, i had the same thing, updated recovery and it flashed zip fine. just as you know.
Post Reply Subscribe to Thread

galaxy s 2, soft brick

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes