Remove All Ads from XDA
Honor 9 Lite

[Q] Network Lock on Galaxy S2 I9100

38 posts
Thanks Meter: 3
By zzsomebody, Member on 13th March 2014, 10:47 AM
Post Reply Email Thread
Hi folks,

I have a pickle of a situation here that I am finding it hard to grasp why this Network Lock continues to plague me.

Seems I cannot manage unlock a Galaxy S2 handset even with the correct IMEI.
Or to understand what exactly is going on here which brief story as follows.

The IMEI number is written on the back of the phone under the battery.
The code *#06# displays IMEI also displays the correct IMEI.

I then go to the Vodafone Site to unlock:

I enter in the correct IMEI number, after I enter the Captcha code and click next, it replies with the Unlock Code for me.

But every time I enter in the Unlock Code that I was given, it returns: Network Unlock request unsuccessful.

I then flash the phone with Odin to a official XSA version, still the same.
I then return to the Voda Rom and its still the same.

Yet, if I use a Voda sim on either Rom it works perfect.

For the life of me, how does one get past this Network sim lock?

Anybody got any ideas to why or how to solve this matter?
13th March 2014, 02:14 PM |#2  
OP Member
Thanks Meter: 3
Ok folks, seems to be moving in the right direction for sorting this out.

Turns out, a friend of mine put his sim in, and entered in passwords causing the lock out.

Got in touch with Voda on the phone, they said the main account holder of the phone needed to request the reset.

As it turns out, the girl whom I also asked for assistance (who I got the handset from) also got Vod to resend a new reset code.

Will take 4 working days there about, so at least the problem will or should be solved.

Failing that, just going to fully flash it to some updated fancy rom

Post Reply Subscribe to Thread

galaxy s2, network lock, vodafone

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes