Remove All Ads from XDA

[Q] Phone doesn't detect SD card

87 posts
Thanks Meter: 10
By raptorjesus1337, Member on 15th June 2012, 06:27 PM
Post Reply Email Thread
Dear XDA'ers.

I've had an S2 for a while now and I've been running CM9 since early alpha. Recently I decided to buy an SD card ( so that I can use it to store my movies. After I got it, I realised that MoboPlayer or AirDroid couldn't detect the SD card and the only way I could put something on it was through a physical USB cable. Now, today I wanted to try something but I found out that my phone doesn't show the SD card at all anymore. I tried taking it out and putting it back in several times as well as flashing the latest CM9 nightly but nothing happened. The only apparent difference that I can see when I put the SD card in is that in the Storage section in Settings, under the SD card tab, I have an option "Mount SD Card" but when I press it, it says preparing SD card yet nothing happens.

Is the SD card fried or what's wrong with it?
I've had the SD card for less than a week so its hard to believe that it's dead already.
15th June 2012, 06:43 PM |#2  
themadba's Avatar
Senior Member
Flag Belfast, United Kingdom
Thanks Meter: 306
Have you got a micro SD card reader that you could use to see if the card is fried? Connect it to your computer, and if it shows up it isn't fried. Also check the format of the card to make sure it is in FAT32 format.


Sent from my GT-I9100 using XDA
The Following User Says Thank You to themadba For This Useful Post: [ View ] Gift themadba Ad-Free
16th June 2012, 05:34 PM |#3  
OP Member
Thanks Meter: 10
Ahh, I know the problem now (I completely forgot about this).
I formated it to NTFS just before I stopped working since I assumed that it works the same way a USB does (but clearly, I was wrong).

I'll format it back and see what's what.
16th June 2012, 06:42 PM |#4  
msquared's Avatar
Senior Member
Flag Milan
Thanks Meter: 236
Have u tried going into settings/memory/left softkey/storage config and select the only options there is?
The Following User Says Thank You to msquared For This Useful Post: [ View ] Gift msquared Ad-Free
17th June 2012, 05:34 AM |#5  
Junior Member
Thanks Meter: 1
have you tried other system folders?
i had the same problem before, I found out my sd card mounted as a system folder called "emmc" I'm using resurrection remix rom 2.3
The Following User Says Thank You to aq12sw23 For This Useful Post: [ View ] Gift aq12sw23 Ad-Free
17th June 2012, 06:25 AM |#6  
-Grift-'s Avatar
Senior Member
Flag Singapore
Thanks Meter: 2,010
Yep just fixed mine today by downloading if you are unsure of what to select just see the screenshots i followed this selections and it now works fine
The Following 2 Users Say Thank You to -Grift- For This Useful Post: [ View ] Gift -Grift- Ad-Free
17th June 2012, 09:18 PM |#7  
OP Member
Thanks Meter: 10
Alright, I've fixed it.

Basically, I had formatted it to NTFS because otherwise it gave me some error about file (the file was around 4 gb's and it acted this way with anything over 3) being too big when I was trying to copy it onto the SD card. Now that someone said it has to be in FAT32, I formatted it back and now it works perfectly.

Thanks to everyone who helped me.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes