Remove All Ads from XDA

[Q] trying to flash with o2 official ROM but odin gets stuck at 'NAND write start' !!

1 posts
Thanks Meter: 0
By chinzie_137, Junior Member on 9th February 2013, 03:23 AM
Post Reply Email Thread
i am facing a serious problem here. i tried to flash my phone, that is galaxy s2 (o2 unlocked) with its original official ROM but the process gets stuck in odin at "NAND write start" (refer image)....ive waited one hour and still there is no progress.... iread it somwhere that i may have to repartition it... so it tried to flash the pit file of galaxy s2 but there also it gets stuck at "SET PARTITION".
also, i can go only to download mode and NOT to recovery mode..... also i cant boot my phone, when i try, it shows "logo.jpg" draw failed.

somebody plz take ur time to read it and hlp me.....THANX in advance !!
9th February 2013, 05:23 AM |#2  
Senior Member
Thanks Meter: 3,229
Whatever you read that said partition it was wrong. You don't flash PIT files unless you have a specific reason to do so/know what you're doing. You obviously don't fall into either of those categories.

I presume you're using Odin 3 ? Don't use it. Find (search Google/XDA) V1.3 & use that. If it still doesn't work first time with that version or if you're already using it, you need to be methodical about tracking down the reason why it's not working:-

*Must run Odin as administrator in Windoze.
*Ensure Kies & it's processes aren't running in Windoze task manager. Kill them if they are.
*Try different USB ports; you must be using a 'powered' or mainboard port.
*Try different USB cables (particularly the cable that came with the phone if you're not using it now)
*Try different versions of Odin (If V3 & V1.3 don't work, get V1.85 & try that; search on here/Google)
*Uninstall Kies, reboot, redownload & reinstall it, reboot, try the flash again.
*Check the rom/kernel you download for corruption. Check the md5 sum, or programs like 7Zip, IZarc, WinRar, etc will allow you to 'test' the rom/kernel file you download. If there are any errors/any of the files fail the test, bad download. Try again/try downloading with a different internet connection if it keeps happening.
*Run Windoze Update.

And if none of the above works, try a different PC. If it won't work first time on another PC, go thru the above steps on that PC.

Still doesn't work ? User error or NAND stuffed; return to Samsung/authorised repairer.

Normally the 'logo.jpg draw' thing is easily fixed if you can otherwise boot your phone, given you can't & can only access download mode, you obviously have to flash a stock rom somehow.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes