Remove All Ads from XDA

[APK] Google Play Store v3.5.16 + MOD

1,722 posts
Thanks Meter: 404
By Deeco7, Senior Member on 4th April 2012, 10:47 PM
Post Reply Email Thread
17th April 2012, 02:05 AM |#111  
Senior Member
Flag Newburg
Thanks Meter: 45
I too can't get it to install. Using AT&T version. When I try to install straight up I get Application Not install. Replacing /system/app version causes it to disappear. Replacing /data/app version causes force closes then upon reboot it disappears. Ideas?

EDIT: Well soon after posting this I found that both the Market and Google Play apps went missing. Removed the com.vending entry from /data/app but left Phonesky.apk on the phone (it's 2.3.6... go figure). Once I did that it still wouldn't come back so I went and cleared cache and dalvik cache with no change. Last I fixed permissions. Once I did that I was able to start to install the Google Play store apks from the op post normally. It still got weird and stuck though so I finally went and cleared data and loaded the app back up giving it permission where prompted and all was golden after that. Still don't know what happened but there you go.

Found that it doesn't work still. Here is an example item.

When you search by the id on the US market it fails to show at all. If you use market enabler to fake the region it just fails at an error occurred. Also I'm finding that it FCs when I try to download and the fix on the op posting doesn't work (file doesn't exist).

EDIT2: In an effort to fix the marketplace on my phone I install the CM7 flashable pack and totally screw myself over on it. Oh well. Guess I'm installing the ICS leak earlier than expected.
17th April 2012, 02:05 AM |#112  
DesignGrits's Avatar
Senior Member
Flag Seattle
Thanks Meter: 1,139
So, how can i tell if i have access to other countries apps, don't see any foreign apps. Can some give a suggestion app that is not in the us?
17th April 2012, 06:08 AM |#113  
Junior Member
Thanks Meter: 0
it didnt work for me, it just remove the banner that said it's not available in my country, when i tried to download, it just give me an error message
17th April 2012, 09:34 AM |#114  
viperdriver2000's Avatar
Flag Berlin
Thanks Meter: 5
i have an viewpad 7e.
i copy the apk to /system/app then i rename it to vending.apk.

after that it works.

apps like facebook i can install now. but only because it is in my history. if i search for it, i don´t find it.
another app i can´t find is slideIT Keyboard and so on...

any ideas to that?

Okay i have tried a little.
google+ app...i can click download but i get a error 940...

greets from germany
17th April 2012, 01:04 PM |#115  
Senior Member
Thanks Meter: 16
Originally Posted by pangiotis24

me too...


LP 7 Lite'ning ROM and Siyah kernel.

This whole app only seems to avoid showing the warning messages about region and device compatibility. It still won't let me install any app that was barred before.

Obviously, it would make sense for Google to control this on the server side, not on the client side. I guess this is exactly what they're doing, so this modded app is pointless. Google knows in which country you are, based on ip address, sim card, credit card.
17th April 2012, 04:56 PM |#116  
Thanks Meter: 1
I killed my gapps.

Tried to install vending-mod.apk

None of gapps works (gtalk, gmail etc.)


* defy using cm9 20120413 nightly

update: fixed. Just patched the from recovery.

Then I uninstalled the orignal gplay using titanium them put the vending.apk in the system/app.

Reboot, open and.... doesnt works...
18th April 2012, 12:24 AM |#117  
Thanks Meter: 0
Originally Posted by Deeco7

Google Play Store (Android Market) v3.5.16
Requirements: Android v2.2+
Overview: Play Anywhere, All your entertainment in one place, Google Play is your one-stop shop for all your favorite entertainment.


- Play Store has becomes lot more faster than 3.5.15,
- Frequent force close errors for the users of Froyo 2.2 has been addressed,
- Works faster even on Slower data speeds,
- Slight UI changes in “My Apps” section
----You now have the Installed and All tabs you can swipe between. The former one is what we used to have before - it lists all apps installed on your device. The latter lists all apps you've ever installed in case you want to download them again or travel down the memory lane. This is quite handy, and I've seen this list before in the Play Store on the web, so it's great to get it here in the mobile app.
----The All tab contains a handy dropdown with all your accounts (if you added more than one) and lets you switch between them very easily (as opposed to clicking Menu, etc).
----A few of the stock apps that apparently never got linked to the Play Store before got identified and picked up this time, and updates.

Mod version features:
- Unlimited access to apps in Google Play Store
- Removed countries restriction in Google Play Store
- Fixed the issue which your device is not compatible with this item in Google Play Store

You should be able to just replace the apk by simply running the package, if not:


Google Play Store v3.5.16

Google Play Store v3.5.16 MOD

it means that i will download Paid apps free ??I don't understand what you call remove country restriction sorry for the question
18th April 2012, 01:07 AM |#118  
Junior Member
Flag changsha
Thanks Meter: 0
Donate to Me
Thumbs up thanks
it's useful thanx
18th April 2012, 02:41 AM |#119  
Thanks Meter: 0
Well done!
18th April 2012, 03:57 AM |#120  
Mario Christian Oquias's Avatar
Senior Member
Thanks Meter: 11
sorry to my understanding this can work with several devices,... anyway i tried this on my nexus s, downloaded the apps from the respective links, tried to install it using root explorer, first and second tries failed, i deleted the phonesky.apk and un installed the updates to play store,...then tried again to install.. it did install though it just reverted back to the original app, which has the restrictions, do i use another account that is based on the us or what was i doing wrong here?
18th April 2012, 04:58 AM |#121  
hermanchb's Avatar
Senior Member
Flag Seremban
Thanks Meter: 51
Originally Posted by Deeco7

Try this:

1) Be sure, your phone is rooted properly
2) Download Root Explorer if you don't have it installed
3)Go to /system/app/ and delete the Vending.apk (Phonesky.apk for ICS 4.x.x) (leave the Vending.odex untouched!). Make sure you have an backup your old Vending.apk (Phonesky.apk for ICS 4.x.x) to your SDCard as well.
4) Install the downloaded Vending.apk (rename it to Phonesky.apk if you have ICS 4.x.x)
5) Reboot your phone
6) Start Play Store and grant the access. You'll be asked to do so
7) Enjoy!

Thanks ~! work for I9100G with no Force Close ~
Post Reply Subscribe to Thread

3.5.16, android, google, play, store

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes