FORUMS

After rooting my camera doesn't work anymore:(

320 posts
Thanks Meter: 18
 
Post Reply Email Thread
hey guys

So I rooted my Exynos S20 Plus after updating it to ATE6 . Since then when I try to open camera I just get "camera error" even after restart.

I tried to use the Samsung service menu and get "unable to connect to camera service" there

Anyone else experienced this and might be able to help?

Thanks!
23rd May 2020, 11:21 AM |#2  
RohanKalra97's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 65
 
More
Did you try resetting your phone once?
If it doesn't work reflash the rom with odin
23rd May 2020, 11:59 AM |#3  
OP Senior Member
Flag Münster
Thanks Meter: 18
 
Donate to Me
More
Quote:
Originally Posted by RohanKalra97

Did you try resetting your phone once?
If it doesn't work reflash the rom with odin

Hey,
thanks for your answer.

When reflashing original firmware: Camera works.
When flashing the "vbmeta_disabled.tar" in USERDATA and the modified "KERNEL-G988BXXS2ATD5" (with Mgisk manager) as AP the camera no longer works, even after two full resets via recovery.
23rd May 2020, 12:15 PM |#4  
RohanKalra97's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 65
 
More
Quote:
Originally Posted by mautz001

Hey,
thanks for your answer.

When reflashing original firmware: Camera works.
When flashing the "vbmeta_disabled.tar" in USERDATA and the modified "KERNEL-G988BXXS2ATD5" (with Mgisk manager) as AP the camera no longer works, even after two full resets via recovery.

"KERNEL-G988BXXS2ATD5" is for the older firmware. Please wait and it will be updated for the latest firmware.
23rd May 2020, 12:21 PM |#5  
Senior Member
Flag Adelaide
Thanks Meter: 196
 
More
If you follow the instructions you can make your own boot.img to suite ATE6. That will fix your camera issues

https://forum.xda-developers.com/gal...e-s20-t4067649
23rd May 2020, 01:15 PM |#6  
OP Senior Member
Flag Münster
Thanks Meter: 18
 
Donate to Me
More
Quote:
Originally Posted by RohanKalra97

"KERNEL-G988BXXS2ATD5" is for the older firmware. Please wait and it will be updated for the latest firmware.

Wow. Sometimes I dont know if my brain is actually active and running or if its just melted or sth.

When I flashed the kernel I "checked" the number and was "ah great, the same". But well I somehow still mixed them up.

After manually packing the new boot image it worked

THANKS!!!!!!!!!
23rd May 2020, 01:15 PM |#7  
OP Senior Member
Flag Münster
Thanks Meter: 18
 
Donate to Me
More
Quote:
Originally Posted by heslo.rb26

If you follow the instructions you can make your own boot.img to suite ATE6. That will fix your camera issues

https://forum.xda-developers.com/gal...e-s20-t4067649

Thanks, those worked like a charm!

If the image could be beneficial to someone please tlel me and will attach!
Post Reply Subscribe to Thread

Tags
camera error, exynos, root, s20 plus

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes