**Ultimate GS3 sudden death thread**

2,023 posts
Thanks Meter: 853
By Obagleyfreer, Senior Member on 15th November 2012, 02:11 AM
Post Reply Email Thread




It seems that at the moment the only devices that have suffered from SDS are the 16GB version with:
FW Rev: 0xF1

To check your eMMC version download eMMC Brickbug Check from Google Play.
What you want is the eMMC version and the FW Rev.

Samsung have now released a Sudden Death Fix via a patched Kernel and Recovery in latest firmware. Firmware Version: XXELKC

Simply update OTA or download XXELKC firmware (or newer) from and flash using Odin.

You need both the stock recovery and kernel installed for it to work properly, or a custom kernel and recovery built from the updated sources
ie Latest Perseus Kernel and PhilZ Recovery are examples

For more info about SDS, who could be effected and how to fix check out this awesome thread by rootSU

For a detailed look at how the fix works check out this thread here.

For those of you in Europe who have rooted your phone it appears that this doesn't void warranty. Check this thread for more info.
Also this website could prove very handy for anyone with a European or UK handset that has died.
The Following 86 Users Say Thank You to Obagleyfreer For This Useful Post: [ View ] Gift Obagleyfreer Ad-Free
15th November 2012, 06:15 AM |#2  
DeadSOL's Avatar
Senior Member
Thanks Meter: 1,807
Okay, here's what just happened to me:

I went to sleep in the night with my phone's battery at around 29%. I just woke up and my phone's home button wouldn't respond. Then, the power button wouldn't respond! I took the battery out and put it back in. It still wouldn't respond! So, I plugged the charger in and then it showed me that it had begun charging. I turned the phone on and as soon as it reached the lock screen, it turned itself off. It did that twice more so I decided to let it rest. Now, it turns on. (>_>)

Apparently, 29% of its battery was somehow consumed last night. I really don't know how!!!! My wifi was on,it seems, but around 30% battery drain in just a few hours?!! That's insane! I'm on stock DL4. Not even rooted!

So it's not a "death" case, per se, but I had a really bad scare.
The Following 2 Users Say Thank You to DeadSOL For This Useful Post: [ View ] Gift DeadSOL Ad-Free
15th November 2012, 06:25 AM |#3  
Senior Member
Thanks Meter: 24
What happened: Went to bed, left phone on charge, woke to the green "fully charged" light, but no response to buttons. Pulled the battery to make it reboot, and now nothing. Neither download nor recovery modes, no charging light, nothing. It's off for repairs.
What ROM/Firmware: Wanam's J5 (which I'm convinced had nothing to do with it.)
What kernel: stock
OV or UV: Nooooo
Where phone was made: No idea
Where battery was made: stock; no idea
The Following 3 Users Say Thank You to UncleBeer For This Useful Post: [ View ] Gift UncleBeer Ad-Free
15th November 2012, 07:12 AM |#4  
Senior Member
Thanks Meter: 46
Seems like a weakness somewhere on the motherboard. Mine died on charge about a month ago. No led no nothing bought in late May. New motherboard working fine. Hoping the problem is identified and fixed now and I don't have the same **** again in three months time.
15th November 2012, 08:13 AM |#5  
Junior Member
Thanks Meter: 8
My story started last Tuesday night. My S3 was working fine: used it as satnav getting to work for night shift and used it a few times at work until I checked it at approx 9:30pm (about three hours into shift) and it was dead - nothing would make it respond.

Got home next morning and my caring wife asks me if it's still the same - I dishearteningly relied that it was. Then she announces that hers was now dead! She had been using hers normally the night before, as I had. She had plugged it in to charge overnight and when she woke in the morning the green light was on, but she couldn't turn it on - she did battery pull, etc, but nothing would revive hers either.

Clearly something has killed our S3's, but not spontaneously as we were in different places at the time of failure. Mine had been happily charging whist I traveled to work and it had over 80% the last time I had noticed / used it before it died - my wife's just died on the charger overnight at our house.

Two dead S3's in the space of 9 hours and I have no idea why...
Both were stock unrooted international models purchased from carphone warehouse at the same time. Both had the recent JB update too (I did both via Kies when it was released).

The only common element I consider could be a cause is the charger we use in our house (but as mine died some time later after being used for several hours away from my house I really don't see any technical explanation for it).

I'm baffled - Carphone warehouse faults tracker now says they have fixed them both and they are awaiting dispatch to our store for collection - maybe they can then offer soom explanation of thefaults / causes.

Either way I reckon I'll bin the "common" charger as a "just in case"!
The Following 5 Users Say Thank You to ph512 For This Useful Post: [ View ] Gift ph512 Ad-Free
15th November 2012, 09:26 AM |#6  
Obagleyfreer's Avatar
OP Senior Member
Flag Wellington
Thanks Meter: 853
That's really odd that both yours and your wife's phones suddenly died at around the same time.

Do you share a charger?
Can let us know some details about both phones, where phones and batteries were made etc

It appears, from what I can gather, that it is a hardware fault. The ROM and kernel don't seem to matter. People's phones are dying regardless of which ROM they're running.

At least CPW have fixed both your phones for you

Maybe you could ask if they have had a few customers bringing back dead phones?

It'll be interesting to know what their technicians say about it.

Sent from my GT-I9300 using xda app-developers app
The Following User Says Thank You to Obagleyfreer For This Useful Post: [ View ] Gift Obagleyfreer Ad-Free
15th November 2012, 09:55 AM |#7  
Ausboy 2011's Avatar
Senior Member
Thanks Meter: 502
this is happening a lot to people... I hope Samsung do something about this!!

Sent from my GT-I9300 using Tapatalk 2
The Following User Says Thank You to Ausboy 2011 For This Useful Post: [ View ] Gift Ausboy 2011 Ad-Free
15th November 2012, 10:08 AM |#8  
Thanks Meter: 4
What happened: Used as Satnav, it was charging on a 1A car charger, battery probably pretty full. Brought it in tried to turn it on and nothing happened. Had a white pulsing LED, after battery pull no reaction.
What ROM/Firmware: CM10
What kernel: Can't remember
OV or UV: Nope
Where phone was made:
Where battery was made: Standard battery but I do use a Anker battery as well, can't remember if it was in the phone at the time.

On the bright side, I have just got it back from Samsung who repaired it without question. They have also given me a 32GB model instead of the 16GB I had before.

Very happy dervish.
The Following 3 Users Say Thank You to dervish666 For This Useful Post: [ View ] Gift dervish666 Ad-Free
15th November 2012, 10:24 AM |#9  
Senior Member
Flag Melbourne
Thanks Meter: 53
I know it is a hassle, but could people please post where their phone came from (language which was default on phone might be good, for example mine was Greek). Might allow us to isolate a particular region/batch
15th November 2012, 11:04 AM |#10  
Junior Member
Thanks Meter: 8
Originally Posted by tqgia2

I know it is a hassle, but could people please post where their phone came from (language which was default on phone might be good, for example mine was Greek). Might allow us to isolate a particular region/batch

My 2 S3's were purchased at the same time from (CPW) - English language by default, unlocked and with no network branding. I had not tampered with these devices in any way. They are totally stock handsets running JB (updated via Kies). They were only used with the Samsung chargers too. Mine had approx 100 apps on it, but my wife hardly had any on, just about twenty or so.

I'll update this page once I get them back so we can share the causes / fixes in my case
The Following 3 Users Say Thank You to ph512 For This Useful Post: [ View ] Gift ph512 Ad-Free
15th November 2012, 03:24 PM |#11  
Junior Member
Thanks Meter: 0
What happened:

Phone was charging on Zenis dock. Checked it at 95% and returned 1 hour later to find it stuck on Samsung boot screen. Had to remove battery to unfreeze it. Phone would not boot and stuck on Samsung screen. Would only boot into Download mode but would not accept any relash of OS via Odin. Reflash attempts met with Invalid PIT partition fault. Tried to reflash a PIT as advised on XDA but with no success. On connection to charger phone displayed grey battery graphic.

Handed into Samsung service centre who confirmed battery was completely dead and that new battery allowed phone to turn on but no ability to reload software. Phone now has been sent to Samsung in the UK

What ROM/Firmware:Stock T Mobile 4.1
What kernel: STOCK
OV or UV: Nope
Where phone was made: UK model bought in June 2012 from
Where battery was made: Dont Know

Phone is English language version and has run fine for months. It was updated via OTA to 4.1 about 2 weeks ago when Tmobile released the ROM. since then I re-rooted it but have never flashed any other ROM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes