Remove All Ads from XDA
Honor 9 Lite

[Q] Can't ADD a Google account on my android

1 posts
Thanks Meter: 0
By Weareborgs, Junior Member on 12th June 2014, 07:49 AM
Post Reply Email Thread
Newbie at using Android here;
I have Galaxy S3 I9300, that was working fine until i rooted it and did bad manip with Titanium Backup !
It started to mess up, so i looked everywhere to fix it , tried everything and even finally unrooted phone; no joy.
Then i read; "Factory reset your phone" (which is Not the best solution), that i did ..; no joy there again !!

Phone won't go into Playstore due to the fact ; i cannot ADD on phone My Google account due to ( "Can't establish a reliable connection.."), also i tried to add New Google account; then phone says " name already taken, even if i typed ; " " !!

I then; Wiped data, Cache, partition etc ; No joy there either ..??

I'm pretty sure that it is nothing much to do ..but i do not know what it is ..
from what i read it can be a common problem but solutions varies
Does anyone having done all i've done found The Solution ..?
12th June 2014, 09:09 AM |#2  
boomboomer's Avatar
Senior Member
Thanks Meter: 826
You've corrupted the firmware. Flash a full stock rom with Odin then factory reset.

Sent from my GT-I9300 using Tapatalk
13th June 2014, 05:43 PM |#3  
Junior Member
Thanks Meter: 0
Wink Try this method
You should create a gmail account at then try to log into your phone using the account you create at Maybe this will work.

Please Hit The Thanks Button. Thank you.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes