FORUMS

[Q] Blocking mode not working with whatsapp?

12 posts
Thanks Meter: 0
 
By Aleph72, Junior Member on 30th November 2012, 06:39 AM
Post Reply Email Thread
Hello.
I'm using a German version of the Galaxy S3 with stock 4.1.1 ROM.
I own it since few days, coming from iPhones and I'm still learning how to use it.

One very useful thing I've found is the blocking mode. I use it at night to stop notifications sound and to permit only my family calls to go through.
Whatsapp notifications, though, are still coming through and I'm forced to manually reduce the notifications volume to zero.
Is it a bug or am I missing something?
I've tried setting the blocking mode with both time range and "always", but no differences at all.

Thanks.
30th November 2012, 04:47 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I was woken up this morning by whatsapp messages, so if anyone has an answer it'd be appreciated.
3rd December 2012, 03:28 AM |#3  
Junior Member
Thanks Meter: 0
 
More
I am having the same problem.. i think the problem is with whatsapp itself it must be a bug as when u go to notification settings the "ringer" whats comes up as default tone not the notification tone.

hope this get resolved quick! i have emailed whatsapp but got standard email template... delete app ... reboot re install ..etc
23rd December 2012, 12:06 AM |#4  
Junior Member
Thanks Meter: 0
 
More
No one has a solution?
I have the same problem but a month or two before it did worked. I guess that maybe an update of whatsapp has disabled this. It very annoying waking up because of that horrible whatsapp noise.
23rd December 2012, 07:56 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Update
Just installed JB 4.1.2 and the problem is still there.
So it seems to be a Whatsapp problem, and it's a very stupid management of the notifications.
The notifications should be managed by the system and if the system says "shut up" ALL notifications should comply.

For me this is a point in favor of iOS.



P.S.: not a fan boy of course. I own both devices and it's normal I compare them.
23rd December 2012, 08:40 AM |#6  
Inactive Recognized Developer
Flag Jerusalem
Thanks Meter: 5,548
 
Donate to Me
More
WhatsApp uses a different method to sounf notificiations, this is why it can sound notifications even playing music (other apps would mute/pause the music for the notification)

I guess someonr could patch WhatsApp, my smali knowledge isn't that good to do it myself.

Sent from my GT-I9300 using xda app-developers app
23rd December 2012, 08:48 AM |#7  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by MohammadAG

WhatsApp uses a different method to sounf notificiations, this is why it can sound notifications even playing music (other apps would mute/pause the music for the notification)

I guess someonr could patch WhatsApp, my smali knowledge isn't that good to do it myself.

Sent from my GT-I9300 using xda app-developers app

I understand, but if Google implements a kind of "do not disturb" mode it should know that some apps can use music as notification sound and block that too...
jaykrishna94
23rd December 2012, 08:56 AM |#8  
Guest
Thanks Meter: 0
 
More
Problem lies with whatsapp. I did mail them about it, no response :/ m forced to put my phone on silent always :/

Sent from my Liquid using xda app-developers app
11th April 2013, 11:25 AM |#9  
Junior Member
Thanks Meter: 2
 
More
[SOLUTION] Blocking Mode WhatsApp Sounds
First of all, I do know that this is a fairly old thread, HOWEVER, it is still the first result on google for "blocking mode whatsapp", so i figure this is where people look. So i hope you will forgive me.

I have found a solution to the very annoying problem which many people seem to suffer from.

I have found a way to include the whatsapp sounds under the android blocking mode.

You will need the LightFlow app, (which i believe is a must have app for the S3 anyways (OP said he uses a s3)).
after you got light flow:

1: In What's app:
- disable notification sounds for incoming messages(not in light flow, in whats app). set it to silent or disable at all

2: The go to light flow and:
- enable sound notifications for whats app
- set what ever notification sound you would like to have for whats app when blocking mode is NOT enabled
- under Sounds-->Volume control method-->tick "Android standard notification volume"

Now it you enable blocking mode, it also blocks what's app sounds and if blocking mode is disabled, everything is normal.

hope that helps....took me quite a while to figure it out.

edit: oh and i do not have any affiliation with the light flow app or their developers!!! i just used it for changing lights and came across the sound feature by chance!!!
The Following 2 Users Say Thank You to tyler_d_ For This Useful Post: [ View ] Gift tyler_d_ Ad-Free
22nd May 2013, 02:47 PM |#10  
Member
Thanks Meter: 0
 
More
its a shame. other blockers block it, why can't the native JB also do it?

furstrating. didn't want to install another software on the phone when the block mode works so well, except for whatsapp of course.

Does this exist with 4.2.2 as well?
30th August 2013, 12:18 AM |#11  
Junior Member
Flag Leicester
Thanks Meter: 1
 
More
Quote:
Originally Posted by slocko

its a shame. other blockers block it, why can't the native JB also do it?

furstrating. didn't want to install another software on the phone when the block mode works so well, except for whatsapp of course.

Does this exist with 4.2.2 as well?

Yeah, I've got a Nexus 4 on 4.2.2 and the issue is on that as well. It's a problem with the way whatsapp handles notifications, not the Android firmware version.

Thanks Tyler D for the solution, will be testing this later today.
Post Reply Subscribe to Thread

Tags
blocking mode, whatsapp

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes