Remove All Ads from XDA
Honor View 10

[Q] help a noob, efs folder vanished, failed to mount. tried many things

1 posts
Thanks Meter: 0
By saagy8, Junior Member on 14th February 2014, 06:46 PM
Thread Closed Email Thread
Hi guys, firstly I'd just like to say I have followed all the protocol that is required on here and been reading and researching/ applying fixes for the past few days now. I have tried to help myself as far as i possibly can but i am still having no luck and i don't think too many people have had the exact similar issue after reading all the other threads that are similar to my issue.

with some of the fixes it is my first time using them as i have never needed to in the past, so bare with me if my level of understanding isn't as great in some departments.

Now onto the issue:

I own a galaxy s3 i9300 and it has been rooted on stock rom since day 1 about a year ago. A few days ago my phone battery died, and when connnected to the charger it had this grey icon with a circle. It wouldn't boot up either so after searching on the net i thought i would listen to the advice of clearing the cache etc etc but this didn't work and neither did the wipe data/dalvik in CWM.

So i reflashed a stock jellybean rom and it worked fine.

It was then at this stage i thought i might as well upgade to a custom rom as every galaxy i had owned before i had done it on, and my current Note tablet is also running custom rom.

I first loaded a stock 4.3 rom and then flashed the slimbean 4.3 with gapps ...and it worked perfectly. I found a couple of issues with the browser which i use a lot so i downgraded to a 4.2.2 version of slimbean with gapps and this made the browser really fast again and all was perfect.

I had been using this for two days or so and everything was smooth, including charging etc until one night it had that same grey battery icon again with the circle and would get stuck booting at the samsung logo.

So as this had happened before i thought i would just flash a stock rom....this is where it all started going mad

Bearing in mind, every flash i always did it properly and wiped cache/dalvik cache and wiped data three times for each one just to make sure as i didnt have anything of value so wanted a fresh wipe each time and didnt need to back anything up.

now before i get flamed i realise i made a huge stupid error in not backing up my efs folder before hand as i had done with every previous phone but because i was under pressure to get it working it skipped my mind totally.

So i flashed a stock jellybean 4.2.2 rom and still bootloop with the EFS not found invalid argument error
i flashed a 4.3
i flashed a 4.1
i flashed a different 4.1
i flashed a different 4.2
i tried loads but nothing worked

so after reading that this would not help as it doesnt touch the efs i looked into fixes that others had done

i tried to follow this

So i downloaded efs professional / adb tool
i downloaded busybox
and cwm was already on the phone but i downloaded philz cm incase i needed that too

now as the phone doesn't turn boot up i can't access anything, i can only access download mode and CWM.

When i open efs professional it says current device offline, turn on allow usb debugging to confirm your phones RSA fingerprint and click ok.

I have no idea what to do about that because i can't get into the phone.

Regarding busybox i have no idea how to get that to install on the phone, i have tried writing some stuff to push it in the adb shell (but because its my first time using adb shell and command prompt i have no idea if i am doing it correctly). Can you install it with odin?

also regarding adb shell i followed the guide and got into root@android and SU....and then when on the phone in cwm i clicked mount efs...and obviously it failed. I went into the log as said and /dev/block/mmcblk0p3 was the file it failed to mount

the thing is everything after that step doesnt work, as i can't create an image of mmcblk0p3 as it says it can't find it as if it doesnt exist.

So im screwed as it effectively is saying i don't even have that file or efs folder i think?

The thing is i never had any issue with losing imei or anything like that at all and this just happpened out of the blue without me doing anything as such

any ideas?.....would be HUGELY appreciative for anyone willing to take the time out and help me with this as i'm not sure i can explore any more avenues on my own with my limited knowledge and at the same time don't want to give up.

PS. I also have access to a galaxy s3 i9305 ....and can possibly try and source another i9300 from a family member IF this helps in any way or makes life easier?
14th February 2014, 07:39 PM |#2  
Senior Member
Thanks Meter: 5,558
Stickied faqs and guides .
service centre repair is your best choice if you have read and tried the stickied fixes .
14th February 2014, 07:41 PM |#3  
boomboomer's Avatar
Senior Member
Thanks Meter: 827
Reads like efs partition corrupted and your phone was already suffering with nand memory issues.

There is no substitute for an efs backup, you cannot recreate the unique information it contained.

Take it to a reputable repair centre, they will be able to get it back to normal, but you are still left with why it keeps corrupting -which may require a new motherboard.

Sent from my GT-I9300 using Tapatalk
14th February 2014, 07:46 PM |#4  
malybru's Avatar
RC-RT Committee / Senior Moderator
Thanks Meter: 21,347
Donate to Me
Mod Edit

Please refer to ,and post in the stickies in the General section.

Thread closed

Forum Moderator
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes