Remove All Ads from XDA

[Q] Modem problem perhaps?

4 posts
Thanks Meter: 0
By Hyperborean, Junior Member on 14th February 2014, 05:27 PM
Post Reply Email Thread
The more I read the more confused I get. I have had a thread going on Sammobile that got quite long but did not lead to a solution.

This phone is a replacement phone from an insurance company. The original phone was Tmobile UK contract and locked that way. It was replaced by the insurance company as the first one had sudden death.

This replacement phone stopped charging or being recognised on the USB and went back to Samsung, they declared "liquid ingress" and refused to do anything. It then went "somewhere" for god knows what and was returned and I was asked to have a look at it.

Originally it had 4.04 on and was never updated from that, on return it had 4.3 on and doesn't work (emergency calls only).

I ripped it to bits and mended the USB problems then started looking into why the phone doesn't work. Kies reports that the phone is SFR, not TMU. As this phone was Tmobile and locked to them I can only assume that the insurance company bought some cheap and put the Tmobile software on which meant that when the firmware was updated it locked to SFR. (brain fading about now)

I rolled back the software with Tmobile software but (of course) this leads to a knackered IMEI. I have tried the latest SFR software expecting that even if it is locked to SFR I should get an unlock request box when I stick another SIM in, I don't get that option and even if I did I couldn't get an unlock code from SFR as it isn't one of their phones. I have tried using Kies to update using the serial from a couple of phones that are identical to this one, one Tmobile (EE) and one Orange (EE) expecting that something should work but all to no avail, no matter what SIM I stick in or what image I put on I get the same result every time. The IMEI is correct if I have a 4.3 image on and in the network list it finds all the mobile providers fine and it does say connected to network if I select any of them, the display on the notification bar shows it with signal.

I can root it and stick CWM on though currently it isn't that way. I can get SSH once that's done though it does seem somewhat flaky on SSH.

So, in a nutshell the phone doesn't bleeding work and I'm getting close to launching it out of the window. The only thing stopping me is that I know that someone here knows how to get it going.

So let me know what needs to posted in terms of numbers or screenshots and I'll stick them up here.

Thanks for not dying of boredom reading that epic.
14th February 2014, 07:44 PM |#2  
Senior Member
Thanks Meter: 5,500
Check modem csc and APN setttings .

Network IMEI EFS

Downgrade and network problems .
14th February 2014, 09:02 PM |#3  
OP Junior Member
Thanks Meter: 0
Check what on the CSC and APN and how?

I tried the second link in your post, I now have no IMEI at all.
14th February 2014, 11:37 PM |#4  
OP Junior Member
Thanks Meter: 0
OK did it again. Updated using Kies "Firmware upgrade and initialisation" to put SFR 4.3 on.
Used Kies to load I9300XXELLA Tmobile 4.12 from SamMobile.
Used the modded modem in your second link.

Happily connected to Orange and working.

Thanks for the input.

I am sure I have done all that before and the first time I tried it this evening it lost my IMEI but the second time it all worked fine. End of an epic. Back to normal life now and this phone is never getting an update of any sort ever again, month of my life down the pan never to return and at 58 years old there aren't that many months left.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes