Remove All Ads from XDA

[Q] (Q) Odin stuck at setup connection

3 posts
Thanks Meter: 0
By beozie, Junior Member on 11th June 2012, 04:31 AM
Post Reply Email Thread
Just got a new Samsung Galaxy S3 and I've been trying to do the quick CF-root

- Model Number GT-I9300
- Baseband Version: I9300XXLE8

Its completely stock, I wanted to root it particularly to get rid of the bloatware. To the best of my knowledge I've done everything correctly.

USB debug on
No Kies running in the background
Odin detects the phone connection when in download mode ("added" appears)
pick the .tar file, make sure repartition is unchecked
hit the start button and it gets stuck at "setupconnection" in Odin.

Also tried running odin in administrator mode taking out the battery for a while to no avail.

Your advice is much appreciated.
11th June 2012, 04:40 AM |#2  
Plexicle's Avatar
Senior Member
Flag Tampa, Florida
Thanks Meter: 549
Try a different USB port.
The Following User Says Thank You to Plexicle For This Useful Post: [ View ] Gift Plexicle Ad-Free
11th June 2012, 05:17 AM |#3  
Account currently disabled
Flag Phuket, Thailand
Thanks Meter: 15,911
Donate to Me
Do not connect through USB hub
Try another port (as previous post)
Another USB cable
USB debugging on
KIES process not running in PC tsk manager

Could also try uncheck "reset time"

Sent from my GT-I9300T using xda premium
The Following User Says Thank You to UpInTheAir For This Useful Post: [ View ] Gift UpInTheAir Ad-Free
18th June 2012, 06:39 AM |#4  
OP Junior Member
Thanks Meter: 0
Sorry to take so long to reply. I've tried all the above except untick reset time.

An interesting note is that I recently tried to flash my Samsung Galaxy S1 as well and it comes up with the same problem. I kind of gave up on the matter and accepted that I can't root my S3, for now anyway.

Any further information would be grateful but not a priority for now.
18th June 2012, 06:43 AM |#5  
Baldilocks's Avatar
Senior Member
Flag Dover, DE
Thanks Meter: 1,084
Donate to Me
Have you tried the other rooting method??
18th June 2012, 07:10 AM |#6  
Account currently disabled
Flag Phuket, Thailand
Thanks Meter: 15,911
Donate to Me
Odin v3.04
Try the latest version of Odin:

NEW: ODIN v3.04

and or

1. try a different PC
2. reinstall drivers
The Following 2 Users Say Thank You to UpInTheAir For This Useful Post: [ View ] Gift UpInTheAir Ad-Free
18th June 2012, 09:04 AM |#7  
Arsaw's Avatar
Recognized Developer
Flag Kuala Lumpur
Thanks Meter: 6,023
Donate to Me
I do have similar problem but that's because I wasn't in download mode. Are u sure u in download mode?

Sent from my GT-I9300 using XDA
18th June 2012, 09:08 AM |#8  
Thanks Meter: 18
This happens to me too (new unlocked S3)
I had also given up but then I figured out how to get past it by accident:
When it is stuck, just unplug the USB cable, then plug it back in, and ODIN happily kicks in and does the flash with a successful PASS result.
Done it quite a few times now.

Jsut a weird quirk of the S3 it seems (my old Note was fine).

BTW I tried different USB ports, nonhubs, cables, ODIN183, 187, 304 etc. All did same, until I found this trick, and BTW I am actually flashing via a hub now and it works fine with this trick.

Hope this helps.
The Following 6 Users Say Thank You to asifanwaruk For This Useful Post: [ View ] Gift asifanwaruk Ad-Free
18th June 2012, 10:14 AM |#9  
OP Junior Member
Thanks Meter: 0
Yup, certain I was in download mode.

Wow the trick worked, very interesting.

thank you very much asifanwaruk, and to everyone else who replied.
11th July 2012, 01:02 PM |#10  
Junior Member
Thanks Meter: 7
Closing all Kies processes via the Task Manager did the trick for me. Thanks!
11th August 2012, 10:57 PM |#11  
andy572's Avatar
Recognized Developer
Flag Germany, Munich (Deutschland, M√ľnchen)
Thanks Meter: 3,951
Hi all,

i flashed at first the "normal" CWM recovery via heimdall on win7, and after it didnt work for latest CM9 nightlies, i was trying to
install the "touch" version ... after the "PASS" in Odin3, the device rebooted ... but after going to the recovery again, i ended up
in the old CWM one ... can someone help me out to re-install a working recovery?

thanks for help
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes