Remove All Ads from XDA

[Q] S3 i9300 Camera Failed

33 posts
Thanks Meter: 3
By Tweetix, Member on 2nd April 2014, 05:41 PM
Post Reply Email Thread
Hi everyone,
I'm posting here because I think that XDA is the place where I will get most usefull answers.
Few days ago, I tried to take a picture (as all days) but the camera app crashed.
I tried another one, but it crashed too : could not connect to camera, or anything like this...

I tried everything : full wipe, kernel change, rom change, stock rom, nothing worked...
A friend gave me the permission to disassembly his S3 :
I plugged his camera module on my motherboard : didn't worked
I plugged my camera module on his motherboard : worked...

When i'm on a stock rom and i want to launch the tool that give us informations about the firmware of the camera it crash too...

I'm going to become crazy with that...

Does anyone see anything that I forgot ?...
Thanks in advance, and sorry for my bad english...
3rd April 2014, 06:59 AM |#2  
kunal1540's Avatar
Senior Member
Flag City of oranges
Thanks Meter: 525
You are by any chance using stock 4.3 ROM..
If you are using then I think you should flash a stock kernel then open camera and take a pic and then flash kernel of your choice..
You mentioned that you changed kernels but did you flash any stock kernels if not you should try this...

Sent from my GT-I9300
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes