Remove All Ads from XDA

[TUTORIAL] on Root/Recovery/Custom ROM Galaxy S4 (I337z) Cricket Wireless/Aio

17 posts
Thanks Meter: 11
Post Reply Email Thread
Hey guys,
After working on my Cricket/Aio Galaxy S4 for days and finding very little development tips, I decided to write my own full guide on how to root, install a custom recovery (TWRP) and flash a custom ROM for the SGH-I337z.

Before we begin, I am not responsible for any damage, including physical damage due to frustration, that you may inflict on your device. If at the end of this, your phone is nothing but an expensive paperweight, I must apologize, but assume no responsibility. If you are not comfortable using Odin or flashing ROMs, I suggest reading a little more on the subject before moving forward. This is a detailed guide for a specific device that is difficult to find help for. This isn't a step by step guide for a first time flasher. You have been warned.

First, download and install the Kingroot apk. Do a quick Google search for this. It is a Chinese root method that I know for a fact works, where Kingoroot and Towelroot fail. Trust me, I tried Kingo and Towelroot just as many times as you. It also installs it's own sub-par version of Superuser called Kinguser. Nothing great, but it gets the job done. If you only want root, you are done. Install the app, run the app, run Root Checker. From here you can uninstall system apps, overclock, etc. Keep in mind, if you uninstall either of these, you lose root access.

If you want a custom recovery/ROM, here's how:
First thing I did was flash the recovery. But it has locked bootloader right? Right. So we are going to Odin flash the recovery. Although it is a custom recovery, flashing through Odin will allow you to bypass the bootloader lock. First, you will want to download the recovery image.
Now put this somewhere you can find it.

Next you will need to download the .tar converter tool and convert this .img file you just downloaded into a .tar.md5 file so that Odin can flash it. There are instructions in the link and it is very simple.

Once you have converted the img, Open Odin, and boot your phone into download mode by holding Volume down and power, and plug it in. Odin should notify you it has been "Added!" Select PDA, and navigate to the recovery img that you just converted to the tar file. Select this file, then make sure Auto Reboot is the only other box checked, and hit start. It should only take a few seconds, and you should be greeted with a "Success" message. Allow the phone to reboot into recovery. It should do it manually, but if not, boot into recovery by holding Volume Up+Home+Power. It should load the TWRP splash screen. If this happens, it was all successful.

That is the hard part honestly. Once you're recovery is installed, you're golden, Pony Boy. Download a compatible ROM and install the zip via TWRP recovery. Unfortunately, from what I understand, Touchwiz based ROMs are the only ones compatible with this method. I am using Skyfall as suggested in another thread I saw, and it is great. Looks just like stock, but enables Wifi Tethering (which Cricket currently blocks) and comes with a couple other cool features. It also uses Aroma installer which allows you to customize the installation, meaning you can choose to have Xposed Modules and Wanam Xposed installed by default, and NONE of the Samsung apps from default.
Here is the link for a ROM that I know for a fact works flawlessly:
KEEP IN MIND---Cricket/Aio must install the AT&T variant from Aroma installer. Others may work, but this is the only one I can confirm. Internally, they are the same phone. LTE, Wifi, Bluetooth all confirmed working.
The Following User Says Thank You to Prozach45 For This Useful Post: [ View ] Gift Prozach45 Ad-Free
18th April 2016, 01:18 AM |#2  
Junior Member
Thanks Meter: 0
Following the steps provided everything worked up until I reached odin. I downloaded and converted the jflteaio_twrp.img to jflteait_twrp.tar.md5 and my phone has root access provided by kingroot.

I tried using Odin3 v3.04 3.07 and 3.10.7 no matter the version always following "<ID:0/005> NAND Write Start!!" I see "<OSM> All threads completed. (succeed 0 / failed 1)".

I know this post was last updated June 30th 2015 so my versions of Odin should be working. Please help, Thanks
19th April 2016, 06:36 AM |#3  
Junior Member
Thanks Meter: 0
Try using Heimdall Suite to flash recovery. Once downloaded unzip file to desktop. Follow these instructions next.
- Boot the Galaxy S4 into download mode (Vol Dwn + Pwr Up).

- Run zadig.exe from the Drivers folder of the Heimdall Suite.

- Choose Options > List All Devices from the menu.

- Select MSM8x60.

- Click Install Driver.

- If prompted with a warning the installer is unable to verify the publisher of the driver, select Install this driver anyway. Further prompts about security may pop-up, select the options which allow the installation to continue.

- Place recovery image in heimdall folder(rename the img to recovery.img) Do not covert img to tar it needs to stay as a img file.

-Next open command window inside the Heimdall folder you unzipped by holding shift and right clicking. Then select open command window here. In the command window type the following.
(heimdall flash --RECOVERY*recovery.img) .Once it's finished the phone should reboot. Let it reboot if it doesn't just do a battery pull and reboot into recovery mode by pressing volume up+home+power .Once it's finished the phone should reboot. Let it reboot if it doesn't just do a battery pull and reboot into recovery mode by pressing volume up+home+power. That should work.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes