Remove All Ads from XDA

[Q] Odin says "PASS" but root checker says "not rooted"..HELP!

2 posts
Thanks Meter: 0
By survivor12006, Junior Member on 1st July 2014, 02:32 AM
Post Reply Email Thread

I signed up just to get help because I'm extremely frustrated.I have gotten the Kit Kat update for my t-mobile s4 and now I can't root my phone again. I have tried to root my phone using Chainfire Auto root md5 file (jfltetmo-sghm919.tar.md5) & Odin 3.09. I have follow the simple directions as I'm done several times before to flash the root files onto my phone then Odin tells me that it passed. but when i tested with root checker app, the app along with other apps that request superuser permissions, tells me that my device is not rooted. I have tried to root my phone several times using different computers and I have no clue why my phone will not root. in download mode my device states that the knox void has been tripped & the binary is custom. this leaves me scratching my head please help!
1st July 2014, 02:48 AM |#2  
Kriptik210's Avatar
Senior Member
Crystal River
Thanks Meter: 158
What firmware is on your phone?

Sent from my SGH-M919 using XDA Premium 4 mobile app
1st July 2014, 05:22 AM |#3  
serio22's Avatar
Senior Member
Flag Houston
Thanks Meter: 1,143
Have you updated the binary? You could also try using towel root
4th July 2014, 03:16 AM |#4  
Skipjacks's Avatar
Senior Member
Flag Baltimore
Thanks Meter: 4,348
Try downloading a recovery from CWM or TWRP in TAR format and flashing that in Odin.

That will give you a custom recovery.

Then boot into recovery and flash a from there. (If you use TWRP recovery you don't even need the TWRP will tell you that you aren't rooted when you boot it and ask it you want TWRP to root it for you.)
4th July 2014, 03:45 AM |#5  
OP Junior Member
Thanks Meter: 0
Red face

Thanks for all the responses... I solved it.. somehow my update for kit-kat via kies prevented me from rooting my phone again. But when I flashed the stock kit-kat update onto my phone using odin, the rooting process using the auto root file from chainfire & odin work! So this solution may work for others...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes