FORUMS
Remove All Ads from XDA

Not Impressed...

203 posts
Thanks Meter: 160
 
By Velrix, Senior Member on 22nd April 2017, 10:33 PM
Post Reply Email Thread
From the 2 hours so far with my S8+ (Had to get it for temp until my UK variant comes in).

I am using the ATT variant and am hoping my Exynos version will not lag as bad as this damn thing. My Axon 7 with stock rom just rooted ran circles around this thing.

Pull the notification menu down = dropped frames
Scroll apps drawer = dropped frames
Animation and Transition effects at 1x = Choppy dropped frames

Everyone keeps saying it's a myth that Samsung's software is not bloated and slow anymore like TW days but I am not impressed this far.

I'm torn because this phone is really beautiful hardware with just slow software.


*Edit* looks like this almost non existent on the Exynos variant so I'm pleased now.
The Following 2 Users Say Thank You to Velrix For This Useful Post: [ View ] Gift Velrix Ad-Free
 
 
22nd April 2017, 11:07 PM |#2  
Zer0_'s Avatar
Senior Member
Flag Toronto
Thanks Meter: 280
 
More
Quote:
Originally Posted by Velrix

From the 2 hours so far with my S8+ (Had to get it for temp until my UK variant comes in).

I am using the ATT variant and am hoping my Exynos version will not lag as bad as this damn thing. My Axon 7 with stock rom just rooted ran circles around this thing.

Pull the notification menu down = dropped frames
Scroll apps drawer = dropped frames
Animation and Transition effects at 1x = Choppy dropped frames

Everyone keeps saying it's a myth that Samsung's software is not bloated and slow anymore like TW days but I am not impressed this far.

I'm torn because this phone is really beautiful hardware with just slow software.

You must be very unlucky because I have zero lag. Been using it for over a week and have not experienced any lag in any of the 130+ apps i've installed.
You might have some faulty version of the phone.

Wish you better luck with your Exynos version
The Following 10 Users Say Thank You to Zer0_ For This Useful Post: [ View ] Gift Zer0_ Ad-Free
22nd April 2017, 11:14 PM |#3  
OP Senior Member
Thanks Meter: 160
 
More
Quote:
Originally Posted by Zer0_

You must be very unlucky because I have zero lag. Been using it for over a week and have not experienced any lag in any of the 130+ apps i've installed.
You might have some faulty version of the phone.

Wish you better luck with your Exynos version


The fact it's been present on Best Buy display models, T-Mobiles display and this phone I doubt that. It seems to happen more when running in WQHD for what it's worth. I have disabled a **** ton of bloat with package disabler and it's still not as smooth as the Axon 7 was not my 6s+.
23rd April 2017, 12:00 AM |#4  
mlock420's Avatar
Senior Member
Thanks Meter: 629
 
More
Quote:
Originally Posted by Velrix

The fact it's been present on Best Buy display models, T-Mobiles display and this phone I doubt that. It seems to happen more when running in WQHD for what it's worth. I have disabled a **** ton of bloat with package disabler and it's still not as smooth as the Axon 7 was not my 6s+.

I'm on tmobile with highest graphic settings no red tint of death and no lag everything is fast at the moment... maybe you got a lemon?

---------- Post added 23rd April 2017 at 12:00 AM ---------- Previous post was 22nd April 2017 at 11:58 PM ----------

and I've had my phone since 4/19 or 4/20 can't remember
The Following 3 Users Say Thank You to mlock420 For This Useful Post: [ View ] Gift mlock420 Ad-Free
23rd April 2017, 12:03 AM |#5  
Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by mlock420

I'm on tmobile with highest graphic settings no red tint of death and no lag everything is fast at the moment... maybe you got a lemon?

---------- Post added 23rd April 2017 at 12:00 AM ---------- Previous post was 22nd April 2017 at 11:58 PM ----------

and I've had my phone since 4/19 or 4/20 can't remember

Yep...same. tmobile, highest settings, and absolutely zero lag
The Following 2 Users Say Thank You to FokenNewbee For This Useful Post: [ View ] Gift FokenNewbee Ad-Free
23rd April 2017, 12:05 AM |#6  
OP Senior Member
Thanks Meter: 160
 
More
Quote:
Originally Posted by mlock420

I'm on tmobile with highest graphic settings no red tint of death and no lag everything is fast at the moment... maybe you got a lemon?


The phone is not a *lag fest* it just drops frames and it's noticeable to the naked eye. For instance pull the notifications menu down to your quick shortcuts and collapse the entire menu back to the home screen, you can notice frame drops for that 1 sec function. It's not as fluid as the expansion itself.

Screen transitions such as the fade out to home I see it ever so slightly. It's not laggy as in the cpu/ram is over worked it's just a bloated launcher and possibly ****ty/suboptimal cpu/gpu scheduler.

The only reason I notice this specifically as it's what originally drove me from Samsung years ago. Well that and the locked bootloaders.

We shall see if it's as noticeable with the Exynos variant when it ships out this week.
The Following User Says Thank You to Velrix For This Useful Post: [ View ] Gift Velrix Ad-Free
23rd April 2017, 12:07 AM |#7  
MicroMod777's Avatar
Recognized Contributor
Flag Los Angeles
Thanks Meter: 4,484
 
Donate to Me
More
Lag? My rippin lightening fast! Had all the other tech guys at my job also blown away with its speed and fluidity. Blows away Apple too.

Sent from my SM-G955U using Tapatalk
The Following 5 Users Say Thank You to MicroMod777 For This Useful Post: [ View ] Gift MicroMod777 Ad-Free
23rd April 2017, 12:11 AM |#8  
bigcid10's Avatar
Senior Member
Flag West Palm Beach
Thanks Meter: 65
 
Donate to Me
More
I don't know ,Dude
Mines from At&t and zero lag ,everything's flying here
The Following 4 Users Say Thank You to bigcid10 For This Useful Post: [ View ] Gift bigcid10 Ad-Free
23rd April 2017, 12:19 AM |#9  
busab's Avatar
Senior Member
Flag Greer, SC
Thanks Meter: 224
 
More
No lag here either. But I know what you're talking about. I've seen it happen in review videos. I was pretty worried about it.

Maybe try a factory reset?

Sent from my SM-G955U using Tapatalk
23rd April 2017, 12:19 AM |#10  
mlock420's Avatar
Senior Member
Thanks Meter: 629
 
More
I've been pulling down notification all day because messages are coming in and don't see frame drops....do I need glasses?...im trying to replicate your problem but I cant....
23rd April 2017, 12:31 AM |#11  
parmend's Avatar
Senior Member
Fort Worth
Thanks Meter: 82
 
More
The only lag I see is when exiting apps , The animation pauses for a split 2nd and then goes away . I think it's a touch wiz launcher thing because when I use Nova launcher I get no lag at all
One thing I wish touch wiz would stop doing when opening a folder on your home page don't take up the entire screen To access the apps inside the folder .
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes