FORUMS
Remove All Ads from XDA

[V2][Root][G950U/W]PartCyborgRom - Root for Snapdragon S8 with Custom Rom

2,532 posts
Thanks Meter: 2,250
 
By partcyborg, Recognized Developer on 10th November 2017, 11:29 AM
Post Reply Email Thread
SamFail presents...

PartCyborgRom
BQL1


A Rooted Custom Rom

For G950U/W, Bootloader Revisions 1 or 2 only any higher are not currently rootable or vulnerable to this exploit


Updates
New Release and a new OP that I hope is easier to read.
Send feedback or suggestions on improvements to me via pm here or on telegram.


Heads Up
You may notice that the BL version of this release is different than the system rom part.
The rom version is in fact BQL1, but the BL is a new version of AQK2. The reason for this is because
the latest combination, ARA1, has a number of sensors not working. I figured out a fix but it requires splicing
stuff in from other versions, and it didnt feel like the battery lasted as well. I am still testing though and
the next release if its ready will come with ARA1. This is not the same BL as the previous
release though, so if you upgrade also flash this new BL!

Thanks!



Featured Modifications

Deodexed
Deodexed for all devices.
I found a way that works!
It should keep working as long as nougat
(is that a haiku?)

Xposed Preinstalled
PCR now comes out of the flasher with xposed pre-installed!
NOTE: Xposed Installer may crash on first boot. It will not crash after setup finishes and you reboot

New Boot Animation
Another great one from @Ryan-refoua.
This one is my favorite so far.

JamesDSP
I added another DSP style audio mod. JamesDSP is similar to V4A in how it operates and what features it has, but it has some really awesome features that have made me a fan and a regular user. Among other things, it has a better convolver (IRS processing) implementation, and its bass boost is significantly better than v4a. If there are things you like about V4A you can use both at the same time.

ITYBP Modded YouTube
A last minute addition, this is a really nice youtube mod brought to you by @laura almeida, @Razerman and @ZaneZam. It features some cool additions like native adblocking (no more xposed module), overriding your max youtube resolution (you can watch 4k videos on your phone, but not 4k hdr). I have been using it for a while and really like it. A big thanks to them for letting me include it with PCR

Improved Debloating
Found better stuff to delete. Added back some stuff I took out before that some of you asked for.
If you find something missing that you want back, pull it from the stock rom and install it in /system/app or /system/priv-app, wherever you got it from.

Improved Battery Life
Thanks to some battery sleuthing by @TheMadScientist, this release comes with a nice big bump in efficiency. With just some very minor tuning using amplify and a service disabler, I can get around 1%/h drain.

Performance Improvements
That increased battery life does not come at the cost of performance. In fact performance is better too. Part of that is due some personally tested build.prop tweaks. Another part is some data optimisation scripts that now run at boot. You wont notice those, but they are there doing their thing.


Other Features
New for first time flashers
- Pre-Rooted with SuperSU installed
- CSC OYN pre-installed. Tested working on several carriers
- RCS and VoLTE icons removed from status bar.
- High quality audio mods, including
- Viper Audio (V4A)
- Dolby Atmos from the Axon 7
- Pandora hifi audio framework
- Native Google Dialer & Contacts support, including local search, spam call blocking
- Oreo 8.1 Emoji Icon Set
- Custom Lockscreen Clock font
- Stock system display fonts replaced with Apple's original San Francisco Font


Special Thanks
- @ahiron and @Zackptg5 for the killer sounds from V4A and Dolby Atmos Mods!
- The Aiur crew for Pandora (now a legacy mod but works great on the s8)
- @syndre for the Google Dialer and Contacts framework mod
- @rayan-refoua for the beautiful Tech Lines Custom boot and shutdown animations!
- Last but not least, my new friend @laura almeida, along with @Razerman amd @ZaneZam for letting me include the iYTBP - injected YouTube Background Playback Mod
- everyone who tested


Warnings/Disclaimers/Known Issues
- 80% Battery life like every other rooted US snapdragon device
- Flashing on a USB 3.0 port will likely cause corruption in your flash that can cause kernel panics, loss of root, and occasionally very strange other errors. If you get something like this, its not the rom its a hardware conflict that can only show up with larger images like are used in SamFail flashing. See the section below on Kernel Panics for more.
- If there is an app or apk from the stock rom that you wish you had installed, the best solution is to extract it from your stock rom image and copy it to the same place in /system using a root file manager.


SamFail Rooting Process
and Rom Installation


WARNING: THE FOLLOWING WILL ERASE YOUR WHOLE PHONE
If you have a SDCard, remove it from your device. Occasional firmware incidents have wiped SDCards in the past. It has neer happened to me, but I have a backup of my sdcard so I can be a little more risky. Better safe than sorry.

Prepare the Following:
- complete stock rom at your bootloader rev in case things dont work
- Everything backed up
- Both Prince Comsy Odin, and Regular Odin for flashing stock
- A USB 2.0 Port. If you attempt to flash with a USB 3.0 port it may work, but if you get kernel panics, or unexpected bad behavior and/or crashes your usb3 is absolutely to blame. some people get lucky and suceed after a few tries, YMMV. If you can not acquire a machine with a usb2.0 port, get a usb2.0 hub and run your phone into that & that into your machine. Reports are that has made things work for some, but we get few reports back.


What is my Bootloader Revision?
Your bootloader revision is part of the baseband build number of the firmware you are currently running. Lets use this rom as our example. The full build number is as follows: G950USQS2BQL1
Start from the right and count 5 characters back. See that 2? That is the bootloader revision for the firmware that came with this rom. But we are not flashing the BQL1 firmware (or Baseband), We are using an older version because it works better. The version we are flashing is: G950UEU2AQK2. Can you tell which revision it is?


Is my Phone Compatible?
Is it a G950U? Is it a G950W? If you answered "yes" to one of those questions, then the answer is "yes". That being said, flashing this rom if you are on bootloader revision 1 will upgrade your bootloader revision to 2, which means that any previous rom you were running wont work, so be prepared by having a copy of stock for bootloader version 2. If you don't want to move to version 2, you can still run the latest PartCyborgRom though, just use the G950UEU1AQk1 BL_ tar under Old Downloads in place of the one that came with this one. It will work just fine. However if you are unsure I suggest you go ahead and upgrade, there are not really any benefits to staying on 1 at this point.




Steps to Root

1) Download and unzip AP Part 1 and BL Part 2 zip files.

2) Download and unzip Prince Comsey Odin and start it up

3) Reboot device into Download mode and connect it to your pc

4) Open Comsy Odin and only add the AP Part1.tar.md5 file. Select only the following options:
- "Auto-Reboot"
- "F-Reset Time"
- "Nand Erase All"

NOTE: Odin will freeze while checking the AP tar.md5 hash.
Be patient, it will come back. If your computer is old this will take even longer.

5) Click "Start" and wait for the system.img.ext4 file to flash fully to your device. This will take a while too.

ATTENTION
When the flash finishes, this is when the SamFail magic happens. Instead of saying "Failed (Auth)" like it should, the device will crash into upload mode with "Unknow Error".

If your device does not do this, and just says "Failed (Auth)" or something similar and stays in download mode, you need to start again from the beginning, but using a different set of usb ports as you have suffered from the usb3 corruption.

When you see the upload mode page, do the 3 button salute to reboot into download mode again.

WARNING: When you reboot from upload mode, it wont look like download mode. You will see an error.

When you reboot back into download mode, your screen will say that you had a failed update and you need to do emergency repair or take your device to a service center.
Rest assured, your phone is actually in download mode, and Odin will have recognized it and said "Added!" along with the com port lighting up underneath the progress bar. Just continue the process. It is safe to do so and that error will go away after the next step.

6) Close and re-open Comsy Odin or hit the reset button, and add BL_PartCyborgRom-BootLoopEdition-<version>.tar.md5 to the BL section.

7) Leave the default checkboxes for "F Reset Time" and "Auto Reboot" checked. Uncheck "Nand erase all". Click "Start" and flash the BL (part 2) to your device.

Note: If you forgot to uncheck nand erase all, don't worry. You are just wasting time doing something again that you already did, the outcome is the same. "All" in "Nand Erase All" means "all userdata", which means cache and, well, userdata. Nothing else is deleted.

8) Wait for the flash to finish . It won't take very long at all as the files are small.

9) When it has finished, Odin will say PASS and your device will reboot into recovery.
From this point forther the scary download error message will be gone for good (or until next flash). Don't go looking yet though, you have more work to do to get root.

Warning: Failure to follow this step could lead to a corrupted instance with no cell coverrage

10) When in recovery issue a factory reset. This ensures that your device has a userdata and cache partitions that are valid, and that the csc is processed correctly. Failure to do the reset could cause issues with either.

11) Boot the device as normal. Wait for it to come up. Its deodexed so it will take longer than even your average odexed rom.

All done!


FlashFire Instructions


- Get the ROM on your phone and unzip it
- Open up FlashFire
- Add a Wipe task, select the top 3 items only
- Select Flash Firmware and load up the AP_PartCyborgRom-BootLoopEdition-<version>.Part1.tar.md5 file to flash your new system
- Select Reboot to Recovery
- Make sure "Inject Root" is NOT checked
- Press go. Wait for the rom to flash and your device to reboot into recovery
- From recovery do a factory reset
- Then select reboot to Download Mode
- When device reboots into Download mode, flash BL_PartCyborgRom-BootLoopEdition-<version>.Part2.tar.md5

You have to use odin for the BL file because flashing bootloaders in FlashFire is a bad idea.



Dirty Flashers


Yes, you can dirty flash this rom to upgrade, however it is problematic and can cause issues. I did it for a long time, but my install was a mess by the time I gave up and reset.
To dirty flash, follow your preferred method of flashing above, but skip the Wipe step.

Odin
Skip "Nand Erase All" during the Part 1 flash. Do everything else the same

FlashFire
For the first Wipe task, instead of selecting the top 3, select only Dalvik like the second wipe task.

NOTE: This procedure is ONLY for people upgrading from an earlier PartCyborgRom version. If you are coming from stock you can not dirty flash because you userdata is encrypted which is not supported by the Factory firmware. If you are coming from other rom, or stock, I have no idea man but don't look at me if it blows up.

ANOTHER NOTE: This method of flashing is unsupported! If you do this and you have issues, you are on your own. If you think they are the rom, then back up your entire rom, wipe and reproduce them.



Help! I Got a Boot loop!
If you get a boot loop or your device hangs at boot, try the following:

1) Reboot to recovery and factory reset again.
To get to recovery hold power+vol-down until screen goes black, then wait till upload mode (press power key for 7+ secs) comes up. Then press vol-down+power again and hold it till it reboots and as SOON as the screen goes black switch to holding vol-up+power+bixby. Hold it for 5-7sec then let go and you will wind up in recovery mode. If this doesnt help, or you can't get to recovery because you cant press the buttons right, proceed to the next step.
2) Try flashing just Part 2 (the BL) again. not only will this get you back in recovery, it will also format your cache again. Its worth a shot and doesnt take long.

Kernel Panic, Invalid Argument

Start Over
Go back to the beginning and do everything again. If it fails again, even in a slightly different way this time, bad interaction between the s8 and your USB port/controller/cable/etc are causing the image to be corrupted as its being written to disk. Try the following:

1) New USB Ports. If you have them, use a different set of usb ports (not the one next to it, but one further away). Its possible that that will be your "good" port, and that will be enough. Lots of machines also have some USB3 ports and some USB2.
2) New Cable. Its less likely, but maybe a new cable will help. Do the whole thing over with a new cable.
3) Try a few times. It sounds silly, but people who have had this issue have reported that eventually it just works. Try a few times until you get sick of trying. If you try like 10 times it probably wont work on the 11th though.

I Dont Have Another USB Port!
Try to borrow your partner/spouse/roommate/friends computer for a quick flash. Ask about the USB ports though, because another 3.0 port may not help you.
If you can't get someones computer, you can purchase a USB2.0 Hub online or at your friendly neighborhood electronics store. They arent very expensive, and I have heard positive reports from people saying it did the trick.


None of that Worked! I'm Screwed!
No you probably arent. I can count on one hand the number of people who someone couldnt get this working eventually. Some of us will be here to help. Check out our telegram channel, where people will be around that can help you. Its right here!.



And they all rooted happily ever after.
The End.


XDA:DevDB Information
PartCyborgRom, ROM for the Samsung Galaxy S8

Contributors
partcyborg
ROM OS Version: 7.x Nougat
ROM Kernel: Linux 4.x
Based On: TouchWiz/Samsung Experience

Version Information
Status: Stable
Current Stable Version: BQL1
Stable Release Date: 2017-12-10

Created 2017-12-11
Last Updated 2018-2-10
The Following 68 Users Say Thank You to partcyborg For This Useful Post: [ View ]
10th November 2017, 11:29 AM |#2  
OP Recognized Developer
Thanks Meter: 2,250
 
Donate to Me
More
The Following 29 Users Say Thank You to partcyborg For This Useful Post: [ View ]
10th November 2017, 11:29 AM |#3  
OP Recognized Developer
Thanks Meter: 2,250
 
Donate to Me
More
The Following 17 Users Say Thank You to partcyborg For This Useful Post: [ View ]
10th November 2017, 08:17 PM |#4  
Senior Member
Flag Texas
Thanks Meter: 97
 
Donate to Me
More
Flashed fine through flashfire(AP only) was a bit worried because after I flashed the bootloader I got a kernel panic upload mode, but I reflashed the bootloader and it worked out fine. Running it for a few hours now and I noticed right away the difference in battery drain, as in, amazing job at extending the battery life. Thanks for your work, look forward to Future updates

Update: only bug I've found is auto rotate doesn't really work, and internet connection issues(might be my network)
The Following User Says Thank You to adj998 For This Useful Post: [ View ] Gift adj998 Ad-Free
11th November 2017, 12:14 AM |#5  
reggie cheeks's Avatar
Senior Member
Flag Lake Tapps
Thanks Meter: 2,726
 
Donate to Me
More
I'm new to SIM unlocked and haven't rooted since s4 so possible newb question but
Can I use this rom to root unrooted AQH3?
I'm on sim-unlocked G950U.
Thanks for any help.

Sent from my SM-G950U1 using Tapatalk
11th November 2017, 12:28 AM |#6  
OMEGAHORSE's Avatar
Junior Member
Thanks Meter: 0
 
More
Followed everything and when it went to go reboot the SAMSUNG GALAXY S8 logo popped with the little custom lock but its almost as if its just there like its not really rebooting just a screenshot of it it wont go away after a certain time period or anything,I also tried re-flashing the BL and it still didn't boot up as it should of. Any idea on what I should do?
11th November 2017, 01:35 AM |#7  
Junior Member
Thanks Meter: 2
 
More
I will test this with my unlocked g950u1 on tmobile
11th November 2017, 04:02 AM |#8  
Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by OMEGAHORSE

Followed everything and when it went to go reboot the SAMSUNG GALAXY S8 logo popped with the little custom lock but its almost as if its just there like its not really rebooting just a screenshot of it it wont go away after a certain time period or anything,I also tried re-flashing the BL and it still didn't boot up as it should of. Any idea on what I should do?

Same here.
11th November 2017, 04:05 AM |#9  
Member
Flag Los Angeles
Thanks Meter: 12
 
More
I tried the first method (fully stock) and it failed badly to where download mode did not work, had to use Smart Switch emergency recovery
The Following 2 Users Say Thank You to Auzzical For This Useful Post: [ View ] Gift Auzzical Ad-Free
11th November 2017, 05:03 AM |#10  
Senior Member
Thanks Meter: 137
 
More
First attempt without flashing CSC on TMo resulted in Kernel Panic after reboot from Download mode. I ended up flashing the CSC and now the Tmobile boot splash is showing up and seems to be working, will update to confirm in a few minutes.

Update: booted just fine now into Setup Wizard...
The Following User Says Thank You to vboyz103 For This Useful Post: [ View ] Gift vboyz103 Ad-Free
11th November 2017, 07:56 AM |#11  
Senior Member
Flag Greenville
Thanks Meter: 342
 
Donate to Me
More
Will someone upload the files elsewhere? I cannot download it tells me that the OP has reached daily traffic limit on website
Post Reply Subscribe to Thread

Tags
g950u, galaxys8, root, samfail, snapdragon

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes