FORUMS
Remove All Ads from XDA

Can't change Bluetooth audio codecs or

223 posts
Thanks Meter: 42
 
By s4shield, Senior Member on 17th March 2018, 03:52 AM
Post Reply Email Thread
I got the Oreo update and in developer options you're supposed to be able to change the codec, samplerate and a few other things to improve Bluetooth audio. However when I select a codec it doesn't change. It defaults to aac. I wanted to use Ldac. Tried aptx hd and Samsung hd as well and they don't work. ☹️
The Following 2 Users Say Thank You to s4shield For This Useful Post: [ View ] Gift s4shield Ad-Free
 
 
19th March 2018, 12:33 AM |#2  
jUsT2eXy's Avatar
Senior Member
Thanks Meter: 18
 
More
I have the same issue. When you select for example, AptX, the settings don't seem to stick.

Any suggestions? Thanks!
The Following User Says Thank You to jUsT2eXy For This Useful Post: [ View ] Gift jUsT2eXy Ad-Free
26th March 2018, 01:28 AM |#3  
Member
Thanks Meter: 4
 
More
Same here on S9+ cant change codec, always goes back to AAC
27th March 2018, 12:38 PM |#4  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by jUsT2eXy

I have the same issue. When you select for example, AptX, the settings don't seem to stick.

Any suggestions? Thanks!

Try deactivating Bluetooth, then change the codec. Should work. Cheers
The Following User Says Thank You to piejj For This Useful Post: [ View ] Gift piejj Ad-Free
27th March 2018, 12:57 PM |#5  
Member
Thanks Meter: 4
 
More
Which codec is best? AAC was my default.

Sent from my SM-G965F using Tapatalk
27th March 2018, 01:24 PM |#6  
Junior Member
Thanks Meter: 4
 
More
Apt-X is the best. That being said, the bluetooth device you connect too has to be compatible. Maybe that's why it switches back to AAC for you. (It sticks to apt X in my case)
5th May 2018, 03:44 PM |#7  
Member
Flag Wageningen |Student Computing Science|
Thanks Meter: 5
 
More
Same problem here, it doesn't seem to stick. Even if I disable bluetooth. After closing and re-opening developer options it reverts back to SBC.

Any fix?
5th May 2018, 06:42 PM |#8  
Senior Member
Thanks Meter: 47
 
More
For me it only changed when a device was actually connected
9th May 2018, 03:51 PM |#9  
dave1977nj's Avatar
Senior Member
Thanks Meter: 142
 
Donate to Me
More
Mine does not stay after I change it, it goes back to SBC.
29th May 2018, 11:31 PM |#10  
Junior Member
Thanks Meter: 3
 
More
Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
Cheers
The Following 3 Users Say Thank You to starfishhaha For This Useful Post: [ View ] Gift starfishhaha Ad-Free
11th June 2018, 02:20 PM |#11  
Senior Member
Toronto, Ontario, Canada
Thanks Meter: 583
 
More
Quote:
Originally Posted by starfishhaha

Yo, everyone. I use a sennheiser gt 4.40 with aptx with s8. If you want to enable aptx. first go to BLUETOOTH settings, click the 3 dots. disable the duo bluetooth audio and then go to the developer settings, you will see it's working. but to be honest, I find no difference between these. LOL
Cheers

Finally! Disabling dul audio is what allows the setting to work on my Note 8. Using Forza Metallo headphones there is a VERY noticeable improvement when using aptx!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread