FORUMS

Weird Night Mode type issue...

37 posts
Thanks Meter: 8
 
By zeebone, Member on 16th March 2018, 04:42 PM
Post Reply Email Thread
So I got my T-Mobile S9+ on Tuesday. I got everything loaded up and restored and at 10pm, I noticed the color shift on the screen into a night mode type color scheme. Whites were turning a yellowish hue. I'm running Nova Launcher as my main launcher and checked all the settings in the phone itself, and nothing is enabled for Night mode. I ended up having to reboot the phone and it was back to normal.

It happened again the last two nights at 10pm EST. No idea why. I've tried everything short of rebuilding the phone (I know most will suggest this, but I'm trying to avoid it for the time factor). Rebooting seems to reset the clock on whatever is doing it and it goes back to normal.

My wife has the same phone and similar setup with Nova and hers doesn't do it. I've tried going back to the stock Samsung launcher when it is happening and nothing seems to fix it.

Anyone had this happen? I don't see any third party apps that would cause this that I have installed. the only app I can think of that even has a night mode is Nova, but that just effects menus and turns them black, not yellow.

*Edit* Sorry, I meant to put this in the Q&A Section.....
16th March 2018, 05:32 PM |#2  
Member
Thanks Meter: 3
 
More
settings - display- blue light filter - custom schedule
16th March 2018, 05:56 PM |#3  
OP Member
Flag Clinton Township
Thanks Meter: 8
 
More
Quote:
Originally Posted by vivilxw

settings - display- blue light filter - custom schedule

Blue Light filter is disabled and schedule is disabled as well. I've tried turning ON the blue light filter when the issue happens and it actually kicks in on top of the other issue and makes it even MORE yellow.

Seems unrelated to that.
16th March 2018, 09:49 PM |#4  
kolembo's Avatar
Senior Member
Thanks Meter: 767
 
More
Have you checked the sunset to sunrise toggle..?
19th March 2018, 04:07 AM |#5  
skinnytoo2's Avatar
Senior Member
Thanks Meter: 133
 
More
Anyone having this blue light issue...blue light is enabled. When I turn on phone from sleep mode it takes like a second to switch to blue. Very weird

Sent from my SM-G965U1 using Tapatalk
19th March 2018, 07:39 AM |#6  
lessthanzach's Avatar
Senior Member
Flag Redding, CA
Thanks Meter: 381
 
More
Quote:
Originally Posted by zeebone

snip.

EDIT: I Fixed it finally!
I have no idea if there's an easier way to fix this, but here's what I figured out sifting through adb commands. If you run the command
Code:
adb shell 'settings list secure
you will get a list of many of the device's settings. The one we're modifying is called "Night Display" which is different from what everyone has been calling "Twilight Mode" in my google searches. So all we have to do is run the two following codes:
Code:
adb shell 'settings put secure night_display_activated 0'
Code:
adb shell 'settings put secure night_display_auto_mode 0'
This fixed my issue immediately and it persisted through my manual date and time adjustments just to verify and also two reboots. I know ADB commands aren't everyone's cup of tea but it is also a very powerful tool at unfu**ing what manufacturers have fu**ed. Hope it helps others as well!

(ORIGINAL, not needed, left for posterity)
This needs more attention. I know EXACTLY what this is. You came from a more recent Android device that uses Google's own "night mode" settings. I know, because I did too. I came from the Razer Phone and had night mode enabled on that on schedule. After my screen turned a real dank orange color at night, I started looking for the setting and discovered Samsung's "Blue Filter" setting and that enabling it made the orange color even more dank. So I immediately knew that the setting must have carried over when I logged into my google account and carried over my settings.
I have a workaround, but it is just that, it's not a permanent fix and I'm still trying to figure out how to fix it permanently. You need to install System UI tuner from the playstore. Follow the instructions to make the app work by granting permissions using ADB while connected to a PC. This is not root and will not void your warranty as such. From here, you can either just disable "Night Mode" under the miscellaneous tab or you can go to the playstore and install "Nougat / Oreo Quick Settings" which will allow you to add the toggle for "Night Mode" to your quick settings pull down bar. Unfortunately, you have to do this every night to get rid of the ugly orange color.

I've tried disabling the setting on my Razer and syncing everything in my google account from that phone, then restarting my galaxy and hoping that the settings would transfer over, but it hasn't worked. My fear is that I will have to factory reset the Galaxy, go back to Razer, toggle the night mode on and back off. Sync settings, then sign back into my galaxy and hopefully the settings will not come back this time. I just haven't because I don't want to set EVERYTHING back up again, ugh.

If anyone is aware of how to disable the "Night Mode" schedule feature in a different way without factory resetting the device, please let me know. Thanks!
The Following 8 Users Say Thank You to lessthanzach For This Useful Post: [ View ] Gift lessthanzach Ad-Free
19th March 2018, 08:36 AM |#7  
Senior Member
Thanks Meter: 31
 
More
There's an easy solution to this, if you hadn't switch off the night mode on your previous phone before transferring to the S9:

https://www.reddit.com/r/GalaxyS9/co...filter_overlap
The Following User Says Thank You to cawith For This Useful Post: [ View ] Gift cawith Ad-Free
19th March 2018, 08:50 AM |#8  
lessthanzach's Avatar
Senior Member
Flag Redding, CA
Thanks Meter: 381
 
More
Quote:
Originally Posted by cawith

There's an easy solution to this, if you hadn't switch off the night mode on your previous phone before transferring to the S9:

https://www.reddit.com/r/GalaxyS9/co...filter_overlap

LOL. Jesus. My long-winded solution above yours looks barbaric now. Good thing I wasted a good evening sifting through ADB commands. Good on you for finding this and posting this. Nova saves the day again.
The Following User Says Thank You to lessthanzach For This Useful Post: [ View ] Gift lessthanzach Ad-Free
19th March 2018, 09:47 PM |#9  
OP Member
Flag Clinton Township
Thanks Meter: 8
 
More
Quote:
Originally Posted by lessthanzach

LOL. Jesus. My long-winded solution above yours looks barbaric now. Good thing I wasted a good evening sifting through ADB commands. Good on you for finding this and posting this. Nova saves the day again.

Wish I had waited a little bit longer and had done this. I ended up backing everything up to my SD Card using Smart Switch and then wiping and rebuilding the phone yesterday afternoon. However, I didn't choose to restore from Google and only from Smart Switch, so the night light setting didn't end up carrying over again.

Good to know I wasn't crazy and that my phone wasn't defective.
14th April 2018, 01:21 AM |#10  
Junior Member
Thanks Meter: 5
 
More
I had this problem too, and couldn't find an easy solution, until today.

The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

So, where is this setting hidden?

Google Playbook.

Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

Simply turn it off and Voila!

No rooting, no launcher or nothing required.
The Following 5 Users Say Thank You to PorcoPorco For This Useful Post: [ View ] Gift PorcoPorco Ad-Free
14th May 2018, 05:20 AM |#11  
Junior Member
Thanks Meter: 0
 
More
I was all ready to get adb working and use the above workaround, and / or install nova launcher and fix this issue but THIS WORKED.

THANK YOU it has been bugging me for WEEKS.

Quote:
Originally Posted by PorcoPorco

I had this problem too, and couldn't find an easy solution, until today.

The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

So, where is this setting hidden?

Google Playbook.

Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

Simply turn it off and Voila!

No rooting, no launcher or nothing required.

Post Reply Subscribe to Thread

Tags
color, night mode, nova laucher, samsung

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes