FORUMS
Remove All Ads from XDA

Linux on DeX on S9

31 posts
Thanks Meter: 12
 
By code_exec, Member on 22nd April 2019, 07:17 PM
Post Reply Email Thread
Linux on DeX now works on the S9. An update was pushed today which adds support for the S9. You need to be on Android Pie, and then download the LoD 1.0.51 apk from SamMobile. Works well on my S9 Exynos although every once in a while it warns me that the container is running out of memory and LoD may slow down. Other than that it works well.
 
 
23rd April 2019, 05:05 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Not working for me
Quote:
Originally Posted by code_exec

Linux on DeX now works on the S9. An update was pushed today which adds support for the S9. You need to be on Android Pie, and then download the LoD 1.0.51 apk from SamMobile. Works well on my S9 Exynos although every once in a while it warns me that the container is running out of memory and LoD may slow down. Other than that it works well.

Hi. It did´t work on my S9 running Pie. Keeps popping up the message Linux on Dex requires your device to have the latest software...bla bla bla...my S9 is up to date. I used the LoD version 1.0.51.
23rd April 2019, 05:38 PM |#3  
OP Member
Thanks Meter: 12
 
More
Quote:
Originally Posted by pcbelem

Hi. It did´t work on my S9 running Pie. Keeps popping up the message Linux on Dex requires your device to have the latest software...bla bla bla...my S9 is up to date. I used the LoD version 1.0.51.

Works for me on April 2019 patch. What patch are you running?
23rd April 2019, 07:13 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by code_exec

Works for me on April 2019 patch. What patch are you running?

Mine was updated on April 2nd 2019. Current Version: G9600ZHS3CSC1 /G9600OWO3CSAC/G9600ZCU3CSAA - Security patch level: March 1st 2019. When I check if there is any new updade, it says: Your software is up to date. So I will wait until I receive the security patch update of April and test again the Linux on Dex version 1.0.51 on my S9. Maybe this is the problem.
26th April 2019, 12:45 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by pcbelem

Mine was updated on April 2nd 2019. Current Version: G9600ZHS3CSC1 /G9600OWO3CSAC/G9600ZCU3CSAA - Security patch level: March 1st 2019. When I check if there is any new updade, it says: Your software is up to date. So I will wait until I receive the security patch update of April and test again the Linux on Dex version 1.0.51 on my S9. Maybe this is the problem.

Today I finally received the April security patch. So I installed and voilà, it worked!!! Now I´m going to install Ubuntu on LoD on my S9.
7th May 2019, 05:59 PM |#6  
Senior Member
Thanks Meter: 12
 
More
Would this allow me to run full on programs? FL studio for example?
7th May 2019, 06:47 PM |#7  
GROGG88's Avatar
Senior Member
Flag Lone Star State
Thanks Meter: 3,042
 
Donate to Me
More
Quote:
Originally Posted by dj.shauny.g

Would this allow me to run full on programs? FL studio for example?

With Wine installed you should be able to.
8th May 2019, 05:19 PM |#8  
Senior Member
Thanks Meter: 12
 
More
Quote:
Originally Posted by GROGG88

With Wine installed you should be able to.

Ok i will check it out when i get there. However i am struggling to get the Linux on Dex beta to install on my s9


At the start when you download the app i am told to click the + button and select download from server.

When i select download from server i get this error message.

Web page not available

The web page at*http://lxd-wv-qa.samsungknox.com/*could not be loaded because:

net::ERR_CLEARTEXT_NOT_PERMITTED

---------- Post added at 04:19 PM ---------- Previous post was at 04:01 PM ----------

Sorry was running old version, i have now installed it
11th May 2019, 12:00 AM |#9  
Senior Member
Thanks Meter: 47
 
More
Tried it, and I have to say I'm not impressed. Linux Deploy does a better job for the most part. The main advantage of LoD is that it doesn't require root. But we're stuck with and outdated version of Ubuntu with Unity (yuck) and around 4 gigs of unnecessary files. I can't get sshd working either.
13th May 2019, 07:25 PM |#10  
Senior Member
Thanks Meter: 12
 
More
Quote:
Originally Posted by GROGG88

With Wine installed you should be able to.

I am having really difficulty installing wine with my s9 on dex.

Do you have any experience with this?

---------- Post added at 06:25 PM ---------- Previous post was at 05:47 PM ----------

Quote:
Originally Posted by GROGG88

With Wine installed you should be able to.

Quote:
Originally Posted by Mogster2K

Tried it, and I have to say I'm not impressed. Linux Deploy does a better job for the most part. The main advantage of LoD is that it doesn't require root. But we're stuck with and outdated version of Ubuntu with Unity (yuck) and around 4 gigs of unnecessary files. I can't get sshd working either.

I believe you can update from the official linuxondex webpage. However am unsure how to do it myself.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes