FORUMS

Stable AOSP 7.1 setup w/ working Google and Voice - ACHIEVED!

15 posts
Thanks Meter: 29
 
By HiltonJ, Junior Member on 25th March 2018, 07:03 AM
Post Reply Email Thread
This guide is to install AOSP 7.1.2 and GApps on the Samsung Galaxy Tab 10.1, model GT-P7500 ("p4"). It has also been reported working on the Wifi-only version GT-P7510 ("p4wifi") with minor changes, noted in the instructions. I will update this main post as better information becomes known.

Updated 2018-Aug-06
After a couple dozen wipe-and-retry sessions, I thought I'd share my current setup which to date has been the most stable configuration I've had between Nougat and Oreo. I've had absolutely no stability issues so far with this setup, and I even have fully functional Google search, voice search (and Ok Google), and voice typing - no crashes. Anyone who's tried to install a modern GApps on these devices will know the frustration of literally endless and unstoppable "....has stopped" messages!

Here's what I've got working on my GT-P7500:
- AOSP Nougat 7.1 (all thanks to @decatf)
- Fully functional Google Apps - NO "... has stopped working"/"... keeps crashing" issues. None.
- Google Search, Google Now, voice search, voice typing, and other voice-related services ALL WORK. No crashing.


I should also mention that I have NOT included the instructions to create the 1GB /system partition. I figured this out when I was trying to install modern GApps that needed more space; in the end the instructions below turned out to be the best and do not require the expanded space. I have posted the file in another thread if anyone wants it for other purposes.

Installation Instructions:
  1. Download these files to your PC. Some files are different for different variants of the device - make sure you get the right ones for your device!
    • Odin v1.85 (download)
      Use only this version, the newer ones don't work well with this device.
    • TeamWin Recovery Project
      Custom unofficial versions for p4* by @decatf. Direct download links below; select the right one for your device. (original thread / downloads page) Some have reported issues with TWRP 3.1.1; if you experience issues, try TWRP 2.8.7.0 instead.
    • Android Open Source Project 7.1.2 Custom Built for Galaxy Tab 10.1 - AOSP 7.1.2 built for p4* by @decatf (downloads page) (original thread).
    • SuperSU v2.82 (download) (original thread).
    • Custom GApps from decatf's Lollipop release (download) (original thread).
      Yes, really, the Lollipop version. Just trust me.
  2. Boot into Download mode (instructions).
  3. Connect to PC.
  4. Start up Odin v1.85.
    • If the device is properly recognized, it will show up in the first of the row of white squares at the top. If not, install the Samsung USB Drivers and start again.
  5. Use Odin 1.85 to install TWRP 3.1.1 Custom.
  6. Reboot to Recovery mode (instructions).
  7. Wipe the device, including the /system partition.
  8. Transfer the AOSP, SuperSU, and GApps files to the device.
  9. Install decatf's AOSP 7.1.2.
  10. Install SuperSU v2.82.
  11. Do NOT install GApps at this time, despite all the instructions everywhere else that you would normally install GApps before the first boot. This older release is being used to get a version of the Google app that works on this tablet's no-longer-supported CPU, and the install is done after first boot to bypass Google's Setup Wizard which will put you in an impossible-to-exit loop.
  12. Reboot to System, and allow complete boot-up. Note that the boot will take several minutes as Android 7 does its thing setting up - be patient!
  13. Once fully booted, wait a minute for the system to settle, then reboot back into Recovery.
  14. Install custom GApps.
  15. Reboot to System. Boot should be much faster this time.
  16. You can do this part later, but the final steps will be smoother if you do this first.
    • Install a CPU Speed Control program of your choice. Device Control, 3C Toolbox, No-Frills CPU, heck even Automate or Tasker if you already have a script setup.
    • Set your CPU Max speed to 1400 MHz (1.4 GHz). I find stability issues at anything above 1400 on my device; your mileage may vary. When testing speeds, do not set them to apply on boot until you are certain it is still stable, or you may have some difficulty reverting.
    • Optionally Set your CPU Governer to Performance. This results in a smoother system overall, and doesn't seem to have much of an effect on battery life. I also use some settings to drop the Governer to Interactive when the screen is off, back to Performance on screen on. You can do this using any number of programs like Automate, Tasker, IFTTT, 3C Toolbox, and many others...
  17. Most important step - open Play Store, go to My Apps, select Google, click the Menu in the top-right corner, and uncheck Auto-Updates. Alternately, you can go to Play Store Settings, and disable auto-updates altogether, but that is more troublesome than simply inhibiting the single app.
  18. Update Google Play Services. It will need to be updated before most of the newer apps will function, so might as well do it now.
  19. Install all the other Google apps you want from the Play Store, and any updates... you will need to update Play Services before most of the newer apps will function... but never, ever update the main Google app.
  20. Open Settings.
    • Scroll to the bottom, and open Language and Input. Select Physical Keyboard settings, and enable "Show Virtual Keyboard". This ROM fakes having a physical keyboard always connected for some reason, so you will never see an on-screen keyboard unless you turn this on.
    • As long as we're in Settings, go to Security, and enable Unknown Sources. You'll probably want this.
    • Set up your Wi-Fi connection.
    • Adjust any of your other preferred settings.
  21. You're finished! Try installing some of the software below.

Known issues:
  • Browser will crash once or twice during the first few minutes of operation for unknown reasons. Doesn't seem to happen again after that.

Recommended software that works: (I'll add Play Store links later...)
  • 3C Toolbox / 3C Toolbox Pro - I've found this to be an excellent package for numerous functions including CPU control, app control, and battery reporting - I was able to quickly determine which of my chargers would charge it fastest. Also gives options for optimizing device on each boot and a number of other useful functions.
  • Via Browser, a modern browser built to be slim and speedy "for geeks". It is surprisingly responsive compared to the other two options on this old device.
  • decatf's Chromium for Tegra 2 CPUs (direct link to Downloads). This is a modern browser with all the features you expect, but compiled to run on the older CPU. It is a little bit slow but is essentially Chrome without the official branding, including the ability to sync with Chrome on other devices. @decatf is nice enough to keep compiling new versions to keep it roughly on par with Chrome, let's hope he keeps it up.
  • Firefox Focus, a privacy-focused version of the Firefox browser maintained separately. For whatever reason, this one is still compiled for older devices where the full browser is not. It is a modern and relatively speedy browser which can be nice to have on hand, but purposely eliminates features most people want in a daily-use browser, like bookmarks, history, etc.
  • Got suggestions for useful software that functions well on this old device? Let me know!

Mainstream software that WILL NOT WORK, even though it shows up as compatible in the Play Store and will install fine (but complain about your CPU type or report 'unsupported device'):
  • Google Chrome browser - as an alternative, check out decatf's Chromium, noted above.
  • Mozilla Firefox browser - as an alternative, check out Firefox Focus and Via Browser, noted above.
  • Find another one? Let me know! There were more but I've forgotten.



Original post...
Quote:

You read it. I have a Tab 10.1 (GT-P7500) which I have managed to configure with decatf's AOSF Nougat 7.1, Google Apps with fully functional Google App and Voice Search (NO crashes), and with an enlarged /system partition so there is actually room on the partition to install some extra system apps without mucking about with linking or anything.

I slapped a quick guide to the GApps bit on the end of decatf's 7.1 thread in Development, but I wonder if there is enough of an interested audience for me to write up how I did the whole thing?

Disclaimer: It may or may not involve pentagram carvings and Satanic rituals.

The Following 18 Users Say Thank You to HiltonJ For This Useful Post: [ View ] Gift HiltonJ Ad-Free
25th March 2018, 08:28 PM |#2  
OP Junior Member
Thanks Meter: 29
 
More
I could find little to no information on how to do any of this, but I pieced it all together, experimented, and got it working. I've solved most of the problems I was having, including the ones that seem to be most commonly posted here from what I can see.

So here's what I've got working on my GT-P7500:
- decatf's AOSF Nougat 7.1
- Fully functional Google Apps, NO "... has stopped working"/"... keeps crashing" issues. None.
- Google App WORKS. No crashing.
- Google Now WORKS. No crashing.
- Voice search WORKS. No crashing.
- Voice typing and other voice-related services WORK. No crashing.
- Larger /system partition.

What I haven't figured out or haven't worked on yet:
- Some apps do not seem to be reading the compass properly, but I think a test app showed it as working, so needs more investigation...
- Get (standard) Firefox running.
- Which partitions can be safely reduced or eliminated to increase available data space.
- Experimenting to see if any voltage adjustments will allow 1.6GHz overclocking to function without freezing up. My device will only run stable at 1.4GHz
23rd April 2018, 04:34 AM |#3  
Junior Member
Thanks Meter: 0
 
More
pOST the instructions
please post instructions
27th April 2018, 02:43 AM |#4  
Junior Member
Thanks Meter: 1
 
More
Yes Please!
Please post the instructions. I still use the OG Galaxy Tab 10.1 regularly. Yes its slow as all heck, and barely runs 2 apps at a time. But Id like to do this just for giggles before my Yoga Book comes in the mail and i lay my 6yr old Tab to rest.
30th April 2018, 12:14 PM |#5  
Member
Thanks Meter: 3
 
More
I'd also be very much interested in this. I just got one of these as a gift for a NGO that I'm working for, and would love to be able to use it...
2nd May 2018, 01:05 PM |#6  
Junior Member
Thanks Meter: 0
 
More
yes please!
Please post instructions/guide. Would love to able to update the tablet. My daughter uses it and it's so slow
2nd May 2018, 01:55 PM |#7  
Member
Flag Lisbon
Thanks Meter: 3
 
More
pls advice if said method can be aplied to P7100
12th May 2018, 04:54 PM |#8  
Junior Member
Thanks Meter: 0
 
More
I am also interested in what you did to get everything working (for me, the Setup Wizard continually crashes right after the first screen).
20th May 2018, 05:54 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Was this guide ever posted and has anyone tried it
24th May 2018, 10:34 AM |#10  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by robbinmoreka

Was this guide ever posted and has anyone tried it

Yes they posted it here:
https://forum.xda-developers.com/sho...postcount=1046

I followed all the steps up until I got to 'install SuperSU'. First root I did, it stopped the home button/recent apps button from working. So I started again and didn't install it
GApps worked perfectly and I was able to login to google and download all my apps
Once I rebooted the system, the tablet was stuck on the "Android" logo for about 5-8 mins so I left it and then it loaded normally. 2nd time it loaded perfectly.
Installed Device Control [root] but it said it wasn't able to access the processor tab so uninstalled.
6th August 2018, 01:30 PM |#11  
Senior Member
Thanks Meter: 22
 
More
FYI, I had to use TWRP 2.8.7.0 available at the same link https://forum.xda-developers.com/dev...t/dl/?id=24424 for my p4wifi. I tried the latter one, but didnt work so just copied over the older tar file, installed in TWRP itself, rebooted recovery, and then the rest of the steps worked. Thanks OP for trying to bring this old tablet back to life!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes