FORUMS
Remove All Ads from XDA

[UNOFFICIAL][ROM] LineageOS/Go 15.1 for Galaxy Tab E [SM-T377P/SM-T560NU]

1,067 posts
Thanks Meter: 1,909
 
By vince2678, Recognized Developer on 26th July 2018, 07:18 PM
Post Reply Email Thread
Announcement from vince2678: New builds are up for all devices.


LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.
LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.


Code:
** Disclaimer
I am not responsible if flashing this ROM bricks your
   phone or causes thermonuclear war  and ends the
    world as we know it. You have been warned.

ROM Information

Quote:

Device Names

Quote:

Verify your device codename before downloading any firmwares or recovery images!

Code:
SM-T377P - gtesqltespr
SM-T560NU - gtelwifiue

Download

Instructions

Quote:



If you are completely new to flashing custom ROMs and have no idea how to begin, start by downloading a TWRP image for your device from the links above and flash it using the ODIN tool (see below).

You cannot flash a custom ROM over stock recovery, so downloading a custom recovery is the first thing you will need to do.






Quote:


If you are completely new to flashing custom ROMs and have no idea how to begin, start by downloading a TWRP image for your device from the links above and flash it using the ODIN tool (see below).

You cannot flash a custom ROM over stock recovery, so downloading a custom recovery is the first thing you will need to do.

Installation via recovery (TWRP/LineageOS Recovery)
Quote:

* Download a recent .zip file from the links above for your device.

* Reboot into recovery mode [Press Power+Volume Up+Home].

* Wipe your data and cache partition (equivalent to doing a Factory Reset)
if you are coming from a stock ROM.


* Either: Plug in your phone into your computer, copy the zip file to a location on your Internal or External Storage on a device, click Install on TWRP on your phone and locate the zip file in the phone, or:

* Plug in your phone into your computer, and open Advanced->ADB Sideload on TWRP on your phone and swipe the slider to enter sideload mode.
Then open a command prompt/terminal on your computer in the folder you put the file by Shift-Clicking (Shift+Right Click) and selecting "Open Command Prompt/Terminal Here" (you will need to have adb installed) and type:

adb sideload name_of_zip.zip

to sideload the file. Replace name_of_zip.zip with the name of the file. If you are running Linux you may need to type adb kill-server and use sudo adb sideload if you get an `Insufficient Permissions` error.

* Download and flash GApps in the same way.


How to provide logcats

Quote:

Under Windows:


Code:
* Install samsung device drivers and then
 the adb utils from here:

https://forum.xda-developers.com/sho....php?t=2588979

* Then enable developer mode, connect your phone to usb,
 and from cmd paste this command:

adb logcat > %userprofile%/Desktop/logcat.txt

then try to reproduce the bug.

* The logcat file will be on your desktop.



Under Linux:


Code:
* Install the adb utils from your distribution's
 package manager and execute the command:

adb logcat > ~/logcat.txt

then try to reproduce the bug.

* The logcat file will be on your home directory.
* Create a bug report at https://bugs.msm8916.com/ and paste the logcat there.

* If you cant connect the device through adb on windows because the drivers, connect the device over wifi, enable adb over network on the quick setting tiles, and type:

Code:
adb connect [ip address here]
And then the adb logcat command for windows.




FAQ

Quote:

Q: Are you taking device requests?
A: No.

Q: Are you accepting feature requests?
A: No.

Q: Can you make XXX ROM as well as LOS?
A: No.

Q: Can I throw money at you?
A: Most certainly. Donations are always welcome.

XDA:DevDB Information
[UNOFFICIAL][ROM] LineageOS/Go 15.1 for Galaxy Tab E [SM-T377P/SM-T560NU], ROM for the Samsung Galaxy Tab E

Contributors
vince2678, minz1, deadman96385, vlw, Danil_e71
Source Code: https://github.com/Galaxy-MSM8916

ROM OS Version: 8.x Oreo
ROM Kernel: Linux 3.10.x
ROM Firmware Required: >= 5.0 (Lollipop)
Based On: LineageOS

Version Information
Status: Beta

Created 2018-07-26
Last Updated 2018-10-10
The Following 16 Users Say Thank You to vince2678 For This Useful Post: [ View ]
 
 
26th July 2018, 07:18 PM |#2  
vince2678's Avatar
OP Recognized Developer
Flag Toronto
Thanks Meter: 1,909
 
Donate to Me
More
Reserved
If this is your first time flashing O, you will need to install the latest unofficial TWRP image for your device from the links above before flashing a zip image, otherwise installation of a zip will invariably fail.
The Following 3 Users Say Thank You to vince2678 For This Useful Post: [ View ]
26th July 2018, 07:18 PM |#3  
vince2678's Avatar
OP Recognized Developer
Flag Toronto
Thanks Meter: 1,909
 
Donate to Me
More
What works

Code:

* RIL (messaging, data possibly )
* Bluetooth (including audio)
* WiFi
* Audio (music, etc)
* Camera (including video recording)
* Flash
* Sensors
* GPS
Known Issues

Code:
All devices
* [BUG]  Encryption does not work. This is indefinitely broken

* [BUG]  RIL/Telephony (calling, texting, data) does not work.
Changelog

Code:
09/02/2018

* [FIX]  Camera recording should be working again.
   This was broken due to upstream android security change. 

* [FIX]  Telephony should be working on the gtes (T377P). 
   
* [NOTE]  Core control has been disabled permanently, in-kernel. 

* [NOTE]  NFC may (or may not) be working this build on capable devices.
   This is Untested. 


* [NOTE]  Rebased lineage-15.1 branches in repos. This is mostly
   for our benefit; just to tidy up the repos and make commit history more descriptive,
   accurate and give proper credits to commit authors. 

* [NOTE]  Reworked zram support in ROM. There are now two zram properties:
	ro.config.zram.enabled and ro.config.zram.size
	Set ro.config.zram.enabled true to enable zram;
	and ro.config.zram.size to set the size of the zram disk.

  If you set this too large the system will slow down. You can also just use a zram
  zip from the download server to do this automatically.
Code:
08/12/2018
* [BUG]  Camera recording is broken.
   This is due to upstream android security change. 

* [NOTE]  Reworked zram support in ROM. There are now two zram properties:
	ro.config.zram.enabled and ro.config.zram.size
	Set ro.config.zram.enabled true to enable zram;
	and ro.config.zram.size to set the size of the zram disk.

  If you set this too large the system will slow down. You can also just use a zram
  zip from the download server to do this automatically.

* [NOTE]  Enabled zram by default for low-ram (1GiB) devices 
The Following 2 Users Say Thank You to vince2678 For This Useful Post: [ View ]
26th July 2018, 08:02 PM |#4  
MikeEx's Avatar
Senior Member
Thanks Meter: 344
 
More
Welcome back Vince! Your work for this tablet is mainly why I have it. If you need testing I'd be happy to help.
Although I've been out of the flashing/dev game for 2.5 years.

Just a few small things I've noticed with my testing with SM-T560NU:

With GAPPS, at the end of the initial setup, it looks like it crashes the launcher and then loops back to select WiFi access point.
workaround: skip wifi setup and google account until after it loads to the launcher.

Opening Developer Options crashes Settings
Related: Cannot connect tablet as MTP to computer because USB debugging is stuck on.
Maybe Related: Cannot enable ROOT/SuperSU (unable to operate in xbin mode?)

Occasionally a thick red boarder flashes around the screen.
Quote:

This is caused by the strict mode setting under the developer options. It flashes a red border around the screen when anything does a long operation on the main thread.

likely workaround: Edit /system/build.prop and change the value of “ro.build.type” from “eng” to “user”
Without ROOT, edit the build.prop from the lineage-15.1 zip file from your computer before flashing.
You can still MTP mount from within TWRP if you need to transfer it.
The Following 3 Users Say Thank You to MikeEx For This Useful Post: [ View ] Gift MikeEx Ad-Free
26th July 2018, 10:18 PM |#5  
Senior Member
Thanks Meter: 51
 
More
Go version bootloops
Hello.Im not a noob and 15.1 booted fine but developers options when go to open crashes.Can not open developers option.And on Go ver will not boot.Just hangs on the opening boot animation.Just some feedback
26th July 2018, 10:47 PM |#6  
vince2678's Avatar
OP Recognized Developer
Flag Toronto
Thanks Meter: 1,909
 
Donate to Me
More
Quote:
Originally Posted by MikeEx

Welcome back Vince! Your work for this tablet is mainly why I have it. If you need testing I'd be happy to help.
Although I've been out of the flashing/dev game for 2.5 years.

Just a few small things I've noticed with my testing with SM-T560NU:

With GAPPS, at the end of the initial setup, it looks like it crashes the launcher and then loops back to select WiFi access point.
workaround: skip wifi setup and google account until after it loads to the launcher.

Opening Developer Options crashes Settings
Related: Cannot connect tablet as MTP to computer because USB debugging is stuck on.
Maybe Related: Cannot enable ROOT/SuperSU (unable to operate in xbin mode?)

Occasionally a thick red boarder flashes around the screen.

likely workaround: Edit /system/build.prop and change the value of “ro.build.type” from “eng” to “user”
Without ROOT, edit the build.prop from the lineage-15.1 zip file from your computer before flashing.
You can still MTP mount from within TWRP if you need to transfer it.


Quote:
Originally Posted by jimrfraser

Hello.Im not a noob and 15.1 booted fine but developers options when go to open crashes.Can not open developers option.And on Go ver will not boot.Just hangs on the opening boot animation.Just some feedback

Those are probably old builds. New builds are in the queue for today/tomorrow, check jenkins to monitor the status. The queue is quite long so it'll take awhile.
The Following 2 Users Say Thank You to vince2678 For This Useful Post: [ View ]
26th July 2018, 11:47 PM |#7  
Senior Member
Thanks Meter: 51
 
More
Did more testing.all versions og anndroid 8 crashes when opening developers settings.Got the Go version to boot with a dalvik and catch wipe then flashed pico gapps for 8.1 but once again developers options crash when opening.Could this be du to the gapps im flashing?Perhaps nano version?

---------- Post added at 11:27 PM ---------- Previous post was at 10:49 PM ----------

Dang lol no sound on the 14.1 builds at all

---------- Post added at 11:47 PM ---------- Previous post was at 11:27 PM ----------

Quote:
Originally Posted by vince2678

Those are probably old builds. New builds are in the queue for today/tomorrow, check jenkins to monitor the status. The queue is quite long so it'll take awhile.

0623 verson j4 is what i flashed.Obviously an older build for back in june.So what your saying is in this new post you have started will have all newer builds?
27th July 2018, 12:53 AM |#8  
Member
Thanks Meter: 14
 
More
I had some of the same issues with the 6-25 build (377p), specifically the crashing/red border, here's what I did to resolve those issues:

1. Google app crashes: Flash OpenGApps immediately after flashing the ROM (before 1st boot), this worked for me at least.
2. Dev Options/red border: Flash the ROM over itself after initial setup. After doing that the red border flash stopped & dev options started working.

I want to say thanks to you Vince, thanks for all of your hard work & not giving up on this device.
The Following User Says Thank You to silver9990 For This Useful Post: [ View ] Gift silver9990 Ad-Free
27th July 2018, 12:55 AM |#9  
vince2678's Avatar
OP Recognized Developer
Flag Toronto
Thanks Meter: 1,909
 
Donate to Me
More
Quote:
Originally Posted by jimrfraser


0623 verson j4 is what i flashed.Obviously an older build for back in june.So what your saying is in this new post you have started will have all newer builds?

Yes.
The Following User Says Thank You to vince2678 For This Useful Post: [ View ]
27th July 2018, 07:49 AM |#10  
MikeEx's Avatar
Senior Member
Thanks Meter: 344
 
More
Tested build lineage-15.1_j5_20180727_NIGHTLY-gtelwifiue:
With TWRP recovery and GAPPS provided by op links.
Data & Dalvik cache wiped.

Stuck at LineageOS boot animation and then the tablet just shuts off after a while.
dmesg.log: https://pastebin.com/EraQqv77
27th July 2018, 09:25 AM |#11  
vince2678's Avatar
OP Recognized Developer
Flag Toronto
Thanks Meter: 1,909
 
Donate to Me
More
Quote:
Originally Posted by MikeEx

Tested build lineage-15.1_j5_20180727_NIGHTLY-gtelwifiue:
With TWRP recovery and GAPPS provided by op links.
Data & Dalvik cache wiped.

Stuck at LineageOS boot animation and then the tablet just shuts off after a while.
dmesg.log: https://pastebin.com/EraQqv77

Dmesg alone is not useful at all. You're better off getting a logcat.

Try a clean install with no gapps and see if that works.

Previous image worked fine, and nothing much changed, so there shouldn't be any reason why it fails to boot (other devices with images built today work fine).

--Edit--

A lot of the issues might have to do with old firmware on the device, so before you flash a custom ROM you'll need to make sure you're on as recent a stock ROM/firmware as possible to avoid any issues.
The Following User Says Thank You to vince2678 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes