FORUMS
Remove All Ads from XDA

Malfunctions due to display protection

2 posts
Thanks Meter: 1
 
By Karl_33, Junior Member on 18th September 2019, 01:44 PM
Post Reply Email Thread
After I fixed a display protection glas on the screen, the tablet is getting a black after some minutes and it takes up to three minutes until the tablet is available again. Therefore, I checked the Galaxy Tab S6 manual: There is a hint that covering the light sensor with screen protection can cause problems. My screen protection glas and also the others I found on the market do not have a hole on the place of the light sensor.
The Following User Says Thank You to Karl_33 For This Useful Post: [ View ] Gift Karl_33 Ad-Free
19th September 2019, 02:05 PM |#2  
Junior Member
Thanks Meter: 1
 
More
Try Alien Surface screen protector for Tab S6. I saw they have both holes on the screen protector.
In my country unfortunately is on pre order for the moment.

Link from my country online shop of alien surface for you to check: https://aliensurface.ro/produs/samsu...ran_precomanda
30th September 2019, 01:41 PM |#3  
I got a pack of 3 glass protector from Amazon and after installing the first one the tablet became very laggy. Saw your post here and the manual does indeed say not to cover any of the front sensors with a protector. These only have a cutout for the camera. So I took it off and the tablet was still super laggy. Decided to install the second protector and do a factory reset. So far the lag seems gone. I won't say it's a permanent solution until I've spent more time with it, but I'll report back if the lag returns or not. As much as I hated doing a factory reset so soon after getting the tablet, if it fixed the problem I'll be happy. But yes, it seems covering the sensors can affect this thing.

EDIT: So far things are still going smoothly today. Have everything restored from the Smart Switch PC program and set back up. Have restarted the tablet a few times just to check even. So it seems the factory reset fixed my problems. Don't know if it matters or not, but just to be sure I did my reset from the recovery mode. So my advice for anyone that runs into issues after installing a screen protector is to back everything up, with your on device cloud options and the Smart Switch PC program imo, then factory reset and you should be good to go.
The Following User Says Thank You to RockwellB1 For This Useful Post: [ View ] Gift RockwellB1 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes