FORUMS
Remove All Ads from XDA

[Q] Whatsapp can't connect to the internet on CM11

2 posts
Thanks Meter: 0
 
By Lollomator, Junior Member on 24th September 2018, 07:28 PM
Post Reply Email Thread
Hello,
i flashed Cyanogenmod11 (11.0-20150211) on my Samsung Galaxy y some days ago and tried to get whatsapp working on it, without success so far (everything else works fine).

The whatsapp version available in google play store (version 2.17.253) is from July 2017, so it is quite old and doesn't work because it's outdated. When i start whatsapp it says the version is obsolete and i should go to the play store and download the latest version (screenshot 1), but obviously there is no update available in the play store.
So i started to download apk-files from apkmirror.com and try out newer versions. On apkmirror there are 4 different architecture versions (armeabi-v7a, x86, arm64-v8a, x86_64) available for every release (excluding beta releases). However, every time i install one of those versions whatsapp shows an error saying that something went wrong with the installation and needs to be installed again (screenshot 2). Reinstalling the app does not help, the error is shown every time.
I also tried the apk available on the official whatsapp website, but it shows the error on screenshot 2 as well.

All versions older than 2.18.122 (including 2.18.122) have different architectures available on apkmirror.com (armeabi, armeabi-v7a, x86). With armeabi-v7a and x86 it shows the same error (screenshot 2), but using the armeabi apk whatsapp does not show any errors. The armeabi versions of v2.18.122 and v2.18.105 start without any errors, any older versions are outdated so they show the obsolete error (screenshot 1).

However, the problem with the "working" versions (armeabi of v2.18.122 and v2.18.105) is that when i try to verify my number whatsapp says that there has been a connection problem and i should try again (screenshot 3).

I tried to install the outdated versions and change the phone date to when they have not been outdated, and then whatsapp works fine without any problems (but i obviously don't want to have the wrong date all the time). I was able to verify my number and i also could send/receive messages.

So i tried the following:
I installed an outdated version, changed the phone date and verified my number with it. After that, i installed version 2.18.122 (armeabi), without uninstalling the old whatsapp installation, so the data won't get deleted. Then I changed the date back to normal. So i got whatsapp without any errors, the right phone date and my number verified. However, i was not able to send/receive any messages or update my status. So basically everything requiring an internet connection did not work. I tried using wifi and mobile data, and all other apps were able to access the internet, just whatsapp behaved as i had no internet connection.

So i think when i install the versions not showing any error (armeabi of v2.18.122 and v2.18.105), there is not a problem with verifying the number, but with connecting to the internet.

The weird thing is, that all outdated versions seem to work fine (if the date is changed) and just the supported versions can't connect to the internet.
Also, if i disable all internet connections and try to start the verifying process on a "working" version (armeabi of v2.18.122 and v2.18.105), it says that an internet connection is required (screenshot 4), so whatsapp is able to check the internet connection before the verifying process starts...

Maybe the versions newer than 2.18.122 could work somehow, but i did not find a way to install them without showing the error on screenshot 2.
I also reinstalled the complete cm11 rom but it didn't change anything...

Screenshot 1: (The date when it became obsolete obviously depends on the installed version.)
screenshot 1
Screenshot 2, 3 and 4:
screenshot 2screenshot 3screenshot 4

I tried to describe my problem as good as possible so i hope you'll be able to understand everything, if not, feel free to ask what you don't understand and i'll try to describe it more clearly.
21st October 2019, 05:12 AM |#2  
Member
Flag Buenos Aires
Thanks Meter: 2
 
More
Looks like ARMv6 support was dropped from WhatsApp some time ago, and when someone installs modern WA on a ARMv6 device, Android can't copy the libraries needed for this platform (just installed WA and went to /data/data/com.whatsapp/lib, that folder was empty on new versions but on older (2.17) it had the ARMv6 libs) and thus can't start properly.
Unless someone manages to use the old libraries in the new WA versions, WhatsApp isn't going to run in our devices (even if we use Android 4.4), that's really sad.
30th October 2019, 05:05 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Yes, you're probably right. I have given up by now...
(i'm still using my galaxy y for everything else though, and it works fine)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes