FORUMS
Remove All Ads from XDA

XDA forum site speed

638 posts
Thanks Meter: 193
 
By Nikos2k, Senior Member on 8th January 2019, 08:43 PM
Post Reply Email Thread
I have the impression that xda forum site is very slow comparing to any site
And it is slow both through the browser or the tapatalk app
Is it me or this is the generally the case ?
9th January 2019, 04:23 PM |#2  
DSA's Avatar
Senior Member
Thanks Meter: 5,823
 
More
Check the other threads about the same thing in the same section you posted this in
The Following 2 Users Say Thank You to DSA For This Useful Post: [ View ] Gift DSA Ad-Free
9th January 2019, 08:53 PM |#3  
Nikos2k's Avatar
OP Senior Member
Thanks Meter: 193
 
More
Quote:
Originally Posted by DSA

Check the other threads about the same thing in the same section you posted this in

I searched with the word "speed" and the most recent thread is this:

https://forum.xda-developers.com/gen...peeds-t3728946

Are you referring to this thread? If yes, the only actual information in this is that:

"Yep, we're having a few server issues at the moment, apologies for the slow load times.
The server nerds are busy working away trying to get things back in shape"

But this statement is as of February 2018

Do you think this information is somehow helpful after almost a year?
21st October 2019, 09:29 AM |#4  
KlarkDevlin's Avatar
Member
Thanks Meter: 4
 
More
The XDA site works fine, pages load quickly. Have you tried using VPN?
21st October 2019, 09:41 AM |#5  
Torpedda's Avatar
Junior Member
Flag NY
Thanks Meter: 0
 
More
I have now checked the page loading speed. At the moment, I have received such indicators host-tracker.com/InstantCheck/1/4bac85a3-d5f3-e911-828a-0003ff73517a/ The site is stable. Maybe there are some problems with loading in different countries or certain regions?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes