FORUMS
Remove All Ads from XDA

 View Poll Results: Are the XDA Forums slow for you too?

Yes
 
6 Vote(s)
85.71%
No
 
1 Vote(s)
14.29%

XDA Forums Page Load Speed

1,312 posts
Thanks Meter: 2,236
 
By Alcolawl, Senior Member on 11th April 2016, 06:18 PM
Post Reply Email Thread
I've avoided making this thread for a while now, hoping that the problem would subside, but it hasn't.

The XDA forums, at least for me, is extremely slow. Like painfully slow at times. I realize that this is a huge site, with many many users performing all sorts of different tasks at the same time, but I have no experienced a major site like this behaving this slow for the past few months now. And it's different tasks that are slow too. Loading different threads, navigating to the next page, checking notifications, it's all dreadfully slow. I like to think that I have a fair amount of patience but sometimes the delay is unbearable, causing me to click the link again. And again... And again, until I receive this false and generic error message most likely in place just to prevent people from spamming the site or something.

My internet speed is decent:

(I took a picture instead of a screenshot so no one can say I've used photoshop or some silly crap like that)

Pinging forum.xda-developers.com results in 27ms times on average, which is pretty decent.

I've even taken a video of this lack of speed for you guys!

https://youtu.be/Z4Vc0nIVz_8
(Struggled to keep it profanity-free. Sorry for the white noise in the video, it's my air purifier on my desk. -- Page load time is like 5 seconds. What am I on dial-up?)

I've timed several page loads at nearly 8 seconds sometimes using the stopwatch on my phone. It's incredible.Is there something going on that I'm not aware of? Is the site slow like this for others? Thoughts? Recommendations?

Browser: Vivaldi 1.0.435.42 (64-bit) -- Based on Chromium.
OS: Windows 10 64-bit
Connection: Hardlined with Cat-6 into my ASUS RT68U Router running AdvancedTomato.
Pertinent Computer Hardware: AMD FX-6300 @4.2GHz, 8gb of DDR3 1600 RAM (Dual Channel)
The Following 2 Users Say Thank You to Alcolawl For This Useful Post: [ View ] Gift Alcolawl Ad-Free
 
 
12th April 2016, 02:41 PM |#2  
Trafalgar Square's Avatar
Senior Member
Flag Düsseldorf
Thanks Meter: 7,814
 
More
Yes, XDA is slow. Maybe...

But what do you think about a forum with 7,173,534 members?
13th April 2016, 01:39 AM |#3  
Member
Flag Sydney
Thanks Meter: 4
 
More
Quote:
Originally Posted by Alcolawl

I've avoided making this thread for a while now, hoping that the problem would subside, but it hasn't.

The XDA forums, at least for me, is extremely slow. Like painfully slow at times. I realize that this is a huge site, with many many users performing all sorts of different tasks at the same time, but I have no experienced a major site like this behaving this slow for the past few months now. And it's different tasks that are slow too. Loading different threads, navigating to the next page, checking notifications, it's all dreadfully slow. I like to think that I have a fair amount of patience but sometimes the delay is unbearable, causing me to click the link again. And again... And again, until I receive this false and generic error message most likely in place just to prevent people from spamming the site or something.


My internet speed is decent:

(I took a picture instead of a screenshot so no one can say I've used photoshop or some silly crap like that)

Pinging forum.xda-developers.com results in 27ms times on average, which is pretty decent.

I've even taken a video of this lack of speed for you guys!

https://youtu.be/Z4Vc0nIVz_8
(Struggled to keep it profanity-free. Sorry for the white noise in the video, it's my air purifier on my desk. -- Page load time is like 5 seconds. What am I on dial-up?)

I've timed several page loads at nearly 8 seconds sometimes using the stopwatch on my phone. It's incredible.Is there something going on that I'm not aware of? Is the site slow like this for others? Thoughts? Recommendations?

Browser: Vivaldi 1.0.435.42 (64-bit) -- Based on Chromium.
OS: Windows 10 64-bit
Connection: Hardlined with Cat-6 into my ASUS RT68U Router running AdvancedTomato.
Pertinent Computer Hardware: AMD FX-6300 @4.2GHz, 8gb of DDR3 1600 RAM (Dual Channel)

Me too !!
13th April 2016, 04:58 AM |#4  
Alcolawl's Avatar
OP Senior Member
Flag New York
Thanks Meter: 2,236
 
More
Quote:
Originally Posted by Trafalgar Square

Yes, XDA is slow. Maybe...

But what do you think about a forum with 7,173,534 members?

I did mention that I realize there are a lot of users but the amount of members doesn't really reflect how busy the site is at a given moment in time. 7,173,534 members, but the most ever online at one time was 135,390 over a year ago. Even at midnight EST (far from what I'd consider peak hours) there are ~23,000 people online, and the page loads are unbearable.
13th April 2016, 11:47 AM |#5  
the_scotsman's Avatar
Assistant Forum Admin
Flag NSW, Australia
Thanks Meter: 23,302
 
10
More
Each page has a LOT of custom content - ie the sidebar on the right, ads, custom written plugins etc. it's not the fastest forum, but it's not as slow as some. It'll depend on a large number of factors. I can't say I've ever had an issue with it being that slow where I've had to click a link for a second time.

@bitpushr might be able to provide some input here.
The Following User Says Thank You to the_scotsman For This Useful Post: [ View ] Gift the_scotsman Ad-Free
5th September 2017, 10:39 AM |#6  
Junior Member
Thanks Meter: 0
 
More
it's not as slow as different
1st July 2018, 06:59 AM |#7  
jime1's Avatar
Senior Member
Center
Thanks Meter: 81
 
More
slow for me too
even more slower on XDA 2015 theme
Attached Thumbnails
Click image for larger version

Name:	slow xda f.JPG
Views:	38
Size:	189.5 KB
ID:	4539151  
13th May 2019, 12:18 PM |#8  
TGN's Avatar
Member
Thanks Meter: 6
 
More
I can still confirm this issue.
Browsing sub-forums history is a horror.

Even with addons like NoScript and Ghostery, in multiple browsers, with a Anti-Malware modified hosts file this issue is persistent.
heck, evening opening threads takes me back to 2005.
14th May 2019, 07:39 PM |#9  
Junior Member
Thanks Meter: 3
 
More
Unfortunately it is the least performant webpage that I use. However, content is one of the most relevant to me.
Post Reply Subscribe to Thread

Tags
delay, lag, page load, slow, xda

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes