FORUMS

Lineage OS 16 connects to car, but car says ^"Bluetooth Device is Locked"

12 posts
Thanks Meter: 2
 
By xiangwuzei, Junior Member on 18th January 2020, 10:28 PM
Post Reply Email Thread
Aloha,
It readily connects to a car, or F-150 in my case, but it constantly gives the above^ message every time you push the media button in the car, just in case you ever tire of commercials on the radio. I deleted the connection a couple of times before figured out it was the phone blocking it. I think it is similar to the constant Privacy Guard notices, "XYZ app will not be able to access your personal information." But the phone is not personal information. It is an appendage that connects you to WWW.

I want to listen to my music, not commercials. Calls can be made, but I have not yet received a call so not sure if that works. I know I saw in an earlier version release notes, 14.1, release notes it says it can't connect to cars. So it is an improvement. And haven't tested 17.1 since @Claymore1297 's Rom for 10 android, 17.1 (which I used initially,) says in its' internal workings that it is in fact Android 17.1. Only discovered this because his version of Gapps for Android 10 won't install because of it. (note the Gapps site does not as of yesterdays have a build for 10 or 17.1 at least not of the stock.)

The other pertinent details are my device is an HTC One M9 with a battery life of only three or four clicks most times, but works when plugged into an external power source e.g. the car.

I may have just found a solution. Google Play Protect is the source of above mentioned Privacy Guard. Disable it. Or just go into Google setting and turn off. Which is what I just did. But Now I need to drive somewhere and (I have had to much to drink, 2 beers at 7.8%) So It can wait till tomorrow. (Alas Google is trying to run our lives. Even after disabling in Google settings and rebooting it still pop ups saying Privacy Guard is protecting you from yourself. Time to disable in app settings.) I just noted the fact that when I click on the i icon it takes me to the Android System app info. So maybe it is not the Google self protection service, but I need to verify in apps if it re-enabled itself. Far too many Google and carrier apps can do this. So much for painting the Google machine black, the setting is still turned off. (this is turning into a step by step trial and error solution post.)

p.s. @MishaalRahman 2004+1^n Thanks
p.s.s I just checked the Lineage official website (See No Links in initial post) and there is only a build on there for HTC One 2014 (m8) no m9.
18th January 2020, 10:40 PM |#2  
OP Junior Member
Ultra Mobile
Thanks Meter: 2
 
Donate to Me
More
Lineage Privacy Guard enabling apps post
Aloha,
Well on my search for improving the above situation I came across the following post on here by @OhioYJ about using the command prompt and a script to set a permissions to shut up the constant Privacy Guard.
[Guide] Improve / Fix Privacy Guard in Lineage
https://forum.xda-developers.com/sho....php?t=3739136 (not an outside link)

My theory as of now is that Bluetooth is just another app that is Guarded to death, rather than notified to death
19th January 2020, 02:29 AM |#3  
OP Junior Member
Ultra Mobile
Thanks Meter: 2
 
Donate to Me
More
It was just the Bluetooth permission for HD audio
For some dumb reason, the settings for individual bluetooth pairings has a number of permissions not enabled by default. Just enable it then delete the connection stored in the vehicles and I've got tunes. No scratchiness in previous versions.

But the vehicle still complains with the same message because I don't allow contacts.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes