FORUMS

 View Poll Results: What do you wanna see most on a uconnect system

Android!
 
108 Vote(s)
68.79%
Custom programs
 
11 Vote(s)
7.01%
Themes/UI Mods
 
4 Vote(s)
2.55%
Free wifi hotspot
 
9 Vote(s)
5.73%
Something even more awsome
 
3 Vote(s)
1.91%
Remove speed lockout
 
6 Vote(s)
3.82%
Add features (i.e. movies on the screen/games)
 
16 Vote(s)
10.19%

Rooted Jeep Cherokee '14 uConnect

50 posts
Thanks Meter: 21
 
By cm0002, Member on 5th September 2015, 03:40 AM
Post Reply Email Thread
25th July 2019, 09:04 PM |#241  
Senior Member
Flag Bradford
Thanks Meter: 100
 
More
Quote:
Originally Posted by Mousie123

Sorry with all the posts on an old thread, but I finally solved it and all australian maps up and running thanks to this forum and others. I just had an issue with the basemap and lyc file given I was moving from a non nav unit in AU so had to get the right lyc and map to fire up. Works a hoot.

Hi Mousie123,

Can I just ask you what lyc / basemap / version of maps... have you used as I am working on a map pack for everybody to be able to use but am unable to find a upto date AU / NZ map with valid lyc files.
I have 2018q4 TomTom and HERE AU / NZ maps but cant use them as no lyc for them.

I currently have a Full EU 2019q1 and NA 2018q3 map pack and would like to be able to offer a ROW (AU/NZ) pack lol
25th July 2019, 09:51 PM |#242  
Junior Member
Thanks Meter: 0
 
More
Hi,

In the end I used the basemap from the sox website, it was the only AU/NZ map update available for MY2014 and currently posted on that forum. It works with my (8) *.Lyc files for 2018Q2 IGO World Nextgen for andriod. So I didn't need any uConnect lyc files at all. for some strange reason, the original basemap in my (8/13 Wk2) non-nav MY13 RebB 8.4 uconnect would not work given I was the odd one out as Jeep changed to the 8.4 in Aug 2013 but if you look at the sox map update the */lyc files cater for RevB and RevA and only for MY14 (Leighm0 advice on matching years is very correct). Forcing productid change from RevB to A or MY13 to My14 combinations failed influence this. the Map AU/NZupdate file were all for MY14. Luckly I had years ago copied off a single Lyc file from the premium section in jeep .org which was for a MY13 RebB file and that was the only lyc that would work in my jeep initially to get access to India, Argentenia and a couple of other country maps from the ROW profile installed.

A side issue I cannot confirm is in th process I removed the entire VR folder, fired it up and then reloaded the VR folder. I'm not 100 percent certain something had effect here. Also, checked a few GPS sites after comparing my lyc files and obvioulsy I would have been wasting my time with maps and unknown quantity with lyc's. I.e. you want to know you have a valid set for when modding here.

Another side issue I had with USB uploading method is for some reason one command must have been a space or letter out hence I gave up on that with a half load (my fault of course) and just reverted to network in on my dlink subD (rev.b1) dongle so manage the transfers direct. Hope this helps
27th July 2019, 05:25 AM |#243  
OP Member
Thanks Meter: 21
 
More
hey everyone!

Its been awhile, glad to see this thread has evolved so much

anyways, has anyone else been having trouble running cmds.sh off USB? I'm still on 14.05.3, and got the annoying OTA nag screen, i was working on how to supress it and did an initial redump with cmds.sh, but after that cmds.sh stopped working. Sometimes i can get something simple to run like echo foo > /fs/usb0/test.txt if i keep changing USBs out, but anything more complex simply doesn't run
28th July 2019, 06:42 AM |#244  
Junior Member
Thanks Meter: 0
 
More
Activation code directory appearing in License folder
Folks, this empty folder is appearing in my license folder and was not there before. I deliberately removed it and it springs back. So is this a hint to perform the touch cmd to create ACTIVATION_CODE within the License folder to assist here. Anyone else noticed this? I just don't want to rip all my IGO maps out to see what this does?
29th July 2019, 04:21 AM |#245  
drizze99's Avatar
Senior Member
Flag Bear
Thanks Meter: 80
 
More
I just bought a 2016 Challenger RT+ which comes with the 8.4 RA4 touch screen. I also just bought the Z Automotive Tazer OBDII dongle.

I'll start by saying that I HATE Uconnect! I want to unlock the Performance Pages and I've done it twice now after restoring the radio to factory defaults and after about 30 sec, Uconnect flags the app and deletes it making me one pist off Challenger owner.

I would love to neutralize Uconnect. Every though I don't have an active Uconnect account, I feel like the radio is communicating with FCA to delete that app.
29th July 2019, 04:49 PM |#246  
drizze99's Avatar
Senior Member
Flag Bear
Thanks Meter: 80
 
More
@Tooltime you seem to be the only user in this thread that has a Dodge Challenger. Do you have the Performance Pages activated and working on your car? It looks like the Uconnect firmware that is on my Challenger is 16.09.09 according to the engineering menu. V850 App is 16.7.0 and the V850 Boot is 13.1.0...
2nd August 2019, 06:26 AM |#247  
Junior Member
Thanks Meter: 0
 
More
Hello everyone,

I'm interested in looking into the cambia commands for the HVAC system. Unfortunately I have a MY17 system so I'm stuck just picking around the 14.05.3 update file. Can anyone point me in the right direction to where the code that send the canbua messages is located in the update iso.

Looks like I need to dig into com.harman.service.HVAC where is this located?
2nd August 2019, 09:17 PM |#248  
Junior Member
Thanks Meter: 0
 
More
Can someone pm me a dump of filesystem from a rooted Uconnect 8.4, I am stuck with a MY17 unit for now
3rd August 2019, 10:10 PM |#249  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Freeloader247

Hello everyone,

I'm interested in looking into the cambia commands for the HVAC system. Unfortunately I have a MY17 system so I'm stuck just picking around the 14.05.3 update file. Can anyone point me in the right direction to where the code that send the canbua messages is located in the update iso.

Looks like I need to dig into com.harman.service.HVAC where is this located?

For anyone else interested it looks like actual CAN messages are predefined on the V850 chip firmware (cmcioc.bin). The original hacking whitepaper has a great section on reverse engineering the firmware.
3rd August 2019, 11:32 PM |#250  
Junior Member
Thanks Meter: 2
 
More
Hey, version 16.09.x sounds very much rootable (anything lower than 16.51.xx they say) and once you have wifi and ssh root access, I guess you can just as well block any unwanted connections with packet filter. Though I did not have to do that as 8.4 RA4 of mine is very much outside of Sprint coverage

In my case it was just enough to poke with preferences file in Performance Pages app folder to make it appear in the menu (to make the car model string match). Some sensors show nothing in my case (like G-force), but that's kind of expected considering the car model at hand. App itself appears to work fine though.

Quote:
Originally Posted by drizze99

@Tooltime you seem to be the only user in this thread that has a Dodge Challenger. Do you have the Performance Pages activated and working on your car? It looks like the Uconnect firmware that is on my Challenger is 16.09.09 according to the engineering menu. V850 App is 16.7.0 and the V850 Boot is 13.1.0...

5th August 2019, 02:19 PM |#251  
drizze99's Avatar
Senior Member
Flag Bear
Thanks Meter: 80
 
More
Well I think I might have screwed myself. I was working with another MY16 Challenger owner who updated his firmware to the latest version (17.43.01) and since he was working just fine, I went and updated my system and I thought I had it since the Performance Pages lasted an entire day. My happiness was squished quickly the next day when the pages were gone again. Now I think I am on an un-rootable version of Uconnect.
Post Reply Subscribe to Thread

Tags
blackberry, jeep, qnx, root, uconnect

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes