FORUMS
Remove All Ads from XDA

uConnect 6.5 (Alfa / Fiat) Root Access

272 posts
Thanks Meter: 73
 
By SquithyX, Senior Member on 12th August 2018, 01:28 PM
Post Reply Email Thread
5th August 2019, 08:07 PM |#601  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by SquithyX

Hi, the minium version of software I have tried to work on is 15.43.00. You could try to do my mods with your version 13 software - it should work, though may need the older / original NaviServer2 (I will upload it to the share). If it does not work you have a backup and the 15.46.00 unmodified update file to restore your uConnect with.

Hi,
Thx for the answer.
I did the upgrade to 15.43 using the regular package from uConnect.
Then 2 or 3 times did the EU Map (with only few countries in the content + basemap to speed up).
First installation gave strange results, I have got SRT start window but there was no mapdb and no naviserver in the admin menu.
Second attempt gave me back fiat start window, navi is checking the license and opening main window for a while and then freezing on the window "Please wait".
I applied small Iden package to get the radio frequency step by 0,1 MHz, it finished but did not helped, frequency step is still ,2. Reboots done all the time.
Once I applied newest Iden package (with Naviserver) I am getting back to freezing window "Navigation is being activate" and no progress.

Tomorrow I will continue.

BR/Codi
 
 
6th August 2019, 02:09 AM |#602  
Junior Member
Thanks Meter: 0
 
More
[QUOTE=SquithyX;80020249]
Unfortunatly the 8.4 uConnect's software is too new - for the 8.4's you need firmware < 16.10.xx, anything newer is locked down and still not hackable yet!


Thanks for the quick reply, lets wait and see if there's any hope in the near future, thanks again.
6th August 2019, 08:25 PM |#603  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by lden

Files to start navigation on Us devices:
1. Run EU maps hack
2. Unpack the files to the root folder of your pen drive (magic swdl.iso must be already there)
3. Insert the pen drive to your uConnect - it should take about 5 minutes (press NO to update firmware).
4. Restart the unit by pressing Browse button and Power button for ~20sec.

5. Please send me the backup folder after you run the script - it will help to fix Radio frequency for US uConnects.

Firmware 16.05.33 here. I used your latest files attached to one of your later posts. I waited for 10 minutes, but nothing happened, no update firmware prompt or anything. The swdl.iso is present on the stick, it's the same one used for the maps hack. I restarted the unit just in case and the navigation tab now says "Navigation is being activated" (previously there was only blank screen). What should I do at this point? Just try a few more times?

---------- Post added at 08:25 PM ---------- Previous post was at 08:16 PM ----------

Quote:
Originally Posted by SquithyX

Well here it is.... I think, the Complete conversion from US to EU solution..... maybe lol

If you have a US uConnect that you want to convert to EU then you should download this pack:

https://mega.nz/#!MR4TDAgS!zDPEpyRGc...tLQ-iTODcwZJeU

It will take your v15.xx firmware US uConnect and update it to v17.07.46, install the 2019v1 map pack and all the files needed to enable SatNav and EU radio reception.
Unlike my other packs, this one contains everything you need including the magic, making it a very big download.

I may make a split version later if needed.

Any chance for the same conversion for the v.16.05.33 firmware?
6th August 2019, 09:17 PM |#604  
OP Senior Member
Flag Bradford
Thanks Meter: 73
 
More
Quote:
Originally Posted by Geolith

Firmware 16.05.33 here. I used your latest files attached to one of your later posts. I waited for 10 minutes, but nothing happened, no update firmware prompt or anything. The swdl.iso is present on the stick, it's the same one used for the maps hack. I restarted the unit just in case and the navigation tab now says "Navigation is being activated" (previously there was only blank screen). What should I do at this point? Just try a few more times?

---------- Post added at 08:25 PM ---------- Previous post was at 08:16 PM ----------





Any chance for the same conversion for the v.16.05.33 firmware?

If it is a uConnect 6.5 then try using the modified 17.07 image instead of the 15.46 image.... Or if you have the 16.05.33 software, upload it for me and I will modify it to work for you.

Sent from my CLT-L09 using Tapatalk
6th August 2019, 09:58 PM |#605  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by SquithyX

If it is a uConnect 6.5 then try using the modified 17.07 image instead of the 15.46 image.... Or if you have the 16.05.33 software, upload it for me and I will modify it to work for you.

Will the full backup of my original, unmodified US 16.05.33 software do? I could zip it and upload it somewhere for you.
7th August 2019, 12:49 AM |#606  
OP Senior Member
Flag Bradford
Thanks Meter: 73
 
More
Quote:
Originally Posted by Geolith

Will the full backup of my original, unmodified US 16.05.33 software do? I could zip it and upload it somewhere for you.

Unfortunately it would now work as the iso is signed and the backup is not. Though if you have a backup from using my script it should allow you to use it for the whole process.

Sent from my CLT-L09 using Tapatalk
7th August 2019, 06:44 AM |#607  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by SquithyX

Unfortunately it would now work as the iso is signed and the backup is not. Though if you have a backup from using my script it should allow you to use it for the whole process.

Yes, the backup was made using your script from the "BACKUP - NA or ROW to EU Convert" folder. I did it prior to the failed map hack attempt, as per instructions from the first page. Could you please download it and take a look?

https://drive.google.com/open?id=18e...4gtZUCmQhkuioE
9th August 2019, 07:49 PM |#608  
OP Senior Member
Flag Bradford
Thanks Meter: 73
 
More
Quote:
Originally Posted by Geolith

Yes, the backup was made using your script from the "BACKUP - NA or ROW to EU Convert" folder. I did it prior to the failed map hack attempt, as per instructions from the first page. Could you please download it and take a look?

https://drive.google.com/open?id=18e...4gtZUCmQhkuioE

Hay, I have had a look through your backup, the NA to EU conversion that you have downloaded already has the correct FRAM file conversion for you so their should be no problem with your firmware being 16.xx and my magic swdl.iso being 15.xx. If you prep the USB as described in the readme (USB 1 & 2) and follow the instructions it should enable you to install the EU 17.05.46 firmware and then update the maps to the 2019v1 (included in the pack).

***Once updated to v17.05.46 there is no way of reverting back to NA v16***
9th August 2019, 08:44 PM |#609  
Member
Thanks Meter: 2
 
More
There is no way to do this update by using fram files from 524 product unit. The system gets freezed and doesn't load on 333 unit as soon as fram files are changed. I tried it many times. It is not possible to update to 17.07.46 this way.
9th August 2019, 08:55 PM |#610  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by wildcook

There is no way to do this update by using fram files from 524 product unit. The system gets freezed and doesn't load on 333 unit as soon as fram files are changed. I tried it many times. It is not possible to update to 17.07.46

But fram files are not part of the big package with map (eg Europe 2019v1) ? Or it could be other way around. Fram files are not copied in the package so it causes issues on the load.
BTW. I failed as well, navi system is hanging on the please wait screen. I am using personally iGo since years. Once there is new set of the map it is creating kind of the index in the memory. On my old navigation it takes less than minute. Maybe here we have case that is it trying but it fails (memory is mounted RO or something).
Generally i did the process few times pure package from page 1 or Iden package. Unit is from 500l coming from NA.
CODI
9th August 2019, 09:42 PM |#611  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by SquithyX

Hay, I have had a look through your backup, the NA to EU conversion that you have downloaded already has the correct FRAM file conversion for you so their should be no problem with your firmware being 16.xx and my magic swdl.iso being 15.xx. If you prep the USB as described in the readme (USB 1 & 2) and follow the instructions it should enable you to install the EU 17.05.46 firmware and then update the maps to the 2019v1 (included in the pack).

***Once updated to v17.05.46 there is no way of reverting back to NA v16***

I'm sorry, but I'm confused. How exactly do I install the 17.05.46 firmware? Where do I get it from?

Never mind that, figured it out.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes