FORUMS
Remove All Ads from XDA

[Doogee X6 S] getting rid of OEM adware

1 posts
Thanks Meter: 0
 
By captnfab, Junior Member on 14th October 2019, 06:22 PM
Post Reply Email Thread
Hi.
I have a Doogee X6 S.
It is currently flashed with stock ROM¹, which runs Android 6.0 with a 3.4.5 kernel and contains OEM adware, and maybe worse.
I'd like to be able to flash a more trustworthy rom of android.

I was unable to root the device with kingoroot app. The bootloader is locked, I can't flash TWRP.
I tried to unlock the bootloader:
- I unlocked and enabled developer options,
- I checked the "oem unlocking" option ("allow the bootloader to be unlocked"),
- "adb reboot bootloader" rebooted the phone in fastboot mode
- "fastboot oem unlock" asked me confirmation for unlock, VOL_UP for "Yes", VOL_DWN for "No", but none of the keys have any effect when pressed.
I tried flashing older versions of the stock ROM with SP Flash Tool, but this resulted in a softbick (solved by flashing back last stock ROM).
I tried contacting Doogee support, to no avail.

I don't know what to try next, so here I am!
While I'm not an Android hacker, I know my Linux, and I'm not affraid of complex solutions.

¹ available from official support page: community.doogee.cc/forum.php?mod=viewthread&tid=4872
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes