FORUMS
Remove All Ads from XDA

[MOD] Google Keyboard with updated iOS 9.1 Emojis

52 posts
Thanks Meter: 120
 
By Qu3ntin0, Member on 24th October 2015, 08:12 AM
Post Reply Email Thread
24th October 2015, 07:34 PM |#31  
qtipbailey's Avatar
Member
Flag Atlanta
Thanks Meter: 52
 
More
Quote:
Originally Posted by sgrabarz16

Thanks for your work! Keyboard has the new emojis, however gesture typing seems to be broken for me.

Also, the new emojis need to be resized, they are quite a bit smaller than all the other ones right now.

I experienced the same thing but I saw a popup saying it was downloading english suggestions and would be available shortly and pretty soon gesture typing started working.
 
 
24th October 2015, 07:47 PM |#32  
Member
Thanks Meter: 110
 
More
Thanks, man! The keyboard worked fine, but i used the ttf from my thread instead of that one from here.
24th October 2015, 07:49 PM |#33  
Psych0t1c20's Avatar
Senior Member
Flag Jersey
Thanks Meter: 109
 
More
Actually could this be keyboard mod be implemented into the stock aosp keyboard? Just because it has the number row, and more characters on the keys.
24th October 2015, 09:14 PM |#34  
Qu3ntin0's Avatar
OP Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by Psych0t1c20

Actually could this be keyboard mod be implemented into the stock aosp keyboard? Just because it has the number row, and more characters on the keys.

That is possible, but I would have to make one for each Android build (5.0.2, 5.1.1 etc)
24th October 2015, 09:34 PM |#35  
Junior Member
Thanks Meter: 0
 
More
Font file is crooked
I have a non-rooted note 5. I downloaded the ttf file from the zip and installed it thru app hifont so I can select this font thru my traditional settings > font. It works and I can see the new ios 9 emojis on the keyboard and my texting app (textra) but the font file is crooked. the phone appears to be higher than usual so I can only the end tips of the end of the letters/characters when using it. Anyone else having this issue?
24th October 2015, 09:46 PM |#36  
DespairFactor's Avatar
Recognized Developer / Recognized Contributor
Flag Toronto
Thanks Meter: 12,362
 
More
Quote:
Originally Posted by caiosilva96

Thanks, man! The keyboard worked fine, but i used the ttf from my thread instead of that one from here.

Yeah, my font file is too big, did you make a flashable?
24th October 2015, 10:02 PM |#37  
Qu3ntin0's Avatar
OP Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by ekapoo

I have a non-rooted note 5. I downloaded the ttf file from the zip and installed it thru app hifont so I can select this font thru my traditional settings > font. It works and I can see the new ios 9 emojis on the keyboard and my texting app (textra) but the font file is crooked. the phone appears to be higher than usual so I can only the end tips of the end of the letters/characters when using it. Anyone else having this issue?

That's strange... You can try another ttf file and see if that works (check OP for new links)
24th October 2015, 10:19 PM |#38  
thegrim11's Avatar
Senior Member
Thanks Meter: 111
 
More


Why are some of my emojis black and white?
24th October 2015, 10:40 PM |#39  
funeralcrows's Avatar
Senior Member
Thanks Meter: 67
 
More
Quote:
Originally Posted by thegrim11



Why are some of my emojis black and white?

I can give you a solution for this but it's quite technical and you need to have slight XML knowledge (easy). You ready? Here we go!

- Go to /system/etc/ and open fonts.xml in an editor.
- Locate this entry:
<family>
<font weight="400" style="normal">NotoColorEmoji.ttf</font>
</family>
- Move that entry (cut and paste) below this line (This is the 95th line or somewhere near there.):
<!-- fallback fonts -->
- Save file.
- Make sure permissions are 644 (-rw-r-r).

- Now open /system/etc/fallback_fonts.xml in an editor:
- Locate this entry:
<family>
<fileset>
<file>NotoColorEmoji.ttf</file>
</fileset>
</family>
- Move that entry (cut and paste) below this line (the line is at the beginning of the xml after the description comment.):
<familyset>
- Save file.
- Make sure permissions are 644 (-rw-r-r).

- Reboot.
The Following 16 Users Say Thank You to funeralcrows For This Useful Post: [ View ] Gift funeralcrows Ad-Free
24th October 2015, 11:03 PM |#40  
Qu3ntin0's Avatar
OP Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by funeralcrows

I can give you a solution for this but it's quite technical and you need to have slight XML knowledge (easy). You ready? Here we go!

- Go to /system/etc/ and open fonts.xml in an editor.
- Locate this entry:

<family>
<font weight="400" style="normal">NotoColorEmoji.ttf</font>
</family>
- Move that entry (cut and paste) below this line (This is the 95th line or somewhere near there.):
<!-- fallback fonts -->
- Save file.
- Make sure permissions are 644 (-rw-r-r).

- Now open /system/etc/fallback_fonts.xml in an editor:
- Locate this entry:
<family>
<fileset>
<file>NotoColorEmoji.ttf</file>
</fileset>
</family>
- Move that entry (cut and paste) below this line (the line is at the beginning of the xml after the description comment.):
<familyset>
- Save file.
- Make sure permissions are 644 (-rw-r-r).

- Reboot.

Tried this but some are still black and white. I'm let you guys know if I find a solution for this.

OK I can clarify this works. I'll update OP with your solution.
24th October 2015, 11:12 PM |#41  
PhilPan's Avatar
Senior Member
Central NJ
Thanks Meter: 185
 
Donate to Me
More
Gesture typing doesn't seem to work. You think you will put out a fix for this?

Sent from my A0001 using XDA Free mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes