FORUMS
Remove All Ads from XDA

[ROOT] One Click Root for Bluestacks 2

699 posts
Thanks Meter: 601
 
Post Reply Email Thread
19th March 2016, 10:12 AM |#11  
Root
With Bluestack easy it can be rooted
You should only change the files with the SuperSU 2.70 and use the su.pie

\Bluestacks Easy\input\Add\Root
inside I put
busybox 1.24.1
su (x86 su.pie)
Superuser.apk

Bluestacks Easy\input\Root
change su3 and Superuser3.apk

Bluestacks Easy\input\Add
libsupol.x86
supolicy.x86

I do not know if this is necessary or just the file in input\Root

Bluestack version 2..1.7.5658

other versions of SuperSU gave me trouble to update the binaries

I apologize if my English is not good
 
 
18th April 2016, 10:11 PM |#12  
Junior Member
Thanks Meter: 0
 
More
I have Bluestacks version 2.2.19.6015 . KingRoot works ,but every time i restart Bluestacks the root dissapears.I tried changed KingRoot to SuperSu with Supersume but the root still dissapeared when i restarted Bluestacks.

I would like to try to root Demicro's way ,but i don't understand everything he says. Maybe he can detail a little about where to get those files and with what to change.
1st May 2016, 06:59 AM |#13  
Senior Member
Flag Delhi
Thanks Meter: 66
 
More
how to root bluestack v 2.2.???
i m unable to root bluestack v2.2 by bluestack easy v3.5, as the filesystem of bluestack has changed from root.fs to root.vdi ( virtual disk image).

plz anyone help us to root bluestack v2.2
3rd May 2016, 06:20 PM |#14  
AJPuzon's Avatar
Member
Flag Makati
Thanks Meter: 10
 
More
Somehow I tried that too in Bluestacks original and it did the same thing, I think because the system is virtual and that affects the rooted process, I rooted the bluestacks and it went successful but after I rebooted to use xposed framwork, after it reboots, it losted its root access, weird thing that kingroot detected it as a Samsung device. Peace
27th May 2016, 06:09 PM |#15  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by syemujahid1911

i installed kingroot and rooted bluestacks but when i try to run xmod for games a message pop ups saying root your divice.
please help me

Thats because XMOD does not work on any emulator, including bluestacks. I dont even know if they support x86 /x64 yet...
20th July 2016, 11:49 PM |#16  
Junior Member
Thanks Meter: 0
 
Donate to Me
More
who can i find this old version 2 from dez 2015 for root to download?
14th September 2016, 03:35 PM |#17  
Junior Member
Thanks Meter: 0
 
More
Does not work
KR is not working on BS2
7th November 2016, 09:06 AM |#18  
hrc3000's Avatar
Member
Thanks Meter: 8
 
More
Yup, it's not working...
7th November 2016, 10:33 AM |#19  
Account currently disabled
Thanks Meter: 6
 
More
Thanks!
4th December 2016, 02:12 AM |#20  
Junior Member
Thanks Meter: 0
 
More
Doesnt work
Even the kingroot app doesnt work. It is identifying my device as my phone which is Asus-T00J which i sold it away a few months ago. Do i have to logout from my google account for the kingroot to access the bluestacks?? because it always says "your phone is on the queue for rooting" or something...
14th December 2016, 01:47 AM |#21  
Junior Member
Flag Los Angeles
Thanks Meter: 1
 
More
If anything, cause I'm still looking myself, there's a youtube vid of someone getting root on Bluestacks v2.5.78, not sure if someone wants to give it a try? https://youtu.be/9S7rG7cYO-Q
Post Reply Subscribe to Thread

Tags
app player, bluestacks, bluestacks 2, root

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes