FORUMS

Teclast M30 Tablet General Thread

28 posts
Thanks Meter: 6
 
By TechGuru123, Junior Member on 8th September 2019, 04:34 PM
Post Reply Email Thread
20th February 2020, 12:15 PM |#81  
Junior Member
Flag Korolev
Thanks Meter: 1
 
More
Quote:
Originally Posted by frenkac

Is anybody able to help me please? I flashed TWRP through fastboot, went to recovery, but I can not install any GSI rom due to 0 MB space within internal storage as it simply does not let me knock the field for it, only SD card..
THX!

Edit:
I managed to get the correct space of internal storage when wipe option "change of file system" to ext2 and back ext4 was done.. BUT when I want to flash any GSI img (only A) I get the same error, "size of image is larger than target device" ;(
See pic

Are You trying to flash system SGI image? Then you have to format SYSTEM partition. SYS partition have about 2.4 GB on my M30. What size of GSI are you loaded?
27th February 2020, 02:14 AM |#82  
Junior Member
Thanks Meter: 2
 
More
I will test the device you give today
4th March 2020, 03:20 PM |#83  
Member
Thanks Meter: 5
 
More
Here you have the link to the stock firmware and boot.img needed for root. Also magisk is included and instructions on how to root are writen just download the torrent from this site and you will get all that you need for M30Teclast X27
https://www.partis.si/torrent/podrobno/569942
You have to press the button (prenesi torrent)
6th March 2020, 08:03 AM |#84  
Junior Member
Thanks Meter: 0
 
More
Hello everybody

Anyone can say more on GSI image installation on this device?
20th March 2020, 12:33 PM |#85  
Senior Member
Thanks Meter: 42
 
Donate to Me
More
Google apps. How?
I reinstalled both fw versions, rooted, wasn't able to get any of the Google services running, they just keep on crashing, with every installer I tried. If any of you managed to get it working, please share how.
23rd March 2020, 01:23 AM |#86  
Junior Member
Thanks Meter: 0
 
More
Jamaica
I hope I win the Huawei phone
25th March 2020, 02:51 PM |#87  
Senior Member
Thanks Meter: 42
 
Donate to Me
More
Did any of you met trouble in getting a SIM card recognized?
I've gone through several firmwares, and tried several SIM cards I have in my household - none of them are being detected (all of them work on cellphones).

In the SIM settings, both checkboxes are greyed out, and SIM cards in both slots aren't being detected.

Tried both with locked and unlocked bootloader.

Any bright ideas? Or is it a hardware malfunction?

EDIT:
IMEI is missing, trying to figure out how to restore it.
26th March 2020, 12:41 PM |#88  
Tinderbox (UK)'s Avatar
Senior Member
Flag England, UK
Thanks Meter: 407
 
More
My battery temp seems to be locket at 25c and never changes.
I have tried a dozen info apps and they all say the same 25c
I have been using GSam Battery for years and it`s battery temp alarm has saved my skin when a rogue app makes my tablet/phone heat up while it supposed to be asleep and in it`s case, I been woken in the middle of the night and found my tablet very hot and had to reboot to fix the problem.

I absolutely love this tablet, It plays all my movies and tv show with no problem, Even my Anime that use 10-bit 265 or 264 codec, I use MX Player as it seems the best.

Thanks
29th March 2020, 04:23 PM |#89  
Junior Member
Thanks Meter: 0
 
More
Hi guys, I just received this Teclast M30 (version M5P3) and wanted to flash a custom ROM on it. But I'm now stuck on a bootloop.

- Went to developer option, allowed Bootloader unlocking.
- Unlocked the Bootloader without any error via:
Code:
fastboot flashing unlock
- Flashed TWRP (found on this thread) without error on fastboot:
Code:
fastboot flash recovery twrp-3.3.1-teclast-m30-20191201.img
- Flashed a GSI (ARM64 A-only) ROM and no error occured during flashing.
(I used the "Android 9 - Havoc-OS v2.9" ROM on this link => github.c*m/phhusson/treble_experimentations/wiki/Teclast-m30-%28MT6797x-helio-x27%29 )
Code:
fastboot flash system Havoc-OS-v2.9-20190914-phhgsi_arm64_a-Official.img
Then when trying to boot after flashing, I'm stuck on a bootloop.
It shows the Teclast Logo with some text saying it's in Orange State (= bootloader unlocked) and then go to a screen with an Android Logo and a message saying: "No Command".

The problem is this screen stays only for about 3 seconds, and then the screen become black for 1 sec, then the "No Command" screen appears again for 3 sec, then it disappears again, endlessly. Pressing "Power & Vol+" or "Power Button & Vol-" on this screen does nothing, I just can't enter fastboot mode as it keep looping and do not stay on the "No Command" screen.

The "Reset" button on the tablet seems useless and when pressing it, it only shut down the tablet and stops the loop. I tried pressing it for long periods like 10-20-30 seconds but it just keep shut down and do nothing.

When the tablet is completely shut down, I tried powering it up pressing just the "Power" button, but also "Power & Vol+", "Power Button & Vol-" but it does the same thing every time. It also acts identical whether the tablet is plugged in via USB or not.

Does someone have any leads on what I can do to revert back to original state or even just access fastboot mode ?

Thanks

EDIT: I just realized the TWRP given on this topic (https://forum.xda-developers.com/sho...5&postcount=56) was for the M4P7 version and mine is M5P3.. Makes sense it's not working BUT even with this info, it doesn't help for my problem.
Today, 01:11 PM |#90  
Junior Member
Thanks Meter: 0
 
More
I own two M30, one is M5P4 (this I rcvd first) and one is M5P3 which I received yesterday. The latter is called KX20 while the first one is called TLA002, see screenshots, both are in "Reader mode", and "eye comfort" both activated:




M30 M5P3


I dont know exactly which the differences are (if any) but the one which looks like with a creamed background is which I like better for reading eBooks and mainly PDFs. A bit strange that I dont like the one with the white background better, isn't ??

M30 M5P4
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes