FORUMS
Remove All Ads from XDA

My (un)pleasant experience rooting the Samsung Galaxy S8 G950U

1 posts
Thanks Meter: 0
 
By kelvinkel101, Junior Member on 27th March 2018, 01:29 AM
Post Reply Email Thread
All links to articles that I tried to follow are at the bottom of this post. Attempt this root at your own risk!
Let me start out by saying I have successfully rooted Android phones before (Motorola Droid from 2009 and LG G3 Vigor from but this phone was not wanting to cooperate from the very start. My intention was to root my Galaxy S8 so that I can install a custom ROM and get rid of unneeded software (i.e. Google, Sprint software, etc...). As it turns out, this is easier said then done. After A LOT of searching on this site and DuckDuckGo, I came across a few articles that seemed like they were legit and would get the job done. So, I prepared by downloading all the necessary files (the new firmware, Odin, adb, etc...) and factory resetting my device. I then tried to follow along with the first tutorial. Everything looked good. I was able to get everything set up just fine. My problem started when I was in the Download mode on the device (the light blue screen that says "Downloading..." in the center).

Before even connecting the device, I had PrinceComsy Odin fired up and ready to go being sure to follow the tutorial steps completely and accurately. Then, I connected my device and hit start.
...It's looking good!...
...Added!...
After a few other very promising log outputs .... nothing happened. I thought to myself, "Okay, no big deal. It said I may have to retry a couple times to get it to work." So, I reset everything back up and rebooted the phone back into Download mode. This time I tried the regular Odin version instead. However, I was presented with an error after hitting start: "SHA256 Invalid". After some searching, I found out that if you get that error in the regular Odin you should try the PrinceComsy Odin. Wow, okay, so I went back to PrinceComsy Odin and tried again to no avail. Still didn't work.

This is when I started to become concerned that I wouldn't be able to root this phone. Note: At this point, the phone still booted back into the OS with no problems. i.e. It was not bricked...yet!
I wasn't even past the Odin part of the root and already I was having problems. What was going on? I did some more searching around the web and these forums and found something interesting. Supposedly having your device plugged into the USB3.0 ports on your computer can sometimes mess Odin up. I tried plugging the phone into the normal USB2.0 ports on the back of my computer and restarted the whole process again.
Now, I was getting some weird errors. Stuff like "odin fail complete(write) operation" and "fail (no pit partition)". I started to sweat a little bit. I can't screw this phone up! I rebooted the phone just to make sure everything was still fine on the device. It booted into OS perfectly fine, again.

Okay, so one more try, and then I'll stop. I did everything again (booted phone into download mode, fired up PrinceComsy Odin, added firmware to appropriate slots, connected the device, and hit start). Once again, everything looked fine until I got another error, "Error SW REV CHECK FAIL : [aboot] Fused 4 > Binary 2". It was at this point I looked more closely at the text on the top left of the Download mode.
My bootloader was locked and for some reason that had something to do with all this failing. After all, I wasn't trying to change the bootloader at all; just trying to gain access to root permissions. Most of the tutorials I looked at said to enable the "OEM Unlocking" option in settings. However, I didn't have this option at all. I didn't think it would matter that much but boy was I wrong. I decided to give up, boot back into the OS, and call it a day.

I rebooted the phone and it took longer than normal. Like way longer. It was stuck at the Samsung splash screen for about an hour before I realized that the device was probably bricked. "Great," I thought. So, I managed to find the stock firmware on Sam Mobile. Once again, I used Odin and tried flashing the stock firmware. This time however, Odin actually completed! I thought I had done it. I successfully restored my phone, right? Nope, turns out the firmware I installed wasn't actually Sprint's original stock firmware. I'm not sure exactly what it was but everything looked fine until I entered the setup device screen. Some settings were greyed out and I was getting some weird error messages (I don't remember what they were). Then, after completing the setup, I noticed that I was no longer on the Sprint network. I also had some of Cricket's and MetroPCS apps installed by default. It was like the phone was in a so called "carrier limbo" and unable to connect to any one carrier. The weird thing is I was still able to send and receive phone calls and receive text messages. It was at this point, I realized I royally screwed up my phone I tried to factory reset (through the Recovery mode) hoping that would fix some issues but nope. Didn't seem to fix anything.

The next day, I took the phone back to the Sprint store to see if they could do anything. Of course, I knew they were just going to try factory resetting it as well. The tech came back and said they could ship it off to Samsung and have them repair it or replace it. I am really crossing my fingers and hoping that they just replace the phone. That would fix all of my issues (including the cracked screen ). Now, I have to wait 5-7 business days before I know if I'm going to be stuck without a Galaxy phone or if I'm going to get a new phone straight from the factory. Who knows? As of now, I am using my old LG G3 Vigor temporarily while Samsung looks at my phone.

TL;DR: If you are on the Sprint network, have a Samsung Galaxy S8, model sm-g950u, US variant, ATTEMPT ROOTING AT YOUR OWN RISK! Sprint apparently has some pretty intense software locks on their phones which is rather unfortunate seeing as I believe Android to be an open-source and modifiable OS. Basically, we have to use the phone as it is from Sprint or we can't use it all. This is unacceptable.

I will update this post with any new information as it becomes available.

Links
26th November 2019, 07:53 AM |#2  
Senior Member
Thanks Meter: 309
 
More
Before rooting, flash it with the unbranded "U1" firmware which is much cleaner (bloat free), and also works on all carriers as long as the sim lock is unlocked.
26th November 2019, 09:26 AM |#3  
HisEvilness's Avatar
Junior Member
Straight out of Vlissingen
Thanks Meter: 7
 
Donate to Me
More
I just use the regular Odin and flash TWRP for the correct Samsung device then find a nice custom ROM you can install using TWRP I wrote several guides for it using Samsung phones, A3(2017, A5(2017, A7(2017, A5(2014, J8(2018 other than the button sequence for DL/recovery it is pretty much works the same, installing a stock ROM I did with Odin but finding a good stock ROM that you can download at a decent pace is harder. The OEM unlock is under Dev option in your phone though combined with USB debugging so you would need to do that before using Odin. But I get where you are coming from most guides are confusing as hell.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes