FORUMS

Blackview BV9800 PRO Rugged Beast MAGISK ROOT REQUIRED

83 posts
Thanks Meter: 5
 
By LGZACRO, Member on 13th February 2020, 03:10 PM
Post Reply Email Thread
18th February 2020, 03:54 PM |#11  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by LGZACRO

Oh man... Sounds bad... have You emailed blackview after sale support (via email, not forum)? No response from them?

And let's say I only root my BV9800Pro, will I be able to send You the files You need?

make total firmware dump and send the bakup , or nvram.bin nvdata.bin file,
18th February 2020, 04:15 PM |#12  
OP Member
Thanks Meter: 5
 
More
I must root to be able ro do this, right? Does TWRP works well on BV9800Pro?
18th February 2020, 04:24 PM |#13  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by LGZACRO

I must root to be able ro do this, right? Does TWRP works well on BV9800Pro?

i dont now. i dont install twrp.
18th February 2020, 04:28 PM |#14  
OP Member
Thanks Meter: 5
 
More
Ok, pm me your skype or signal or wickr or fb. We will try to do this in few hours
19th February 2020, 01:35 PM |#15  
Member
Thanks Meter: 13
 
More
Quote:
Originally Posted by LGZACRO

Oh man... Sounds bad... have You emailed blackview after sale support (via email, not forum)? No response from them?

And let's say I only root my BV9800Pro, will I be able to send You the files You need?

I posted in their forum a detailed error report but the moderator deleted my post.
Don't bargain for help by them.

---------- Post added at 02:35 PM ---------- Previous post was at 02:33 PM ----------

Quote:
Originally Posted by LGZACRO

I must root to be able ro do this, right? Does TWRP works well on BV9800Pro?

As I mention there's no TWRP available for this phone yet.
20th February 2020, 04:38 AM |#16  
Junior Member
Thanks Meter: 3
 
More
I just rooted BV9800 pro yesterday.
You don't need to SP flash tool or others, just need adb and fastboot.
Quick steps:
1. set OEM unlock to allow
2. connect phone to windows
3. use adb to check if connecting. command: adb devices
4. using adb to reboot to bootloader, command: adb reboot bootloader
5. And then the phone will enter fastboot mode ( you could see small string at left bottom corner)
6. use fastboot command to unlock bootloader. command: fastboot flashing unlock
7. If fastboot program is waiting, please check windows device manager, there should be an unknown device, let windows search driver automatically. it needs android interface driver.
8.Using volume up or down to agree unlock.
9. If agree, all data will be disappeared.
10. Install Magisk manger
11. Download stock ROM from blackview forum. it is zip file. Unzip it and copy boot-verified.img to phone.
12. patch boot.img by Magisk manger.
13. Copy patch image file to windows
14. use adb to reboot phone to fastboot mode
15. reflash boot image file. command: fastboot flash boot patched file name (normally, I would put patch image file in the same folder of fastboot)
16. reboot (fastboot reboot) and reinstall Magisk manager

There are many Magisk root steps instruction in internet. You could refer to other steps, they should be clear than mine. I prepared lots of drivers and application. Finally, I only used adb and fastboot to root this phone.
Attached Thumbnails
Click image for larger version

Name:	IMG_20200220_121124.jpg
Views:	176
Size:	96.7 KB
ID:	4954599  
The Following 2 Users Say Thank You to james35888 For This Useful Post: [ View ] Gift james35888 Ad-Free
20th February 2020, 05:28 AM |#17  
OP Member
Thanks Meter: 5
 
More
I rooted it exactly like You and it worked perfectly! Thanks for auch detailed rooting guide!

By the way guys, I think we Should open the request for TWRP for BV9800Pro. How do You think?
6th March 2020, 04:20 AM |#18  
Junior Member
Thanks Meter: 3
 
More
After you unlocked bootloader, it changed to orange state, and it always shows "Your device has been unlocked and can't be trusted..Your device will boot in 5 seconds", it could be resolved by modified LK image.
Refer to
1. https://forum.hovatek.com/thread-31664.html
2. http://bbs.blackview.hk/viewtopic.php?f=286&t=532899 -- included modified LK image

Of course, you could reflash by fastboot, no need to use SP flash tool.
20th May 2020, 03:53 AM |#19  
Junior Member
Thanks Meter: 5
 
More
hi if u have back up on your phone could u provide for me link. I had some problems with my loudspeaker and i thought its from the root, or software and i did full format and download. and now it show some watermark and probably is because i l deleted NVRAM.
i download already official version but didn't help ... thank u upfront.

Quote:
Originally Posted by james35888

I just rooted BV9800 pro yesterday.
You don't need to SP flash tool or others, just need adb and fastboot.
Quick steps:
1. set OEM unlock to allow
2. connect phone to windows
3. use adb to check if connecting. command: adb devices
4. using adb to reboot to bootloader, command: adb reboot bootloader
5. And then the phone will enter fastboot mode ( you could see small string at left bottom corner)
6. use fastboot command to unlock bootloader. command: fastboot flashing unlock
7. If fastboot program is waiting, please check windows device manager, there should be an unknown device, let windows search driver automatically. it needs android interface driver.
8.Using volume up or down to agree unlock.
9. If agree, all data will be disappeared.
10. Install Magisk manger
11. Download stock ROM from blackview forum. it is zip file. Unzip it and copy boot-verified.img to phone.
12. patch boot.img by Magisk manger.
13. Copy patch image file to windows
14. use adb to reboot phone to fastboot mode
15. reflash boot image file. command: fastboot flash boot patched file name (normally, I would put patch image file in the same folder of fastboot)
16. reboot (fastboot reboot) and reinstall Magisk manager

There are many Magisk root steps instruction in internet. You could refer to other steps, they should be clear than mine. I prepared lots of drivers and application. Finally, I only used adb and fastboot to root this phone.

20th May 2020, 08:25 AM |#20  
Junior Member
Flag Seattle
Thanks Meter: 2
 
More
Quote:
Originally Posted by zlatkomas

hi if u have back up on your phone could u provide for me link. I had some problems with my loudspeaker and i thought its from the root, or software and i did full format and download. and now it show some watermark and probably is because i l deleted NVRAM.
i download already official version but didn't help ... thank u upfront.

Hi, I'm not rooted (yet) and my BV9800 PRO is having some issues with the loudspeaker, any media like YouTube or Spotify, play audio for a second or two and then just go mute, volume can be high but no audio at all, phone calls last longer but also go mute and have to go back to regular "ear-speaker" to keep listen to the other side. Are this the same problems you refer to? I can't remember if this happened after the OTA update tho. Thank you.
20th May 2020, 09:53 AM |#21  
Junior Member
Thanks Meter: 5
 
More
Hi, rooted and installed twrp successful. In the beginning i thought from that could be the problem for the loudspeaker.and i factory restarted, and the sound come back with full potential,but it was last few day that pleasure and it started again. And i decided to download full rom and format fully and hopefully the problem will be solved. But it didn't. First i thought its software bug, second i thought the speaker need replacement. And if i replaced it won't solved the problem. Today i just sorted my problem.

How(my way how it solved the problem) i had that months this problem with the loudspeaker and i ordered new loudspeaker but i couldn't be patient and wait it.
1. j need to open your phone until u get to the speaker check youtube video how to do it.
2. U need some soldering knowledge and equipment.
I just applied a tiny bit of little Lead Flux Cored Solder on speaker connectors and assembled it.
Probably it was bad connection between the loudspeaker and the mainboard. If it continues same problem i recommend soldering with wire and it would be permanently solved.
Just to remain u u don't need removed the speaker from the back case, if u do that u will need some supper glue to put it back.
Soon i will upload some pics and video what i did and i hopefully u will find my explanation useful and solved the problem with many of you have same problem like mine. And i hope someone could help and send me a their backup, On my phone still show with this watermark Google and TEE on right top corner of the screen with some Chinese red letters: which means probably unregistered google or something after my full format
Thanks u and good luck.
Quote:
Originally Posted by vinko2000

Hi, I'm not rooted (yet) and my BV9800 PRO is having some issues with the loudspeaker, any media like YouTube or Spotify, play audio for a second or two and then just go mute, volume can be high but no audio at all, phone calls last longer but also go mute and have to go back to regular "ear-speaker" to keep listen to the other side. Are this the same problems you refer to? I can't remember if this happened after the OTA update tho. Thank you.

The Following User Says Thank You to zlatkomas For This Useful Post: [ View ] Gift zlatkomas Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes